diff mbox series

[1/1] package/gpm: fix musl build with gcc 14

Message ID 20240518091707.267692-1-fontaine.fabrice@gmail.com
State New
Headers show
Series [1/1] package/gpm: fix musl build with gcc 14 | expand

Commit Message

Fabrice Fontaine May 18, 2024, 9:17 a.m. UTC
Fix the following musl build failure with gcc 14:

daemon/old_main.c: In function 'old_main':
daemon/old_main.c:56:11: error: implicit declaration of function 'strcmp' [-Wimplicit-function-declaration]
   56 |       if(!strcmp((which_mouse->opt_dev),"-")) fd=0; /* use stdin */
      |           ^~~~~~
daemon/old_main.c:35:1: note: include '<string.h>' or provide a declaration of 'strcmp'
   34 | #include "headers/gpmInt.h"         /* daemon internals */
  +++ |+#include <string.h>
   35 |

While at it, add Upstream tags to other patches

Fixes:
 - http://autobuild.buildroot.org/results/3192740863d57e72e90e622683e7b9fcc057fa8b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .checkpackageignore                           |  6 -----
 ...usl-support-to-libgpm-and-the-daemon.patch |  4 +--
 .../0002-Install-unversioned-solibrary.patch  |  4 +--
 ...Really-install-unversioned-solibrary.patch |  3 +--
 ...mptyset-API-instead-of-__sigemptyset.patch |  1 +
 .../gpm/0005-fix-building-w-newer-glibc.patch |  1 +
 ...on.h-avoid-redefinition-of-last_sele.patch |  1 +
 package/gpm/0007-Add-include-string-h.patch   | 27 +++++++++++++++++++
 8 files changed, 33 insertions(+), 14 deletions(-)
 create mode 100644 package/gpm/0007-Add-include-string-h.patch
diff mbox series

Patch

diff --git a/.checkpackageignore b/.checkpackageignore
index 070b97116a..ab792709b2 100644
--- a/.checkpackageignore
+++ b/.checkpackageignore
@@ -748,12 +748,6 @@  package/gob2/0001-dont-include-from-prefix.patch lib_patch.Upstream
 package/gobject-introspection/0001-disable-tests.patch lib_patch.Upstream
 package/gobject-introspection/0002-Add-rpath-links-to-ccompiler.patch lib_patch.Upstream
 package/gobject-introspection/0003-giscanner-ignore-error-return-codes-from-ldd-wrapper.patch lib_patch.Upstream
-package/gpm/0001-Added-musl-support-to-libgpm-and-the-daemon.patch lib_patch.Upstream
-package/gpm/0002-Install-unversioned-solibrary.patch lib_patch.Upstream
-package/gpm/0003-src-Makefile.in-Really-install-unversioned-solibrary.patch lib_patch.Upstream
-package/gpm/0004-Use-sigemptyset-API-instead-of-__sigemptyset.patch lib_patch.Upstream
-package/gpm/0005-fix-building-w-newer-glibc.patch lib_patch.Upstream
-package/gpm/0006-src-headers-daemon.h-avoid-redefinition-of-last_sele.patch lib_patch.Upstream
 package/gpsd/S50gpsd Shellcheck lib_sysv.Indent lib_sysv.Variables
 package/gptfdisk/0001-gptcurses-partially-revert-Tweaks-for-building-on-th.patch lib_patch.Upstream
 package/graphite2/0001-don-t-install-a-libtool-file-with-static-library.patch lib_patch.Upstream
diff --git a/package/gpm/0001-Added-musl-support-to-libgpm-and-the-daemon.patch b/package/gpm/0001-Added-musl-support-to-libgpm-and-the-daemon.patch
index 1e1e919416..1e143e5031 100644
--- a/package/gpm/0001-Added-musl-support-to-libgpm-and-the-daemon.patch
+++ b/package/gpm/0001-Added-musl-support-to-libgpm-and-the-daemon.patch
@@ -3,9 +3,7 @@  From: Dima Krasner <dima@dimakrasner.com>
 Date: Wed, 12 Nov 2014 23:06:46 +0200
 Subject: [PATCH] Added musl support to libgpm and the daemon.
 
-[Upstream patch backported from the github repository,
-https://github.com/telmich/gpm/commit/d88fb1de5803c366ab62f7de9ee5d83207fb2afe.]
-
+Upstream: https://github.com/telmich/gpm/commit/d88fb1de5803c366ab62f7de9ee5d83207fb2afe
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 ---
  src/daemon/open_console.c  | 1 +
diff --git a/package/gpm/0002-Install-unversioned-solibrary.patch b/package/gpm/0002-Install-unversioned-solibrary.patch
index 27e97acb32..5f184daba2 100644
--- a/package/gpm/0002-Install-unversioned-solibrary.patch
+++ b/package/gpm/0002-Install-unversioned-solibrary.patch
@@ -6,9 +6,7 @@  Subject: [PATCH] Install unversioned solibrary
 Unversioned solibraries are shipped with -devel packages in Linux
 distros. Generate and install it for the consistency.
 
-[Upstream patch backported from the github repository,
-https://github.com/telmich/gpm/commit/06b00d53d8bd513ad5d262dc94a016c6fbf2d3aa]
-
+Upstream: https://github.com/telmich/gpm/commit/06b00d53d8bd513ad5d262dc94a016c6fbf2d3aa
 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 ---
  src/Makefile.in | 7 +++----
diff --git a/package/gpm/0003-src-Makefile.in-Really-install-unversioned-solibrary.patch b/package/gpm/0003-src-Makefile.in-Really-install-unversioned-solibrary.patch
index 2591801976..857bb5c2ba 100644
--- a/package/gpm/0003-src-Makefile.in-Really-install-unversioned-solibrary.patch
+++ b/package/gpm/0003-src-Makefile.in-Really-install-unversioned-solibrary.patch
@@ -7,8 +7,7 @@  This commit is a follow-up to
 https://github.com/telmich/gpm/commit/06b00d53d8bd513ad5d262dc94a016c6fbf2d3aa
 which created libgpm.so but failed to include it in the install target.
 
-Patch sent upstream: https://github.com/telmich/gpm/pull/11
-
+Upstream: https://github.com/telmich/gpm/pull/11
 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 ---
  src/Makefile.in | 1 +
diff --git a/package/gpm/0004-Use-sigemptyset-API-instead-of-__sigemptyset.patch b/package/gpm/0004-Use-sigemptyset-API-instead-of-__sigemptyset.patch
index 01c7424a9d..5820d21f51 100644
--- a/package/gpm/0004-Use-sigemptyset-API-instead-of-__sigemptyset.patch
+++ b/package/gpm/0004-Use-sigemptyset-API-instead-of-__sigemptyset.patch
@@ -7,6 +7,7 @@  __sigemptyset has been removed from glibc public
 API headers in upcoming (2.26) release onwards
 
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream: https://github.com/telmich/gpm/commit/fdc42770596e25749f7e2ce0ea97882177397167
 Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
 ---
  src/prog/gpm-root.y | 4 ----
diff --git a/package/gpm/0005-fix-building-w-newer-glibc.patch b/package/gpm/0005-fix-building-w-newer-glibc.patch
index b451d975e0..839f92f37b 100644
--- a/package/gpm/0005-fix-building-w-newer-glibc.patch
+++ b/package/gpm/0005-fix-building-w-newer-glibc.patch
@@ -7,6 +7,7 @@  Linux C libraries are looking to disentangle sysmacros.h from the
 sys/types.h include, so make sure we pull in the header when it is
 found.
 
+Upstream: https://github.com/telmich/gpm/commit/b350aee4ea5785a75cb6ad770f6b768c506ebb70
 Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
 ---
  src/daemon/open_console.c | 4 ++++
diff --git a/package/gpm/0006-src-headers-daemon.h-avoid-redefinition-of-last_sele.patch b/package/gpm/0006-src-headers-daemon.h-avoid-redefinition-of-last_sele.patch
index 36a8ddc5bb..0c8428df2c 100644
--- a/package/gpm/0006-src-headers-daemon.h-avoid-redefinition-of-last_sele.patch
+++ b/package/gpm/0006-src-headers-daemon.h-avoid-redefinition-of-last_sele.patch
@@ -20,6 +20,7 @@  https://gcc.gnu.org/PR85678.
 The error also happens if CFLAGS=-fno-common passed explicitly.
 
 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Upstream: https://github.com/telmich/gpm/commit/f04f24dd5ca5c1c13608b144ab66e2ccd47f106a
 Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
 ---
  src/headers/daemon.h | 2 +-
diff --git a/package/gpm/0007-Add-include-string-h.patch b/package/gpm/0007-Add-include-string-h.patch
new file mode 100644
index 0000000000..dd7e736e7b
--- /dev/null
+++ b/package/gpm/0007-Add-include-string-h.patch
@@ -0,0 +1,27 @@ 
+From 2085cab74a0a84df8b965addf007775a7225c9ec Mon Sep 17 00:00:00 2001
+From: Kurt Nalty <46026992+kurtnalty@users.noreply.github.com>
+Date: Sat, 29 Dec 2018 23:47:17 -0600
+Subject: [PATCH] Add include <string.h>
+
+Added
+ line 28, #include <string.h>                 /* strcpy, bzero     */
+for musl compilation
+
+Upstream: https://github.com/telmich/gpm/commit/2085cab74a0a84df8b965addf007775a7225c9ec
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ src/daemon/old_main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/daemon/old_main.c b/src/daemon/old_main.c
+index 2581e26..ab7a87f 100644
+--- a/src/daemon/old_main.c
++++ b/src/daemon/old_main.c
+@@ -25,6 +25,7 @@
+ #include <signal.h>                 /* guess again       */
+ #include <errno.h>                  /* guess again       */
+ #include <unistd.h>                 /* unlink            */
++#include <string.h>                 /* strcpy, bzero     */
+ #include <sys/stat.h>               /* chmod             */
+
+ #include <linux/kd.h>               /* linux hd*         */