diff mbox series

[v2,1/3] package/json-glib: add host build

Message ID 20240517173140.24531-2-jarkko@kernel.org
State Changes Requested
Headers show
Series swtpm and libtpms host packages | expand

Commit Message

Jarkko Sakkinen May 17, 2024, 5:31 p.m. UTC
Signed-off-by: Jarkko Sakkinen <jarkko@kernel.org>
---
v2:
- Disable GOI and NLS for the host.
- Add the missing host config.
---
 package/json-glib/Config.in    | 9 +++++++++
 package/json-glib/json-glib.mk | 5 +++++
 2 files changed, 14 insertions(+)

--
2.45.0

Comments

Yann E. MORIN May 17, 2024, 6:35 p.m. UTC | #1
Jarkko, All,

On 2024-05-17 20:31 +0300, Jarkko Sakkinen spake thusly:
> Signed-off-by: Jarkko Sakkinen <jarkko@kernel.org>
> ---
> v2:
> - Disable GOI and NLS for the host.

I think your forgot the GOI part [0]...

> - Add the missing host config.

Err, I was probably not explicit enough in my previous review: there is
no need for a Kconfig option for host packages, when they only provide a
library.

Also see below...

> ---
>  package/json-glib/Config.in    | 9 +++++++++
>  package/json-glib/json-glib.mk | 5 +++++
>  2 files changed, 14 insertions(+)
> 
> diff --git a/package/json-glib/Config.in b/package/json-glib/Config.in
> index 9df03d924a..ebf697bc64 100644
> --- a/package/json-glib/Config.in
> +++ b/package/json-glib/Config.in
> @@ -11,6 +11,15 @@ config BR2_PACKAGE_JSON_GLIB
> 
>  	  https://live.gnome.org/JsonGlib/
> 
> +config BR2_HOST_PACKAGE_JSON_GLIB

The actual Kconfig symbol should be BR2_PACKAGE_HOST_JSON_GLIB (note the
inversion between PACKAGE and HOST). You can catch such mis-naming by
running the basic sanity checks:

    $ ./utils/docker-run make check-package
    package/json-glib/Config.in:14: BR2_HOST_PACKAGE_JSON_GLIB defined but not referenced

Also, Kconfig entries for host packages should be in a separate
Config.in.host.

But in this case, there is no need for a Kconfig symbol, because
json-glib only provides a library, so you only need the changes in
json-glib.mk.

> +	bool "json-glib"
> +	help
> +	  JSON-GLib is a library providing serialization and
> +	  deserialization support for the JavaScript Object Notation
> +	  (JSON) format described by RFC 4627.
> +
> +	  https://live.gnome.org/JsonGlib/
> +
>  comment "json-glib needs a toolchain w/ wchar, threads"
>  	depends on BR2_USE_MMU
>  	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
> diff --git a/package/json-glib/json-glib.mk b/package/json-glib/json-glib.mk
> index cd53f24cee..a6bc53b823 100644
> --- a/package/json-glib/json-glib.mk
> +++ b/package/json-glib/json-glib.mk
> @@ -18,6 +18,10 @@ JSON_GLIB_DEPENDENCIES = \
>  	host-pkgconf \
>  	libglib2
> 
> +HOST_JSON_GLIB_DEPENDENCIES = \
> +	host-pkgconf \
> +	host-libglib2

...[0] I think you forgot:

    HOST_JSON_GLIB_CONF_OPTS = -Dintrospection=diabled

Regards,
Yann E. MORIN.

>  ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
>  JSON_GLIB_CONF_OPTS += -Dintrospection=enabled
>  JSON_GLIB_DEPENDENCIES += gobject-introspection
> @@ -34,3 +38,4 @@ endif
>  JSON_GLIB_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
> 
>  $(eval $(meson-package))
> +$(eval $(host-meson-package))
> --
> 2.45.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/json-glib/Config.in b/package/json-glib/Config.in
index 9df03d924a..ebf697bc64 100644
--- a/package/json-glib/Config.in
+++ b/package/json-glib/Config.in
@@ -11,6 +11,15 @@  config BR2_PACKAGE_JSON_GLIB

 	  https://live.gnome.org/JsonGlib/

+config BR2_HOST_PACKAGE_JSON_GLIB
+	bool "json-glib"
+	help
+	  JSON-GLib is a library providing serialization and
+	  deserialization support for the JavaScript Object Notation
+	  (JSON) format described by RFC 4627.
+
+	  https://live.gnome.org/JsonGlib/
+
 comment "json-glib needs a toolchain w/ wchar, threads"
 	depends on BR2_USE_MMU
 	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/json-glib/json-glib.mk b/package/json-glib/json-glib.mk
index cd53f24cee..a6bc53b823 100644
--- a/package/json-glib/json-glib.mk
+++ b/package/json-glib/json-glib.mk
@@ -18,6 +18,10 @@  JSON_GLIB_DEPENDENCIES = \
 	host-pkgconf \
 	libglib2

+HOST_JSON_GLIB_DEPENDENCIES = \
+	host-pkgconf \
+	host-libglib2
+
 ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
 JSON_GLIB_CONF_OPTS += -Dintrospection=enabled
 JSON_GLIB_DEPENDENCIES += gobject-introspection
@@ -34,3 +38,4 @@  endif
 JSON_GLIB_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)

 $(eval $(meson-package))
+$(eval $(host-meson-package))