diff mbox series

[v2] package/frotz: fix build with gcc 14

Message ID 20240517082007.312904-1-huth@tuxfamily.org
State New
Headers show
Series [v2] package/frotz: fix build with gcc 14 | expand

Commit Message

Thomas Huth May 17, 2024, 8:20 a.m. UTC
Change -std=c99 into -std=gnu99 in the CFLAGS to avoid the following
build failure with gcc 14:

fastmem.c: In function 'z_restore':
fastmem.c:842:36: error: implicit declaration of function 'strdup'; did you mean 'strcmp'? [-Wimplicit-function-declaration]
  842 |                 f_setup.aux_name = strdup(default_name);
      |                                    ^~~~~~
      |                                    strcmp

Fixes:
 - http://autobuild.buildroot.org/results/df3b3b98265ec3a75578614746b2d1426c90e125

Reported-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Huth <huth@tuxfamily.org>
---
 v2: Use gnu99 instead of removing c99

 package/frotz/frotz.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/frotz/frotz.mk b/package/frotz/frotz.mk
index 5af235137c..4c477c396d 100644
--- a/package/frotz/frotz.mk
+++ b/package/frotz/frotz.mk
@@ -21,7 +21,7 @@  endif
 define FROTZ_BUILD_CMDS
 	$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) PREFIX=/usr CONFIG_DIR=/etc \
 		SOUND_TYPE=none CURSES="$(FROTZ_CURSES)" USE_UTF8=$(FROTZ_UTF8) \
-		CFLAGS="$(TARGET_CFLAGS) -std=c99"
+		CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
 endef
 
 define FROTZ_INSTALL_TARGET_CMDS