diff mbox series

[1/1] package/syslog-ng: fix libcurl build without C++

Message ID 20240515162501.1086749-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/syslog-ng: fix libcurl build without C++ | expand

Commit Message

Fabrice Fontaine May 15, 2024, 4:25 p.m. UTC
Fix the following libcurl build failure without C++ raised since bump to
version 4.7.1 in commit 105f0398c76f3288b2668e0b3ec722b2ebe55a0b and
https://github.com/syslog-ng/syslog-ng/commit/86feed7bff068a48be477a5b702ca24abc441d70:

configure: error: C++ support is mandatory when the cloud-auth module is enabled.

Fixes: 105f0398c76f3288b2668e0b3ec722b2ebe55a0b
 - http://autobuild.buildroot.org/results/cf36fb119224ba50a768dbe363d4c381f76eb476

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/syslog-ng/syslog-ng.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle June 6, 2024, 7:29 p.m. UTC | #1
On 15/05/2024 18:25, Fabrice Fontaine wrote:
> Fix the following libcurl build failure without C++ raised since bump to
> version 4.7.1 in commit 105f0398c76f3288b2668e0b3ec722b2ebe55a0b and
> https://github.com/syslog-ng/syslog-ng/commit/86feed7bff068a48be477a5b702ca24abc441d70:
> 
> configure: error: C++ support is mandatory when the cloud-auth module is enabled.
> 
> Fixes: 105f0398c76f3288b2668e0b3ec722b2ebe55a0b
>   - http://autobuild.buildroot.org/results/cf36fb119224ba50a768dbe363d4c381f76eb476
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/syslog-ng/syslog-ng.mk | 7 ++++++-
>   1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/package/syslog-ng/syslog-ng.mk b/package/syslog-ng/syslog-ng.mk
> index 4f9a455e81..57ee46ce05 100644
> --- a/package/syslog-ng/syslog-ng.mk
> +++ b/package/syslog-ng/syslog-ng.mk
> @@ -61,8 +61,13 @@ endif
>   
>   ifeq ($(BR2_PACKAGE_LIBCURL),y)
>   SYSLOG_NG_DEPENDENCIES += libcurl
> -SYSLOG_NG_CONF_OPTS += --enable-http --enable-cloud-auth
> +SYSLOG_NG_CONF_OPTS += --enable-http
>   SYSLOG_NG_CONF_OPTS += --with-libcurl="$(STAGING_DIR)/usr"
> +ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
> +SYSLOG_NG_CONF_OPTS += --enable-cloud-auth
> +else
> +SYSLOG_NG_CONF_OPTS += --disable-cloud-auth
> +endif
>   else
>   SYSLOG_NG_CONF_OPTS += --disable-http --disable-cloud-auth
>   endif
diff mbox series

Patch

diff --git a/package/syslog-ng/syslog-ng.mk b/package/syslog-ng/syslog-ng.mk
index 4f9a455e81..57ee46ce05 100644
--- a/package/syslog-ng/syslog-ng.mk
+++ b/package/syslog-ng/syslog-ng.mk
@@ -61,8 +61,13 @@  endif
 
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
 SYSLOG_NG_DEPENDENCIES += libcurl
-SYSLOG_NG_CONF_OPTS += --enable-http --enable-cloud-auth
+SYSLOG_NG_CONF_OPTS += --enable-http
 SYSLOG_NG_CONF_OPTS += --with-libcurl="$(STAGING_DIR)/usr"
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+SYSLOG_NG_CONF_OPTS += --enable-cloud-auth
+else
+SYSLOG_NG_CONF_OPTS += --disable-cloud-auth
+endif
 else
 SYSLOG_NG_CONF_OPTS += --disable-http --disable-cloud-auth
 endif