diff mbox series

[1/1] package/gnuplot: fix readline dependency

Message ID 20240514173919.318237-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gnuplot: fix readline dependency | expand

Commit Message

Fabrice Fontaine May 14, 2024, 5:39 p.m. UTC
--without-readline is interpreted as --with-readline=builtin since bump
to version 5.4.0 in commit 263da09323e83bb3d6552b70b739523b66459df8 and
https://github.com/gnuplot/gnuplot/commit/b492ea63bd604081ffb9dee3843e295b0b29df85
so add a mandatory dependency to readline or libedit to gnuplot

As a side-effect, this will avoid the following build failure with
builtin readline raised since bump to version 6.0.0 in commit
5f11ce4aeaba99917778c384b236d267e78a7b29:

/home/autobuild/autobuild/instance-14/output-1/host/lib/gcc/arm-buildroot-linux-gnueabi/13.2.0/../../../../arm-buildroot-linux-gnueabi/bin/ld: history.o: in function `read_history':
history.c:(.text+0xa8): undefined reference to `gp_read_history'

Fixes: 5f11ce4aeaba99917778c384b236d267e78a7b29
 - http://autobuild.buildroot.org/results/5e45dd8f9071694110c8481f222b9b07b6a97ef3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gnuplot/Config.in  | 1 +
 package/gnuplot/gnuplot.mk | 5 +++--
 2 files changed, 4 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard May 15, 2024, 6:11 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > --without-readline is interpreted as --with-readline=builtin since bump
 > to version 5.4.0 in commit 263da09323e83bb3d6552b70b739523b66459df8 and
 > https://github.com/gnuplot/gnuplot/commit/b492ea63bd604081ffb9dee3843e295b0b29df85
 > so add a mandatory dependency to readline or libedit to gnuplot

 > As a side-effect, this will avoid the following build failure with
 > builtin readline raised since bump to version 6.0.0 in commit
 > 5f11ce4aeaba99917778c384b236d267e78a7b29:

 > /home/autobuild/autobuild/instance-14/output-1/host/lib/gcc/arm-buildroot-linux-gnueabi/13.2.0/../../../../arm-buildroot-linux-gnueabi/bin/ld:
 > history.o: in function `read_history':
 > history.c:(.text+0xa8): undefined reference to `gp_read_history'

 > Fixes: 5f11ce4aeaba99917778c384b236d267e78a7b29
 >  - http://autobuild.buildroot.org/results/5e45dd8f9071694110c8481f222b9b07b6a97ef3

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/gnuplot/Config.in b/package/gnuplot/Config.in
index 603c194fe5..8068a7283b 100644
--- a/package/gnuplot/Config.in
+++ b/package/gnuplot/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_GNUPLOT
 	bool "gnuplot"
+	select BR2_PACKAGE_READLINE if !BR2_PACKAGE_LIBEDIT
 	help
 	  A portable command-line driven graphing utility.
 
diff --git a/package/gnuplot/gnuplot.mk b/package/gnuplot/gnuplot.mk
index 26b2daaf24..e34dd2a60b 100644
--- a/package/gnuplot/gnuplot.mk
+++ b/package/gnuplot/gnuplot.mk
@@ -41,8 +41,9 @@  endif
 ifeq ($(BR2_PACKAGE_READLINE),y)
 GNUPLOT_CONF_OPTS += --with-readline=gnu
 GNUPLOT_DEPENDENCIES += readline
-else
-GNUPLOT_CONF_OPTS += --without-readline
+else ifeq ($(BR2_PACKAGE_LIBEDIT),y)
+GNUPLOT_CONF_OPTS += --with-readline=bsd
+GNUPLOT_DEPENDENCIES += libedit
 endif
 
 # Remove Javascript scripts, lua scripts, PostScript files