diff mbox series

[1/1] package/libp11: fix enginesdir

Message ID 20240509204218.77779-1-fontaine.fabrice@gmail.com
State New
Headers show
Series [1/1] package/libp11: fix enginesdir | expand

Commit Message

Fabrice Fontaine May 9, 2024, 8:42 p.m. UTC
pkg-config doesn't return a libcrypto enginesdir prefixed with the
sysroot so drop unneeded call to xargs, readlink and sed

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libp11/libp11.mk | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Thomas Petazzoni May 9, 2024, 9:10 p.m. UTC | #1
On Thu,  9 May 2024 22:42:18 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> pkg-config doesn't return a libcrypto enginesdir prefixed with the
> sysroot so drop unneeded call to xargs, readlink and sed
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libp11/libp11.mk | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/package/libp11/libp11.mk b/package/libp11/libp11.mk
> index cd4ed34297..dc489758aa 100644
> --- a/package/libp11/libp11.mk
> +++ b/package/libp11/libp11.mk
> @@ -11,10 +11,8 @@ LIBP11_INSTALL_STAGING = YES
>  LIBP11_LICENSE = LGPL-2.1+
>  LIBP11_LICENSE_FILES = COPYING
>  
> -# pkg-config returns a libcrypto enginesdir prefixed with the sysroot,
> -# so let's rip it out.

Well, this workaround was here for a reason. Since when it is no longer
needed?

Thomas
diff mbox series

Patch

diff --git a/package/libp11/libp11.mk b/package/libp11/libp11.mk
index cd4ed34297..dc489758aa 100644
--- a/package/libp11/libp11.mk
+++ b/package/libp11/libp11.mk
@@ -11,10 +11,8 @@  LIBP11_INSTALL_STAGING = YES
 LIBP11_LICENSE = LGPL-2.1+
 LIBP11_LICENSE_FILES = COPYING
 
-# pkg-config returns a libcrypto enginesdir prefixed with the sysroot,
-# so let's rip it out.
 LIBP11_CONF_OPTS = \
-	--with-enginesdir=`$(PKG_CONFIG_HOST_BINARY) --variable enginesdir libcrypto | xargs readlink -f | sed 's%^$(STAGING_DIR)%%'`
+	--with-enginesdir=`$(PKG_CONFIG_HOST_BINARY) --variable enginesdir libcrypto`
 
 ifeq ($(BR2_PACKAGE_P11_KIT),y)
 LIBP11_CONF_OPTS += --with-pkcs11-module=/usr/lib/p11-kit-proxy.so