diff mbox series

[3/3] package/optee-client: bump to version 4.2.0

Message ID 20240509-optee-bumps-v1-3-fa2a6e1096a6@microchip.com
State Accepted
Headers show
Series Bump optee-{client, test, examples} packages to 4.2.0 | expand

Commit Message

Nayab Sayed May 9, 2024, 6:28 a.m. UTC
Bumps OP-TEE client package version to OP-TEE release 4.2.0.
Removes the local patch related to build failure as the changes are
integrated into mailine repository before 4.2.0.

Signed-off-by: Nayab Sayed <nayabbasha.sayed@microchip.com>
---
 ...tee-supplicant-fix-build-with-kernel-4.16.patch | 56 ----------------------
 package/optee-client/optee-client.hash             |  4 +-
 package/optee-client/optee-client.mk               |  2 +-
 3 files changed, 3 insertions(+), 59 deletions(-)
diff mbox series

Patch

diff --git a/package/optee-client/0001-tee-supplicant-fix-build-with-kernel-4.16.patch b/package/optee-client/0001-tee-supplicant-fix-build-with-kernel-4.16.patch
deleted file mode 100644
index fa51bd5d5e..0000000000
--- a/package/optee-client/0001-tee-supplicant-fix-build-with-kernel-4.16.patch
+++ /dev/null
@@ -1,56 +0,0 @@ 
-From acc5aec37f5f246ebf185d2129e7630eb80bb388 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Fri, 5 Jan 2024 09:47:43 +0100
-Subject: [PATCH] tee-supplicant: fix build with kernel < 4.16
-
-Commit 3ac968ee7c927271e83ea3a4247839649202ab5e moved linux/tee.h from
-libteec/include to libteec/src resulting in the following build failure
-with any kernel < 4.16 (i.e before
-https://github.com/torvalds/linux/commit/033ddf12bcf5326b93bd604f50a7474a434a35f9):
-
-/home/buildroot/autobuild/instance-3/output-1/build/optee-client-4.0.0/tee-supplicant/src/tee_supplicant.c: In function 'register_local_shm':
-/home/buildroot/autobuild/instance-3/output-1/build/optee-client-4.0.0/tee-supplicant/src/tee_supplicant.c:356:44: error: storage size of 'data' isn't known
-  356 |         struct tee_ioctl_shm_register_data data;
-      |                                            ^~~~
-
-To fix this build failure, update CMakeLists.txt and Makefile of
-tee-supplicant to add libteec/src to the include directories.
-
-Fixes: 3ac968ee7c92 ("Makefile, cmake: move teec related headers")
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Upstream: https://github.com/OP-TEE/optee_client/pull/369
----
- tee-supplicant/CMakeLists.txt | 5 ++++-
- tee-supplicant/Makefile       | 2 +-
- 2 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/tee-supplicant/CMakeLists.txt b/tee-supplicant/CMakeLists.txt
-index 31c6dac5..b44e9e95 100644
---- a/tee-supplicant/CMakeLists.txt
-+++ b/tee-supplicant/CMakeLists.txt
-@@ -93,7 +93,10 @@ endif()
- ################################################################################
- # Public and private header and library dependencies
- ################################################################################
--target_include_directories(${PROJECT_NAME} PRIVATE src)
-+target_include_directories(${PROJECT_NAME}
-+	PRIVATE src
-+	PRIVATE ../libteec/src
-+)
- 
- target_link_libraries(${PROJECT_NAME}
- 	PRIVATE teec
-diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
-index 06c4b2e5..c3b32252 100644
---- a/tee-supplicant/Makefile
-+++ b/tee-supplicant/Makefile
-@@ -40,7 +40,7 @@ TEES_OBJ_DIR	:= $(OUT_DIR)
- TEES_OBJS 	:= $(patsubst %.c,$(TEES_OBJ_DIR)/%.o, $(TEES_SRCS))
- TEES_INCLUDES 	:= ${CURDIR}/../libteec/include \
- 		   ${CURDIR}/src \
--		   ${CURDIR}/../libteec/include \
-+		   ${CURDIR}/../libteec/src \
- 
- TEES_CFLAGS	:= $(addprefix -I, $(TEES_INCLUDES)) $(CFLAGS) \
- 		   -DDEBUGLEVEL_$(CFG_TEE_SUPP_LOG_LEVEL) \
diff --git a/package/optee-client/optee-client.hash b/package/optee-client/optee-client.hash
index bb97820ab1..b0c6dfcb5e 100644
--- a/package/optee-client/optee-client.hash
+++ b/package/optee-client/optee-client.hash
@@ -1,4 +1,4 @@ 
-# From https://github.com/OP-TEE/optee_client/archive/4.0.0/optee-client-4.0.0.tar.gz
-sha256  bcdac9c3a9f2e93c64d114667cc6d1feddf9f978992cdc2d59745885f9bd8fbe  optee-client-4.0.0.tar.gz
+# From https://github.com/OP-TEE/optee_client/archive/4.2.0/optee-client-4.2.0.tar.gz
+sha256  ba0dad79cec2dabb7b6a6d3e391804f0184863ee9810e90bf97a392d3c1ad5eb  optee-client-4.2.0.tar.gz
 # Locally computed
 sha256  fda8385993f112d7ca61b88b54ba5b4cbeec7e43a0f9b317d5186703c1985e8f  LICENSE
diff --git a/package/optee-client/optee-client.mk b/package/optee-client/optee-client.mk
index 99c922a171..6600a9c4fc 100644
--- a/package/optee-client/optee-client.mk
+++ b/package/optee-client/optee-client.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-OPTEE_CLIENT_VERSION = 4.0.0
+OPTEE_CLIENT_VERSION = 4.2.0
 OPTEE_CLIENT_SITE = $(call github,OP-TEE,optee_client,$(OPTEE_CLIENT_VERSION))
 OPTEE_CLIENT_LICENSE = BSD-2-Clause
 OPTEE_CLIENT_LICENSE_FILES = LICENSE