diff mbox series

[1/1] package/igt-gpu-tools: disable chamelium

Message ID 20240508084918.472419-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/igt-gpu-tools: disable chamelium | expand

Commit Message

Fabrice Fontaine May 8, 2024, 8:49 a.m. UTC
Disable chamelium to avoid the following build failure if gsl is found
but not alsa-lib raised since the addition of the package in commit
d8a729d1731339da141612be33c5e59bc9928748:

In file included from ../lib/igt_audio.c:35:
../lib/igt_audio.h:35:10: fatal error: alsa/asoundlib.h: No such file or directory
   35 | #include <alsa/asoundlib.h>
      |          ^~~~~~~~~~~~~~~~~~

Fixes: d8a729d1731339da141612be33c5e59bc9928748
 - http://autobuild.buildroot.org/results/a7818af881d9aafa9a36f87dc7c882a6880554e8

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/igt-gpu-tools/igt-gpu-tools.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni May 8, 2024, 4:32 p.m. UTC | #1
On Wed,  8 May 2024 10:49:18 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Disable chamelium to avoid the following build failure if gsl is found
> but not alsa-lib raised since the addition of the package in commit
> d8a729d1731339da141612be33c5e59bc9928748:
> 
> In file included from ../lib/igt_audio.c:35:
> ../lib/igt_audio.h:35:10: fatal error: alsa/asoundlib.h: No such file or directory
>    35 | #include <alsa/asoundlib.h>
>       |          ^~~~~~~~~~~~~~~~~~
> 
> Fixes: d8a729d1731339da141612be33c5e59bc9928748
>  - http://autobuild.buildroot.org/results/a7818af881d9aafa9a36f87dc7c882a6880554e8
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/igt-gpu-tools/igt-gpu-tools.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/igt-gpu-tools/igt-gpu-tools.mk b/package/igt-gpu-tools/igt-gpu-tools.mk
index d4997c9c28..e3e7d4a896 100644
--- a/package/igt-gpu-tools/igt-gpu-tools.mk
+++ b/package/igt-gpu-tools/igt-gpu-tools.mk
@@ -23,7 +23,9 @@  IGT_GPU_TOOLS_DEPENDENCIES = \
 	udev \
 	zlib
 
-IGT_GPU_TOOLS_CONF_OPTS = -Dtests=disabled
+IGT_GPU_TOOLS_CONF_OPTS = \
+	-Dchamelium=disabled \
+	-Dtests=disabled
 
 # On x86 systems, libigt resolves igt_half_to_float and igt_float_to_half as
 # indirect functions at runtime by checking CPU features with igt_x86_features.