diff mbox series

configs/sheevaplug_defconfig: bump Linux to fix binutils 2.41 build

Message ID 20240505195943.176708-1-peter@korsgaard.com
State Changes Requested
Headers show
Series configs/sheevaplug_defconfig: bump Linux to fix binutils 2.41 build | expand

Commit Message

Peter Korsgaard May 5, 2024, 7:59 p.m. UTC
Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/6761770801

The Linux kernel fails to build since commit e88225ed882 (package/binutils:
make 2.41 the default version):

arch/arm/mm/proc-feroceon.S: Assembler messages:
arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
make[3]: *** Waiting for unfinished jobs....

Fix the build by bumping the kernel to 4.14.336, which includes commit
3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
directive):

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 configs/sheevaplug_defconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN May 5, 2024, 8:13 p.m. UTC | #1
Peter, All,

On 2024-05-05 21:59 +0200, Peter Korsgaard spake thusly:
> Fixes:
> https://gitlab.com/buildroot.org/buildroot/-/jobs/6761770801
> 
> The Linux kernel fails to build since commit e88225ed882 (package/binutils:
> make 2.41 the default version):
> 
> arch/arm/mm/proc-feroceon.S: Assembler messages:
> arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
> make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
> make[3]: *** Waiting for unfinished jobs....
> 
> Fix the build by bumping the kernel to 4.14.336, which includes commit
> 3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
> directive):
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

As I recently explained to other such patches [0] [1], please enable
BR2_DOWNLOAD_FORCE_CHECK_HASHES=y. Also, you're no stranger to this
topic, are you? ;-)

[0] https://lore.kernel.org/buildroot/ZjepViPtMWJL05DF@landeda/
[1] https://lore.kernel.org/buildroot/ZjeDWeQ-Jnutgk0G@landeda/

Regards,
Yann E. MORIN.

> ---
>  configs/sheevaplug_defconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/configs/sheevaplug_defconfig b/configs/sheevaplug_defconfig
> index 7f186df22c..0879f17071 100644
> --- a/configs/sheevaplug_defconfig
> +++ b/configs/sheevaplug_defconfig
> @@ -27,7 +27,7 @@ BR2_TARGET_UBOOT_FORMAT_KWB=y
>  # Kernel
>  BR2_LINUX_KERNEL=y
>  BR2_LINUX_KERNEL_CUSTOM_VERSION=y
> -BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.253"
> +BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.336"
>  BR2_LINUX_KERNEL_DEFCONFIG="mvebu_v5"
>  BR2_LINUX_KERNEL_APPENDED_UIMAGE=y
>  BR2_LINUX_KERNEL_UIMAGE_LOADADDR="0x8000"
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard May 6, 2024, 6:50 a.m. UTC | #2
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Peter, All,
 > On 2024-05-05 21:59 +0200, Peter Korsgaard spake thusly:
 >> Fixes:
 >> https://gitlab.com/buildroot.org/buildroot/-/jobs/6761770801
 >> 
 >> The Linux kernel fails to build since commit e88225ed882 (package/binutils:
 >> make 2.41 the default version):
 >> 
 >> arch/arm/mm/proc-feroceon.S: Assembler messages:
 >> arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
 >> make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
 >> make[3]: *** Waiting for unfinished jobs....
 >> 
 >> Fix the build by bumping the kernel to 4.14.336, which includes commit
 >> 3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
 >> directive):
 >> 
 >> https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331
 >> 
 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

 > As I recently explained to other such patches [0] [1], please enable
 > BR2_DOWNLOAD_FORCE_CHECK_HASHES=y. Also, you're no stranger to this
 > topic, are you? ;-)

True. Will fix and resend ;)
diff mbox series

Patch

diff --git a/configs/sheevaplug_defconfig b/configs/sheevaplug_defconfig
index 7f186df22c..0879f17071 100644
--- a/configs/sheevaplug_defconfig
+++ b/configs/sheevaplug_defconfig
@@ -27,7 +27,7 @@  BR2_TARGET_UBOOT_FORMAT_KWB=y
 # Kernel
 BR2_LINUX_KERNEL=y
 BR2_LINUX_KERNEL_CUSTOM_VERSION=y
-BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.253"
+BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.336"
 BR2_LINUX_KERNEL_DEFCONFIG="mvebu_v5"
 BR2_LINUX_KERNEL_APPENDED_UIMAGE=y
 BR2_LINUX_KERNEL_UIMAGE_LOADADDR="0x8000"