diff mbox series

[RESEND,v2,03/11] boot/ti-k3-r5-loader: bump to version v2024.04

Message ID 20240430-optee-update-v2-3-5bdc2f940db1@ti.com
State Accepted
Headers show
Series update bsp binaries for TI SoCs | expand

Commit Message

Bryan Brattlof May 2, 2024, 4:26 p.m. UTC
The ti-k3-r5-loader is just U-Boot with a different defconfig compiled
for the 32b MCU cores needed for TI's K3 generation of SoCs. Update to
match the U-Boot version

Signed-off-by: Bryan Brattlof <bb@ti.com>
---
 boot/ti-k3-r5-loader/Config.in            | 4 ++--
 boot/ti-k3-r5-loader/ti-k3-r5-loader.hash | 2 +-
 boot/ti-k3-r5-loader/ti-k3-r5-loader.mk   | 1 +
 3 files changed, 4 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni May 6, 2024, 8:11 p.m. UTC | #1
On Thu, 2 May 2024 11:26:53 -0500
Bryan Brattlof via buildroot <buildroot@buildroot.org> wrote:

>  TI_K3_R5_LOADER_VERSION = $(call qstrip,$(BR2_TARGET_TI_K3_R5_LOADER_VERSION))
> +TI_K3_R5_LOADER_DL_DIR = $(UBOOT_DL_DIR)

This is an unrelated change, so I dropped it from the commit when
applying.

Thomas
Bryan Brattlof May 8, 2024, 12:04 p.m. UTC | #2
On May  6, 2024 thus sayeth Thomas Petazzoni via buildroot:
> On Thu, 2 May 2024 11:26:53 -0500
> Bryan Brattlof via buildroot <buildroot@buildroot.org> wrote:
> 
> >  TI_K3_R5_LOADER_VERSION = $(call qstrip,$(BR2_TARGET_TI_K3_R5_LOADER_VERSION))
> > +TI_K3_R5_LOADER_DL_DIR = $(UBOOT_DL_DIR)
> 
> This is an unrelated change, so I dropped it from the commit when
> applying.
> 

Oops thank you. This was an errant fixup from a little experiment trying 
to tie together the ti-k3-r5-loaders and uboot. 

Thanks for catching it.

~Bryan
diff mbox series

Patch

diff --git a/boot/ti-k3-r5-loader/Config.in b/boot/ti-k3-r5-loader/Config.in
index df885cc2af601..2f2434e9db2a8 100644
--- a/boot/ti-k3-r5-loader/Config.in
+++ b/boot/ti-k3-r5-loader/Config.in
@@ -18,7 +18,7 @@  choice
 	  here as it is used to build the main U-Boot package.
 
 config BR2_TARGET_TI_K3_R5_LOADER_LATEST_VERSION
-	bool "2024.01"
+	bool "2024.04"
 
 config BR2_TARGET_TI_K3_R5_LOADER_CUSTOM_VERSION
 	bool "Custom version"
@@ -62,7 +62,7 @@  endif
 
 config BR2_TARGET_TI_K3_R5_LOADER_VERSION
 	string
-	default "2024.01"	if BR2_TARGET_TI_K3_R5_LOADER_LATEST_VERSION
+	default "2024.04"	if BR2_TARGET_TI_K3_R5_LOADER_LATEST_VERSION
 	default BR2_TARGET_TI_K3_R5_LOADER_CUSTOM_VERSION_VALUE \
 		if BR2_TARGET_TI_K3_R5_LOADER_CUSTOM_VERSION
 	default "custom"	if BR2_TARGET_TI_K3_R5_LOADER_CUSTOM_TARBALL
diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.hash b/boot/ti-k3-r5-loader/ti-k3-r5-loader.hash
index fbe5d215409d2..a8021fb696b1a 100644
--- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.hash
+++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3  u-boot-2024.01.tar.bz2
+sha256  18a853fe39fad7ad03a90cc2d4275aeaed6da69735defac3492b80508843dd4a  u-boot-2024.04.tar.bz2
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  Licenses/gpl-2.0.txt
diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
index 98a6d473f17f3..2ce053461038f 100644
--- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
+++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
@@ -5,6 +5,7 @@ 
 ################################################################################
 
 TI_K3_R5_LOADER_VERSION = $(call qstrip,$(BR2_TARGET_TI_K3_R5_LOADER_VERSION))
+TI_K3_R5_LOADER_DL_DIR = $(UBOOT_DL_DIR)
 
 ifeq ($(BR2_TARGET_TI_K3_R5_LOADER_CUSTOM_TARBALL),y)
 # Handle custom U-Boot tarballs as specified by the configuration