diff mbox series

[v1,7/8] package/gdk-pixbuf: fix reference to atomic

Message ID 20240420185853.4134260-7-thomas@devoogdt.com
State Changes Requested
Headers show
Series [v1,1/8] package/libsoup3: fix reference to atomic | expand

Commit Message

Thomas Devoogdt April 20, 2024, 6:58 p.m. UTC
gthread-posix.c:(.text+0x137c): undefined reference to `__atomic_compare_exchange_4'
collect2: error: ld returned 1 exit status

Signed-off-by: Thomas Devoogdt <thomas@devoogdt.com>
---
 package/gdk-pixbuf/gdk-pixbuf.mk | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
index e041d2cbde..9d272be382 100644
--- a/package/gdk-pixbuf/gdk-pixbuf.mk
+++ b/package/gdk-pixbuf/gdk-pixbuf.mk
@@ -31,6 +31,13 @@  HOST_GDK_PIXBUF_CONF_OPTS = \
 	-Drelocatable=true \
 	-Dman=false
 
+GDK_PIXBUF_LDFLAGS = $(TARGET_LDFLAGS)
+
+# Uses __atomic_compare_exchange_4
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+GDK_PIXBUF_LDFLAGS += -latomic
+endif
+
 ifeq ($(BR2_STATIC_LIBS),y)
 GDK_PIXBUF_CONF_OPTS += -Dbuiltin_loaders=all
 endif