diff mbox series

package/elfutils: fix host build failure due to missing demangle support

Message ID 20240418135615.457970-1-giulio.benetti@benettiengineering.com
State New
Headers show
Series package/elfutils: fix host build failure due to missing demangle support | expand

Commit Message

Giulio Benetti April 18, 2024, 1:56 p.m. UTC
When building on hosts with libstdc++ without demangle support this error
shows up:
checking for __cxa_demangle in -lstdc++... no
configure: error: __cxa_demangle not found in libstdc++, use --disable-demangler to disable demangler support.
make[1]: *** [package/pkg-generic.mk:273: /home/giuliobenetti/br_reproduce/c2524c7580d97f7387ec22da62be71d77f2ed8ec/output/build/host-elfutils-0.189/.stamp_configured] Error 1
make: *** [Makefile:23: _all] Error 2

So let's disable demangler for host by default.

Fixes: still not showed by autobuilders. Reproduced on Ubuntu 22.04 with
Ubuntu APT g++ 11.4.0

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/elfutils/elfutils.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Christian Stewart April 22, 2024, 1:24 a.m. UTC | #1
Hi Giulio, all,

> When building on hosts with libstdc++ without demangle support this error
> shows up:
> checking for __cxa_demangle in -lstdc++... no
> configure: error: __cxa_demangle not found in libstdc++, use --disable-demangler to disable demangler support.
> make[1]: *** [package/pkg-generic.mk:273: /home/giuliobenetti/br_reproduce/c2524c7580d97f7387ec22da62be71d77f2ed8ec/output/build/host-elfutils-0.189/.stamp_configured] Error 1
> make: *** [Makefile:23: _all] Error 2

> So let's disable demangler for host by default.

> Fixes: still not showed by autobuilders. Reproduced on Ubuntu 22.04 with
> Ubuntu APT g++ 11.4.0

> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> ---
>  package/elfutils/elfutils.mk | 1 +
>  1 file changed, 1 insertion(+)

> diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
> index 87b51aa5b5..4d8cc43342 100644
> --- a/package/elfutils/elfutils.mk
> +++ b/package/elfutils/elfutils.mk
> @@ -27,6 +27,7 @@ HOST_ELFUTILS_CONF_OPTS = \
>  	--with-bzlib \
>  	--with-lzma \
>  	--without-zstd \
> +	--disable-demangler \
>  	--disable-progs
> 
> ELFUTILS_LDFLAGS = $(TARGET_LDFLAGS) \

A user encountered this issue and reported it:

https://github.com/skiffos/SkiffOS/issues/311

Thanks!

Reviewed-by: Christian Stewart <christian@aperture.us>
diff mbox series

Patch

diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
index 87b51aa5b5..4d8cc43342 100644
--- a/package/elfutils/elfutils.mk
+++ b/package/elfutils/elfutils.mk
@@ -27,6 +27,7 @@  HOST_ELFUTILS_CONF_OPTS = \
 	--with-bzlib \
 	--with-lzma \
 	--without-zstd \
+	--disable-demangler \
 	--disable-progs
 
 ELFUTILS_LDFLAGS = $(TARGET_LDFLAGS) \