diff mbox series

package/petitboot: add libxcrypt optional dependency

Message ID 20240416144818.681220-1-arbab@linux.ibm.com
State New
Headers show
Series package/petitboot: add libxcrypt optional dependency | expand

Commit Message

Reza Arbab April 16, 2024, 2:48 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

  checking for crypt in -lcrypt... no
  configure: error: in `/home/arbab/src/buildroot/output/build/petitboot-1.15':
  configure: error: shadow/crypt libs required

Signed-off-by: Reza Arbab <arbab@linux.ibm.com>
---
 package/petitboot/Config.in    | 1 +
 package/petitboot/petitboot.mk | 1 +
 2 files changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/package/petitboot/Config.in b/package/petitboot/Config.in
index 533c7a9f2980..66836f31acd8 100644
--- a/package/petitboot/Config.in
+++ b/package/petitboot/Config.in
@@ -14,6 +14,7 @@  config BR2_PACKAGE_PETITBOOT
 	# run-time dependencies
 	select BR2_PACKAGE_KEXEC if !BR2_PACKAGE_KEXEC_LITE_ARCH_SUPPORTS
 	select BR2_PACKAGE_KEXEC_LITE if BR2_PACKAGE_KEXEC_LITE_ARCH_SUPPORTS && !BR2_PACKAGE_KEXEC
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_NVME if ( BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le )
 	select BR2_PACKAGE_POWERPC_UTILS if ( BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le )
 	help
diff --git a/package/petitboot/petitboot.mk b/package/petitboot/petitboot.mk
index cd7631fa5cae..2eb6461144cd 100644
--- a/package/petitboot/petitboot.mk
+++ b/package/petitboot/petitboot.mk
@@ -14,6 +14,7 @@  PETITBOOT_DEPENDENCIES = \
 	host-bison \
 	host-flex \
 	lvm2 \
+	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt) \
 	$(TARGET_NLS_DEPENDENCIES)
 PETITBOOT_LICENSE = GPL-2.0
 PETITBOOT_LICENSE_FILES = COPYING