diff mbox series

package/python-yamllint: fix dependencies and SETUP_TYPE

Message ID 20240413133202.29033-1-heiko.thiery@gmail.com
State New
Headers show
Series package/python-yamllint: fix dependencies and SETUP_TYPE | expand

Commit Message

Heiko Thiery April 13, 2024, 1:32 p.m. UTC
For host build the runtime depndencies has to be added. Also the setup
type needs to be set to 'setuptools'.

./output/host/bin/python ./support/testing/tests/package/sample_python_yamllint.py
Traceback (most recent call last):
  File "/home/hthiery/sources/mainline/buildroot/support/testing/tests/package/sample_python_yamllint.py", line 3, in <module>
    from yamllint import (config, linter)
  File "/home/hthiery/sources/mainline/buildroot/output/host/lib/python3.11/site-packages/yamllint/config.py", line 19, in <module>
    import pathspec
ModuleNotFoundError: No module named 'pathspec'

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
Reported-by: Romain Naour <romain.naour@smile.fr>
---
 package/python-yamllint/python-yamllint.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/python-yamllint/python-yamllint.mk b/package/python-yamllint/python-yamllint.mk
index ceaca3b0b8..29344a1408 100644
--- a/package/python-yamllint/python-yamllint.mk
+++ b/package/python-yamllint/python-yamllint.mk
@@ -7,9 +7,13 @@ 
 PYTHON_YAMLLINT_VERSION = 1.35.1
 PYTHON_YAMLLINT_SOURCE = yamllint-$(PYTHON_YAMLLINT_VERSION).tar.gz
 PYTHON_YAMLLINT_SITE = https://files.pythonhosted.org/packages/da/06/d8cee5c3dfd550cc0a466ead8b321138198485d1034130ac1393cc49d63e
-PYTHON_YAMLLINT_SETUP_TYPE = pep517
+PYTHON_YAMLLINT_SETUP_TYPE = setuptools
 PYTHON_YAMLLINT_LICENSE = GPL-3.0
 PYTHON_YAMLLINT_LICENSE_FILES = LICENSE
 
+HOST_PYTHON_YAMLLINT_DEPENDENCIES += \
+	host-python-pathspec \
+	host-python-pyyaml
+
 $(eval $(python-package))
 $(eval $(host-python-package))