diff mbox series

[1/1] package/python-remi: fix pep517 build

Message ID 20240407115439.872167-1-fontaine.fabrice@gmail.com
State New
Headers show
Series [1/1] package/python-remi: fix pep517 build | expand

Commit Message

Fabrice Fontaine April 7, 2024, 11:54 a.m. UTC
Fix the following build failure raised since commit
8937db8dd595e0988751e5dbb568e870b07b39cc:

  File "/home/buildroot/autobuild/run/instance-0/output-1/host/lib/python3.11/site-packages/setuptools/build_meta.py", line 76, in fetch_build_eggs
    raise SetupRequirementsError(specifier_list)
setuptools.build_meta.SetupRequirementsError: ['setuptools_scm']

Fixes: 8937db8dd595e0988751e5dbb568e870b07b39cc
 - http://autobuild.buildroot.org/results/59ff2895baa49260fb83bc375993907144b945af

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/python-remi/python-remi.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle April 7, 2024, 7:33 p.m. UTC | #1
On 07/04/2024 13:54, Fabrice Fontaine wrote:
> Fix the following build failure raised since commit
> 8937db8dd595e0988751e5dbb568e870b07b39cc:
> 
>    File "/home/buildroot/autobuild/run/instance-0/output-1/host/lib/python3.11/site-packages/setuptools/build_meta.py", line 76, in fetch_build_eggs
>      raise SetupRequirementsError(specifier_list)
> setuptools.build_meta.SetupRequirementsError: ['setuptools_scm']

  If the package _does_ build without setuptools_scm, it means that the 
setup.cfg is wrong. So an upstream patch to fix that would be better..

  Regards,
  Arnout

> 
> Fixes: 8937db8dd595e0988751e5dbb568e870b07b39cc
>   - http://autobuild.buildroot.org/results/59ff2895baa49260fb83bc375993907144b945af
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   package/python-remi/python-remi.mk | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/package/python-remi/python-remi.mk b/package/python-remi/python-remi.mk
> index 419a3441a7..ec1649f8a4 100644
> --- a/package/python-remi/python-remi.mk
> +++ b/package/python-remi/python-remi.mk
> @@ -11,5 +11,6 @@ PYTHON_REMI_SITE = https://files.pythonhosted.org/packages/b7/5c/fca9d9273fc9d5f
>   PYTHON_REMI_LICENSE = Apache-2.0
>   PYTHON_REMI_LICENSE_FILES = LICENSE
>   PYTHON_REMI_SETUP_TYPE = setuptools
> +PYTHON_REMI_BUILD_OPTS = --skip-dependency-check
>   
>   $(eval $(python-package))
Fabrice Fontaine April 7, 2024, 7:58 p.m. UTC | #2
Hello,

Le dim. 7 avr. 2024 à 21:33, Arnout Vandecappelle <arnout@mind.be> a écrit :
>
>
>
> On 07/04/2024 13:54, Fabrice Fontaine wrote:
> > Fix the following build failure raised since commit
> > 8937db8dd595e0988751e5dbb568e870b07b39cc:
> >
> >    File "/home/buildroot/autobuild/run/instance-0/output-1/host/lib/python3.11/site-packages/setuptools/build_meta.py", line 76, in fetch_build_eggs
> >      raise SetupRequirementsError(specifier_list)
> > setuptools.build_meta.SetupRequirementsError: ['setuptools_scm']
>
>   If the package _does_ build without setuptools_scm, it means that the
> setup.cfg is wrong. So an upstream patch to fix that would be better..

From my understanding, upstream uses setuptools_scm to retrieve version since
https://github.com/rawpython/remi/pull/404/commits/f27630721d2bbcfbce515dc2e6be3167f6a06a34

So setuptools_scm is not "strictly" needed.

I used --skip-dependency-check because it is already done in 6 other
packages since commit 8937db8dd595e0988751e5dbb568e870b07b39cc


>
>   Regards,
>   Arnout
>
> >
> > Fixes: 8937db8dd595e0988751e5dbb568e870b07b39cc
> >   - http://autobuild.buildroot.org/results/59ff2895baa49260fb83bc375993907144b945af
> >
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > ---
> >   package/python-remi/python-remi.mk | 1 +
> >   1 file changed, 1 insertion(+)
> >
> > diff --git a/package/python-remi/python-remi.mk b/package/python-remi/python-remi.mk
> > index 419a3441a7..ec1649f8a4 100644
> > --- a/package/python-remi/python-remi.mk
> > +++ b/package/python-remi/python-remi.mk
> > @@ -11,5 +11,6 @@ PYTHON_REMI_SITE = https://files.pythonhosted.org/packages/b7/5c/fca9d9273fc9d5f
> >   PYTHON_REMI_LICENSE = Apache-2.0
> >   PYTHON_REMI_LICENSE_FILES = LICENSE
> >   PYTHON_REMI_SETUP_TYPE = setuptools
> > +PYTHON_REMI_BUILD_OPTS = --skip-dependency-check
> >
> >   $(eval $(python-package))

Best Regards,

Fabrice
diff mbox series

Patch

diff --git a/package/python-remi/python-remi.mk b/package/python-remi/python-remi.mk
index 419a3441a7..ec1649f8a4 100644
--- a/package/python-remi/python-remi.mk
+++ b/package/python-remi/python-remi.mk
@@ -11,5 +11,6 @@  PYTHON_REMI_SITE = https://files.pythonhosted.org/packages/b7/5c/fca9d9273fc9d5f
 PYTHON_REMI_LICENSE = Apache-2.0
 PYTHON_REMI_LICENSE_FILES = LICENSE
 PYTHON_REMI_SETUP_TYPE = setuptools
+PYTHON_REMI_BUILD_OPTS = --skip-dependency-check
 
 $(eval $(python-package))