diff mbox series

[1/1] toolchain/helpers.mk: Use int as main return type

Message ID 20240403170351.470997-1-petr.vorel@gmail.com
State Accepted
Headers show
Series [1/1] toolchain/helpers.mk: Use int as main return type | expand

Commit Message

Petr Vorel April 3, 2024, 5:03 p.m. UTC
Although -Wmain-return-type is not considered as error (unlike
-Wimplicit-int), but just a warning, let's fix it for the future.

<stdin>:1:1: warning: return type of 'main' is not 'int' [-Wmain-return-type]

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
---
Based on the fix from Robert
https://lore.kernel.org/buildroot/20240403121807.2087547-1-robimarko@gmail.com/

NOTE: I also updated config project ML to get
support/gnuconfig/config.guess fixed.

Kind regards,
Petr

 toolchain/helpers.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 8, 2024, 8:37 p.m. UTC | #1
On Wed,  3 Apr 2024 19:03:51 +0200
Petr Vorel <petr.vorel@gmail.com> wrote:

> Although -Wmain-return-type is not considered as error (unlike
> -Wimplicit-int), but just a warning, let's fix it for the future.
> 
> <stdin>:1:1: warning: return type of 'main' is not 'int' [-Wmain-return-type]
> 
> Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
> ---
> Based on the fix from Robert
> https://lore.kernel.org/buildroot/20240403121807.2087547-1-robimarko@gmail.com/

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index e5c838c0af..839ee278d0 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -483,7 +483,7 @@  check_unusable_toolchain = \
 #
 check_toolchain_ssp = \
 	__CROSS_CC=$(strip $1) ; \
-	__HAS_SSP=`echo 'void main(){}' | $${__CROSS_CC} -Werror -fstack-protector -x c - -o $(BUILD_DIR)/.br-toolchain-test.tmp >/dev/null 2>&1 && echo y` ; \
+	__HAS_SSP=`echo 'int main(){}' | $${__CROSS_CC} -Werror -fstack-protector -x c - -o $(BUILD_DIR)/.br-toolchain-test.tmp >/dev/null 2>&1 && echo y` ; \
 	if [ "$(BR2_TOOLCHAIN_HAS_SSP)" != "y" -a "$${__HAS_SSP}" = "y" ] ; then \
 		echo "SSP support available in this toolchain, please enable BR2_TOOLCHAIN_EXTERNAL_HAS_SSP" ; \
 		exit 1 ; \
@@ -494,7 +494,7 @@  check_toolchain_ssp = \
 	fi ; \
 	__SSP_OPTION=$(2); \
 	if [ -n "$${__SSP_OPTION}" ] ; then \
-		if ! echo 'void main(){}' | $${__CROSS_CC} -Werror $${__SSP_OPTION} -x c - -o $(BUILD_DIR)/.br-toolchain-test.tmp >/dev/null 2>&1 ; then \
+		if ! echo 'int main(){}' | $${__CROSS_CC} -Werror $${__SSP_OPTION} -x c - -o $(BUILD_DIR)/.br-toolchain-test.tmp >/dev/null 2>&1 ; then \
 			echo "SSP option $${__SSP_OPTION} not available in this toolchain, please select another SSP level" ; \
 			exit 1 ; \
 		fi; \