diff mbox series

[2/9] package/apr: add optional dependency to libxcrypt

Message ID 20240403153641.4122789-2-bernd@kuhls.net
State Accepted
Headers show
Series [1/9] package/apg: add optional dependency to libxcrypt | expand

Commit Message

Bernd Kuhls April 3, 2024, 3:36 p.m. UTC
When glibc was bumped to version 2.39 in commit
b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
libcrypt support.

As glibc's libcrypt was providing apr's libcrypt dependency this broke
the apache build using glibc version 2.39.

To fix this select the libxcrypt dependency to apr when using a glibc
toolchain and add the dependency if selected.

Fixes:
http://autobuild.buildroot.net/results/11ccf857a70ae9f44e8d3ae39fc01db68632ca64/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/apr/Config.in | 1 +
 package/apr/apr.mk    | 4 ++++
 2 files changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/apr/Config.in b/package/apr/Config.in
index 4606fc5378..9427b7af2c 100644
--- a/package/apr/Config.in
+++ b/package/apr/Config.in
@@ -3,6 +3,7 @@  config BR2_PACKAGE_APR
 	# apr really needs shared library support
 	depends on !BR2_STATIC_LIBS
 	depends on BR2_USE_MMU # fork() in apr_proc_fork()
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  The mission of the Apache Portable Runtime (APR) project is to
 	  create and maintain software libraries that provide a
diff --git a/package/apr/apr.mk b/package/apr/apr.mk
index bdc5e915c6..cb8c12dd65 100644
--- a/package/apr/apr.mk
+++ b/package/apr/apr.mk
@@ -68,6 +68,10 @@  else
 APR_CONF_OPTS += --disable-nonportable-atomics
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+APR_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
 APR_DEPENDENCIES += util-linux
 endif