diff mbox series

[1/1] package/screen: fix build with glibc 2.39

Message ID 20240402052617.153655-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/screen: fix build with glibc 2.39 | expand

Commit Message

James Hilliard April 2, 2024, 5:26 a.m. UTC
When glibc was bumped to version 2.39 in commit
b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
libcrypt support.

As glibc's libcrypt was providing screen's libcrypt dependency this
broke any screen build using glibc version 2.39.

To fix this select the libxcrypt dependency for screen when using a
glibc toolchain and add the dependency if selected.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/screen/Config.in | 1 +
 package/screen/screen.mk | 4 ++++
 2 files changed, 5 insertions(+)

Comments

Yann E. MORIN April 2, 2024, 9:26 p.m. UTC | #1
James, All,

On 2024-04-01 23:26 -0600, James Hilliard spake thusly:
> When glibc was bumped to version 2.39 in commit
> b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
> libcrypt support.
> 
> As glibc's libcrypt was providing screen's libcrypt dependency this
> broke any screen build using glibc version 2.39.
> 
> To fix this select the libxcrypt dependency for screen when using a
> glibc toolchain and add the dependency if selected.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/screen/Config.in | 1 +
>  package/screen/screen.mk | 4 ++++
>  2 files changed, 5 insertions(+)
> 
> diff --git a/package/screen/Config.in b/package/screen/Config.in
> index ee4c04ca9e..40cda77b50 100644
> --- a/package/screen/Config.in
> +++ b/package/screen/Config.in
> @@ -1,6 +1,7 @@
>  config BR2_PACKAGE_SCREEN
>  	bool "screen"
>  	depends on BR2_USE_MMU # fork()
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	select BR2_PACKAGE_NCURSES
>  	help
>  	  Screen is a full-screen window manager that multiplexes a
> diff --git a/package/screen/screen.mk b/package/screen/screen.mk
> index d4052b1191..55fecb89bc 100644
> --- a/package/screen/screen.mk
> +++ b/package/screen/screen.mk
> @@ -16,6 +16,10 @@ SCREEN_CONF_ENV = CFLAGS="$(TARGET_CFLAGS)"
>  SCREEN_CONF_OPTS = --enable-colors256
>  SCREEN_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) SCREEN=screen install_bin
>  
> +ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
> +SCREEN_DEPENDENCIES += libxcrypt
> +endif
> +
>  ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
>  SCREEN_DEPENDENCIES += linux-pam
>  SCREEN_CONF_OPTS += --enable-pam
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/screen/Config.in b/package/screen/Config.in
index ee4c04ca9e..40cda77b50 100644
--- a/package/screen/Config.in
+++ b/package/screen/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_PACKAGE_SCREEN
 	bool "screen"
 	depends on BR2_USE_MMU # fork()
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_NCURSES
 	help
 	  Screen is a full-screen window manager that multiplexes a
diff --git a/package/screen/screen.mk b/package/screen/screen.mk
index d4052b1191..55fecb89bc 100644
--- a/package/screen/screen.mk
+++ b/package/screen/screen.mk
@@ -16,6 +16,10 @@  SCREEN_CONF_ENV = CFLAGS="$(TARGET_CFLAGS)"
 SCREEN_CONF_OPTS = --enable-colors256
 SCREEN_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) SCREEN=screen install_bin
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+SCREEN_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 SCREEN_DEPENDENCIES += linux-pam
 SCREEN_CONF_OPTS += --enable-pam