diff mbox series

[1/1] package/luaposix: fix build with glibc 2.39

Message ID 20240402045055.6236-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/luaposix: fix build with glibc 2.39 | expand

Commit Message

James Hilliard April 2, 2024, 4:50 a.m. UTC
When glibc was bumped to version 2.39 in commit
b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
libcrypt support.

As glibc's libcrypt was providing luaposix's libcrypt dependency this
broke any luaposix build using glibc version 2.39.

To fix this select the libxcrypt dependency to luaposix when using a
glibc toolchain and add the dependency if selected.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/luaposix/Config.in   | 1 +
 package/luaposix/luaposix.mk | 5 ++++-
 2 files changed, 5 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN April 2, 2024, 9:27 p.m. UTC | #1
James, All,

On 2024-04-01 22:50 -0600, James Hilliard spake thusly:
> When glibc was bumped to version 2.39 in commit
> b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
> libcrypt support.
> 
> As glibc's libcrypt was providing luaposix's libcrypt dependency this
> broke any luaposix build using glibc version 2.39.
> 
> To fix this select the libxcrypt dependency to luaposix when using a
> glibc toolchain and add the dependency if selected.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/luaposix/Config.in   | 1 +
>  package/luaposix/luaposix.mk | 5 ++++-
>  2 files changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/package/luaposix/Config.in b/package/luaposix/Config.in
> index 85943f9915..bd2105743d 100644
> --- a/package/luaposix/Config.in
> +++ b/package/luaposix/Config.in
> @@ -4,6 +4,7 @@ config BR2_PACKAGE_LUAPOSIX
>  	# "bit" module, but since it has a different name, luaposix
>  	# doesn't find it.
>  	select BR2_PACKAGE_LUA_BIT32 if BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION_5_1 # runtime
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	help
>  	  This is a POSIX binding for LuaJIT, Lua 5.1 through 5.4;
>  	  like most libraries it simply binds to C APIs on the
> diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
> index d09a1bcd1d..680aeb8b81 100644
> --- a/package/luaposix/luaposix.mk
> +++ b/package/luaposix/luaposix.mk
> @@ -8,7 +8,10 @@ LUAPOSIX_VERSION = 36.2.1
>  LUAPOSIX_SITE = $(call github,luaposix,luaposix,v$(LUAPOSIX_VERSION))
>  LUAPOSIX_LICENSE = MIT
>  LUAPOSIX_LICENSE_FILES = LICENSE
> -LUAPOSIX_DEPENDENCIES = luainterpreter host-lua
> +LUAPOSIX_DEPENDENCIES = \
> +	luainterpreter \
> +	host-lua \
> +	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt)
>  
>  define LUAPOSIX_BUILD_CMDS
>  	(cd $(@D); \
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/luaposix/Config.in b/package/luaposix/Config.in
index 85943f9915..bd2105743d 100644
--- a/package/luaposix/Config.in
+++ b/package/luaposix/Config.in
@@ -4,6 +4,7 @@  config BR2_PACKAGE_LUAPOSIX
 	# "bit" module, but since it has a different name, luaposix
 	# doesn't find it.
 	select BR2_PACKAGE_LUA_BIT32 if BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION_5_1 # runtime
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  This is a POSIX binding for LuaJIT, Lua 5.1 through 5.4;
 	  like most libraries it simply binds to C APIs on the
diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
index d09a1bcd1d..680aeb8b81 100644
--- a/package/luaposix/luaposix.mk
+++ b/package/luaposix/luaposix.mk
@@ -8,7 +8,10 @@  LUAPOSIX_VERSION = 36.2.1
 LUAPOSIX_SITE = $(call github,luaposix,luaposix,v$(LUAPOSIX_VERSION))
 LUAPOSIX_LICENSE = MIT
 LUAPOSIX_LICENSE_FILES = LICENSE
-LUAPOSIX_DEPENDENCIES = luainterpreter host-lua
+LUAPOSIX_DEPENDENCIES = \
+	luainterpreter \
+	host-lua \
+	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt)
 
 define LUAPOSIX_BUILD_CMDS
 	(cd $(@D); \