diff mbox series

[v1] package/zic: fix host compile (needs CC/HOST_CONFIGURE_OPTS set)

Message ID 20240401112421.27763-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1] package/zic: fix host compile (needs CC/HOST_CONFIGURE_OPTS set) | expand

Commit Message

Peter Seiderer April 1, 2024, 11:24 a.m. UTC
Host compile of zic needs CC defined since version bump to 2024a (given by
HOST_CONFIGURE_OPTS).

	$ diff -ru build/host-zic-2023c/Makefile build/host-zic-2024a/Makefile
  --- build/host-zic-2023c/Makefile	2024-04-01 12:44:14.515490354 +0200
  +++ build/host-zic-2024a/Makefile	2024-04-01 13:10:50.138333771 +0200
  [...]
  +# To affect how this Makefile works, you can run a shell script like this:
  +#
  +#	#!/bin/sh
  +#	make CC='gcc -std=gnu11' "$@"
  +#
  +# This example script is appropriate for a pre-2017 GNU/Linux system
  +# where a non-default setting is needed to support this package's use of C99.
  +#
  +# Alternatively, you can simply edit this Makefile to tailor the following
  +# macro definitions.
  +
  +###############################################################################
  +# Start of macros that one plausibly might want to tailor.
  [...]
  -cc=		cc
  -CC=		$(cc) -DTZDIR='"$(TZDIR)"'
  [...]

Fixes:

  c99 -O1   -c -o zic.o zic.c
  make[2]: c99: No such file or directory

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/zic/zic.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN April 1, 2024, 12:11 p.m. UTC | #1
Peter, All,

On 2024-04-01 13:24 +0200, Peter Seiderer via buildroot spake thusly:
> Host compile of zic needs CC defined since version bump to 2024a (given by
> HOST_CONFIGURE_OPTS).
> 
> 	$ diff -ru build/host-zic-2023c/Makefile build/host-zic-2024a/Makefile
>   --- build/host-zic-2023c/Makefile	2024-04-01 12:44:14.515490354 +0200
>   +++ build/host-zic-2024a/Makefile	2024-04-01 13:10:50.138333771 +0200
>   [...]
>   +# To affect how this Makefile works, you can run a shell script like this:
>   +#
>   +#	#!/bin/sh
>   +#	make CC='gcc -std=gnu11' "$@"
>   +#
>   +# This example script is appropriate for a pre-2017 GNU/Linux system
>   +# where a non-default setting is needed to support this package's use of C99.
>   +#
>   +# Alternatively, you can simply edit this Makefile to tailor the following
>   +# macro definitions.
>   +
>   +###############################################################################
>   +# Start of macros that one plausibly might want to tailor.
>   [...]
>   -cc=		cc
>   -CC=		$(cc) -DTZDIR='"$(TZDIR)"'
>   [...]

This diff is not very helpful, so I replaced it with a reference to the
upstream commit that changed the requirements.

I also slightly reworded the commit log to also mention that our CFLAGS
and LDFLAGS are now used as well, in addition to the now required CC.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> Fixes:
> 
>   c99 -O1   -c -o zic.o zic.c
>   make[2]: c99: No such file or directory
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
>  package/zic/zic.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/zic/zic.mk b/package/zic/zic.mk
> index 95fa1eaa96..8abcec9360 100644
> --- a/package/zic/zic.mk
> +++ b/package/zic/zic.mk
> @@ -12,7 +12,7 @@ ZIC_LICENSE = Public domain
>  ZIC_LICENSE_FILES = LICENSE
>  
>  define HOST_ZIC_BUILD_CMDS
> -	$(HOST_MAKE_ENV) $(MAKE) -C $(@D) zic
> +	$(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) zic
>  endef
>  
>  define HOST_ZIC_INSTALL_CMDS
> -- 
> 2.44.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard April 28, 2024, 2:18 p.m. UTC | #2
>>>>> "Peter" == Peter Seiderer via buildroot <buildroot@buildroot.org> writes:

 > Host compile of zic needs CC defined since version bump to 2024a (given by
 > HOST_CONFIGURE_OPTS).

 > 	$ diff -ru build/host-zic-2023c/Makefile build/host-zic-2024a/Makefile
 >   --- build/host-zic-2023c/Makefile	2024-04-01 12:44:14.515490354 +0200
 >   +++ build/host-zic-2024a/Makefile	2024-04-01 13:10:50.138333771 +0200
 >   [...]
 >   +# To affect how this Makefile works, you can run a shell script like this:
 >   +#
 >   +#	#!/bin/sh
 >   +#	make CC='gcc -std=gnu11' "$@"
 >   +#
 >   +# This example script is appropriate for a pre-2017 GNU/Linux system
 >   +# where a non-default setting is needed to support this package's use of C99.
 >   +#
 >   +# Alternatively, you can simply edit this Makefile to tailor the following
 >   +# macro definitions.
 >   +
 >   +###############################################################################
 >   +# Start of macros that one plausibly might want to tailor.
 >   [...]
 >   -cc=		cc
 >   -CC=		$(cc) -DTZDIR='"$(TZDIR)"'
 >   [...]

 > Fixes:

 >   c99 -O1   -c -o zic.o zic.c
 >   make[2]: c99: No such file or directory

 > Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Committed to 2024.02.x, thanks.
diff mbox series

Patch

diff --git a/package/zic/zic.mk b/package/zic/zic.mk
index 95fa1eaa96..8abcec9360 100644
--- a/package/zic/zic.mk
+++ b/package/zic/zic.mk
@@ -12,7 +12,7 @@  ZIC_LICENSE = Public domain
 ZIC_LICENSE_FILES = LICENSE
 
 define HOST_ZIC_BUILD_CMDS
-	$(HOST_MAKE_ENV) $(MAKE) -C $(@D) zic
+	$(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) zic
 endef
 
 define HOST_ZIC_INSTALL_CMDS