diff mbox series

[1/2] package/python-pyqt5-sip: new package

Message ID 20240401084841.439073-1-hypnotoad@lindra.de
State Superseded
Headers show
Series [1/2] package/python-pyqt5-sip: new package | expand

Commit Message

Ralf Dragon April 1, 2024, 8:48 a.m. UTC
This packages adds the PyQt5.sip module.

The official documentation [1] mentions that this module is needed
during PyQt5 runtime. It is currently compiled without any
dependencies to Qt or PyQt5, but it seems quite useless without it.
The module was introduced together with PyQt 5.11 [2].

[1] https://www.riverbankcomputing.com/static/Docs/PyQt5/installation.html#building-and-installing-from-source
[2] https://www.riverbankcomputing.com/static/Docs/PyQt5/incompatibilities.html#pyqt-v5-11

Signed-off-by: Ralf Dragon <hypnotoad@lindra.de>
---
Changes v1 -> v2:
 - fix License and make sure legal info passes
 - document in commit message why this package is needed
 - split off the runtime dependency to separate patch

Backport to: 2023.*.x 2024.02.x
(2022 LTS branches are probably also affected but I could not test any, 2021.11.3 is fine)

 package/Config.in                              |  1 +
 package/python-pyqt5-sip/Config.in             |  4 ++++
 package/python-pyqt5-sip/python-pyqt5-sip.hash |  7 +++++++
 package/python-pyqt5-sip/python-pyqt5-sip.mk   | 14 ++++++++++++++
 4 files changed, 26 insertions(+)
 create mode 100644 package/python-pyqt5-sip/Config.in
 create mode 100644 package/python-pyqt5-sip/python-pyqt5-sip.hash
 create mode 100644 package/python-pyqt5-sip/python-pyqt5-sip.mk

Comments

Arnout Vandecappelle April 1, 2024, 12:58 p.m. UTC | #1
Hi Ralf,

On 01/04/2024 10:48, Ralf Dragon wrote:
> This packages adds the PyQt5.sip module.
> 
> The official documentation [1] mentions that this module is needed
> during PyQt5 runtime. It is currently compiled without any
> dependencies to Qt or PyQt5, but it seems quite useless without it.
> The module was introduced together with PyQt 5.11 [2].
> 
> [1] https://www.riverbankcomputing.com/static/Docs/PyQt5/installation.html#building-and-installing-from-source
> [2] https://www.riverbankcomputing.com/static/Docs/PyQt5/incompatibilities.html#pyqt-v5-11
> 
> Signed-off-by: Ralf Dragon <hypnotoad@lindra.de>
> ---
> Changes v1 -> v2:
>   - fix License and make sure legal info passes
>   - document in commit message why this package is needed
>   - split off the runtime dependency to separate patch
> 
> Backport to: 2023.*.x 2024.02.x
> (2022 LTS branches are probably also affected but I could not test any, 2021.11.3 is fine)

  All 2022.x and 2023.x branches are EOL, so this will only be backported to 
2024.02.x.

> 
>   package/Config.in                              |  1 +
>   package/python-pyqt5-sip/Config.in             |  4 ++++
>   package/python-pyqt5-sip/python-pyqt5-sip.hash |  7 +++++++
>   package/python-pyqt5-sip/python-pyqt5-sip.mk   | 14 ++++++++++++++

  Please add yourself to the DEVELOPERS file [1] for this package. This way, 
you'll get an e-mail if the package fails in the autobuilders, or when a new 
version is released if the package is registered on release-monitoring.org.

>   4 files changed, 26 insertions(+)
>   create mode 100644 package/python-pyqt5-sip/Config.in
>   create mode 100644 package/python-pyqt5-sip/python-pyqt5-sip.hash
>   create mode 100644 package/python-pyqt5-sip/python-pyqt5-sip.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index 33039331f7..d897f16120 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1278,6 +1278,7 @@ menu "External python modules"
>   	source "package/python-pypng/Config.in"
>   	source "package/python-pyqrcode/Config.in"
>   	source "package/python-pyqt5/Config.in"
> +	source "package/python-pyqt5-sip/Config.in"
>   	source "package/python-pyratemp/Config.in"
>   	source "package/python-pyroute2/Config.in"
>   	source "package/python-pyrsistent/Config.in"
> diff --git a/package/python-pyqt5-sip/Config.in b/package/python-pyqt5-sip/Config.in
> new file mode 100644
> index 0000000000..f7be60c8ec
> --- /dev/null
> +++ b/package/python-pyqt5-sip/Config.in
> @@ -0,0 +1,4 @@
> +config BR2_PACKAGE_PYTHON_PYQT5_SIP
> +	bool "python-pyqt5-sip"
> +	help
> +	  This is the PyQt5.sip module which is needed to run PyQt5.

  Please add an upstream URL (that should point to the project's website, some 
high-level intro, the documentation, or if nothing else the README). If there 
really is nothing specific to this package, just refer to pyqt5.

> diff --git a/package/python-pyqt5-sip/python-pyqt5-sip.hash b/package/python-pyqt5-sip/python-pyqt5-sip.hash
> new file mode 100644
> index 0000000000..fb4a8cb04d
> --- /dev/null
> +++ b/package/python-pyqt5-sip/python-pyqt5-sip.hash
> @@ -0,0 +1,7 @@
> +# from https://pypi.org/project/PyQt5-sip/12.30.0
> +sha256  7f321daf84b9c9dbca61b80e1ef37bdaffc0e93312edae2cd7da25b953971d91  PyQt5_sip-12.13.0.tar.gz
> +
> +# Hash for license files:
> +md5  9cd437778ebd1c056a76b4ded73b3a6d  LICENSE
> +md5  e91355d8a6f8bd8f7c699d62863c7303  LICENSE-GPL2
> +md5  7ea41d866d6638e430db5287a3f66090  LICENSE-GPL3
> diff --git a/package/python-pyqt5-sip/python-pyqt5-sip.mk b/package/python-pyqt5-sip/python-pyqt5-sip.mk
> new file mode 100644
> index 0000000000..0114f6db69
> --- /dev/null
> +++ b/package/python-pyqt5-sip/python-pyqt5-sip.mk
> @@ -0,0 +1,14 @@
> +################################################################################
> +#
> +# python-SIP-QT5
> +#
> +################################################################################
> +
> +PYTHON_PYQT5_SIP_VERSION = 12.13.0
> +PYTHON_PYQT5_SIP_SITE = https://files.pythonhosted.org/packages/ee/81/fce2a475aa56c1f49707d9306b930695b6ff078c2242c9f2fd72a3214e1f
> +PYTHON_PYQT5_SIP_SOURCE = PyQt5_sip-$(PYTHON_PYQT5_SIP_VERSION).tar.gz
> +PYTHON_PYQT5_SIP_LICENSE = SIP

  SIP is not a valid SPDX license. We have the informal habit of indicating this 
with multiple space-separated words (typically ending with license). See for 
example the python-sip package, which mentsion "SIP license".

  In addition, this license declaration doesn't correspond to the license files, 
which include GPL-2.0 and GPL-3.0. So I suspect the correct license declaration 
would be the same as for python-sip: SIP license or GPL-2.0 or GPL-3.0

  Regards,
  Arnout

[1] https://nightly.buildroot.org/#DEVELOPERS


> +PYTHON_PYQT5_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
> +PYTHON_PYQT5_SIP_SETUP_TYPE = setuptools
> +
> +$(eval $(python-package))
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 33039331f7..d897f16120 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1278,6 +1278,7 @@  menu "External python modules"
 	source "package/python-pypng/Config.in"
 	source "package/python-pyqrcode/Config.in"
 	source "package/python-pyqt5/Config.in"
+	source "package/python-pyqt5-sip/Config.in"
 	source "package/python-pyratemp/Config.in"
 	source "package/python-pyroute2/Config.in"
 	source "package/python-pyrsistent/Config.in"
diff --git a/package/python-pyqt5-sip/Config.in b/package/python-pyqt5-sip/Config.in
new file mode 100644
index 0000000000..f7be60c8ec
--- /dev/null
+++ b/package/python-pyqt5-sip/Config.in
@@ -0,0 +1,4 @@ 
+config BR2_PACKAGE_PYTHON_PYQT5_SIP
+	bool "python-pyqt5-sip"
+	help
+	  This is the PyQt5.sip module which is needed to run PyQt5.
diff --git a/package/python-pyqt5-sip/python-pyqt5-sip.hash b/package/python-pyqt5-sip/python-pyqt5-sip.hash
new file mode 100644
index 0000000000..fb4a8cb04d
--- /dev/null
+++ b/package/python-pyqt5-sip/python-pyqt5-sip.hash
@@ -0,0 +1,7 @@ 
+# from https://pypi.org/project/PyQt5-sip/12.30.0
+sha256  7f321daf84b9c9dbca61b80e1ef37bdaffc0e93312edae2cd7da25b953971d91  PyQt5_sip-12.13.0.tar.gz
+
+# Hash for license files:
+md5  9cd437778ebd1c056a76b4ded73b3a6d  LICENSE
+md5  e91355d8a6f8bd8f7c699d62863c7303  LICENSE-GPL2
+md5  7ea41d866d6638e430db5287a3f66090  LICENSE-GPL3
diff --git a/package/python-pyqt5-sip/python-pyqt5-sip.mk b/package/python-pyqt5-sip/python-pyqt5-sip.mk
new file mode 100644
index 0000000000..0114f6db69
--- /dev/null
+++ b/package/python-pyqt5-sip/python-pyqt5-sip.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-SIP-QT5
+#
+################################################################################
+
+PYTHON_PYQT5_SIP_VERSION = 12.13.0
+PYTHON_PYQT5_SIP_SITE = https://files.pythonhosted.org/packages/ee/81/fce2a475aa56c1f49707d9306b930695b6ff078c2242c9f2fd72a3214e1f
+PYTHON_PYQT5_SIP_SOURCE = PyQt5_sip-$(PYTHON_PYQT5_SIP_VERSION).tar.gz
+PYTHON_PYQT5_SIP_LICENSE = SIP
+PYTHON_PYQT5_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
+PYTHON_PYQT5_SIP_SETUP_TYPE = setuptools
+
+$(eval $(python-package))