diff mbox series

[1/2] package/python-sqlalchemy: add cython for python-sqlalchemy

Message ID 20240324162848.17338-1-flavio.tapajos@newtesc.com.br
State Accepted
Headers show
Series [1/2] package/python-sqlalchemy: add cython for python-sqlalchemy | expand

Commit Message

Flávio Tapajós March 24, 2024, 4:28 p.m. UTC
From: James Hilliard <james.hilliard1@gmail.com>

When migrating to setuptools with pep517 support we need to add
host-python-cython which is a pep517 build dependency for
python-sqlalchemy.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Tested-By: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
---
 package/python-sqlalchemy/python-sqlalchemy.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle March 27, 2024, 9:16 p.m. UTC | #1
On 24/03/2024 17:28, Flávio Tapajós wrote:
> From: James Hilliard <james.hilliard1@gmail.com>
> 
> When migrating to setuptools with pep517 support we need to add
> host-python-cython which is a pep517 build dependency for
> python-sqlalchemy.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> Tested-By: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
> Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>

  I don't understand why you cherry-picked that patch from the pep517-setuptools 
series - AFAICS it shouldn't be needed for the version bump. But since it needs 
to be applied at some point anyway, I applied both to master, thanks.

  Regards,
  Arnout

> ---
>   package/python-sqlalchemy/python-sqlalchemy.mk | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/package/python-sqlalchemy/python-sqlalchemy.mk b/package/python-sqlalchemy/python-sqlalchemy.mk
> index 400ad92f63..167c3a4498 100644
> --- a/package/python-sqlalchemy/python-sqlalchemy.mk
> +++ b/package/python-sqlalchemy/python-sqlalchemy.mk
> @@ -12,5 +12,6 @@ PYTHON_SQLALCHEMY_LICENSE = MIT
>   PYTHON_SQLALCHEMY_LICENSE_FILES = LICENSE
>   PYTHON_SQLALCHEMY_CPE_ID_VENDOR = sqlalchemy
>   PYTHON_SQLALCHEMY_CPE_ID_PRODUCT = sqlalchemy
> +PYTHON_SQLALCHEMY_DEPENDENCIES = host-python-cython
>   
>   $(eval $(python-package))
Peter Korsgaard April 28, 2024, 11:07 a.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle via buildroot <buildroot@buildroot.org> writes:

 > On 24/03/2024 17:28, Flávio Tapajós wrote:
 >> From: James Hilliard <james.hilliard1@gmail.com>
 >> When migrating to setuptools with pep517 support we need to add
 >> host-python-cython which is a pep517 build dependency for
 >> python-sqlalchemy.
 >> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
 >> Tested-By: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
 >> Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>

 >  I don't understand why you cherry-picked that patch from the
 >  pep517-setuptools series - AFAICS it shouldn't be needed for the
 >  version bump. But since it needs to be applied at some point anyway,
 > I applied both to master, thanks.

So it is presumably not needed for 2024.02.x, right?
Arnout Vandecappelle April 28, 2024, 5:07 p.m. UTC | #3
On 28/04/2024 13:07, Peter Korsgaard wrote:
>>>>>> "Arnout" == Arnout Vandecappelle via buildroot <buildroot@buildroot.org> writes:
> 
>   > On 24/03/2024 17:28, Flávio Tapajós wrote:
>   >> From: James Hilliard <james.hilliard1@gmail.com>
>   >> When migrating to setuptools with pep517 support we need to add
>   >> host-python-cython which is a pep517 build dependency for
>   >> python-sqlalchemy.
>   >> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
>   >> Tested-By: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
>   >> Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
> 
>   >  I don't understand why you cherry-picked that patch from the
>   >  pep517-setuptools series - AFAICS it shouldn't be needed for the
>   >  version bump. But since it needs to be applied at some point anyway,
>   > I applied both to master, thanks.
> 
> So it is presumably not needed for 2024.02.x, right?

  No, it's only needed for the migrate-to-setuptools series which is not in 
2024.02.x.

  Regards,
  Arnout
diff mbox series

Patch

diff --git a/package/python-sqlalchemy/python-sqlalchemy.mk b/package/python-sqlalchemy/python-sqlalchemy.mk
index 400ad92f63..167c3a4498 100644
--- a/package/python-sqlalchemy/python-sqlalchemy.mk
+++ b/package/python-sqlalchemy/python-sqlalchemy.mk
@@ -12,5 +12,6 @@  PYTHON_SQLALCHEMY_LICENSE = MIT
 PYTHON_SQLALCHEMY_LICENSE_FILES = LICENSE
 PYTHON_SQLALCHEMY_CPE_ID_VENDOR = sqlalchemy
 PYTHON_SQLALCHEMY_CPE_ID_PRODUCT = sqlalchemy
+PYTHON_SQLALCHEMY_DEPENDENCIES = host-python-cython
 
 $(eval $(python-package))