diff mbox series

[v1,1/1] package/go: security bump to go1.21.8

Message ID 20240306003454.13352-1-christian@aperture.us
State Accepted
Headers show
Series [v1,1/1] package/go: security bump to go1.21.8 | expand

Commit Message

Christian Stewart March 6, 2024, 12:34 a.m. UTC
Fixes the following CVEs:

CVE-2024-24783: crypto/x509: Verify panics on certificates with an unknown public key algorithm
CVE-2023-45290: net/http: memory exhaustion in Request.ParseMultipartForm
CVE-2023-45289: net/http, net/http/cookiejar: incorrect forwarding of sensitive headers and cookies on HTTP redirect
CVE-2024-24785: html/template: errors returned from MarshalJSON methods may break template escaping
CVE-2024-24784: net/mail: comments in display names are incorrectly handled

https://go.dev/doc/devel/release#go1.21.8

Signed-off-by: Christian Stewart <christian@aperture.us>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard March 6, 2024, 7:24 a.m. UTC | #1
>>>>> "Christian" == Christian Stewart <christian@aperture.us> writes:

 > Fixes the following CVEs:
 > CVE-2024-24783: crypto/x509: Verify panics on certificates with an unknown public key algorithm
 > CVE-2023-45290: net/http: memory exhaustion in Request.ParseMultipartForm
 > CVE-2023-45289: net/http, net/http/cookiejar: incorrect forwarding of sensitive headers and cookies on HTTP redirect
 > CVE-2024-24785: html/template: errors returned from MarshalJSON methods may break template escaping
 > CVE-2024-24784: net/mail: comments in display names are incorrectly handled

 > https://go.dev/doc/devel/release#go1.21.8

 > Signed-off-by: Christian Stewart <christian@aperture.us>

Committed, thanks.
Peter Korsgaard March 20, 2024, 8:18 p.m. UTC | #2
>>>>> "Christian" == Christian Stewart <christian@aperture.us> writes:

 > Fixes the following CVEs:
 > CVE-2024-24783: crypto/x509: Verify panics on certificates with an unknown public key algorithm
 > CVE-2023-45290: net/http: memory exhaustion in Request.ParseMultipartForm
 > CVE-2023-45289: net/http, net/http/cookiejar: incorrect forwarding of sensitive headers and cookies on HTTP redirect
 > CVE-2024-24785: html/template: errors returned from MarshalJSON methods may break template escaping
 > CVE-2024-24784: net/mail: comments in display names are incorrectly handled

 > https://go.dev/doc/devel/release#go1.21.8

 > Signed-off-by: Christian Stewart <christian@aperture.us>

Committed to 2024.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index d008019e94..b1aed10c7c 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://go.dev/dl
-sha256  00197ab20f33813832bff62fd93cca1c42a08cc689a32a6672ca49591959bff6  go1.21.7.src.tar.gz
+sha256  dc806cf75a87e1414b5b4c3dcb9dd3e9cc98f4cfccec42b7af617d5a658a3c43  go1.21.8.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index 9efd4a3123..3ca055b25d 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.21.7
+GO_VERSION = 1.21.8
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz