diff mbox series

[1/1] package/xz: bump to version 5.6.0

Message ID 20240224192732.1298236-1-ju.o@free.fr
State Rejected
Headers show
Series [1/1] package/xz: bump to version 5.6.0 | expand

Commit Message

Julien Olivain Feb. 24, 2024, 7:27 p.m. UTC
This commit changes the version branch from 5.4.x to 5.6.x. This old
stable 5.4.x branch is expected to be end-of-life. The release note
mention in [1]:

"""
There currently are no plans to maintain the 5.4.x branch, but
releases could be made if there is community interest.
"""

For a change log since 5.4.5, see [2].

The COPYING licence file hash has changed. Most public domain files
are now licensed under the Zero-Clause BSD license. This release
explicitly set the XZ logo under the CC-by-SA-4.0 license. Due to
those changes, the new license files COPYING.0BSD and
COPYING.CC-BY-SA-4.0 are added to _LICENSE_FILES and in the hash file.

The package homepage URL https://tukaani.org/xz/ now redirects to
https://xz.tukaani.org/xz-utils/. This commit updates the homepage
URL accordingly in Config.in.

Finally, the package download URL moved to Github. This commit changes
the _SITE to reflect that change.

[1] https://github.com/tukaani-project/xz/releases/tag/v5.6.0
[2] https://github.com/tukaani-project/xz/blob/v5.6.0/NEWS

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
Patch tested on branch master at commit fb6274f with commands:

    make check-package
    ...
    0 warnings generated

    support/testing/run-tests \
        -d dl -o output_folder \
        tests.package.test_xz
    ...
    OK

    utils/test-pkg -a -p xz
    ...
    45 builds, 0 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed
---
 package/xz/Config.in |  2 +-
 package/xz/xz.hash   |  8 +++++---
 package/xz/xz.mk     | 14 ++++++++++----
 3 files changed, 16 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/package/xz/Config.in b/package/xz/Config.in
index 687bd554821..7130fa5e8e4 100644
--- a/package/xz/Config.in
+++ b/package/xz/Config.in
@@ -12,4 +12,4 @@  config BR2_PACKAGE_XZ
 	  invoked via appropriate symlinks will emulate the behavior
 	  of the commands in the lzma package.
 
-	  https://tukaani.org/xz/
+	  https://xz.tukaani.org/xz-utils/
diff --git a/package/xz/xz.hash b/package/xz/xz.hash
index 3d93ad6b5ee..46edd336bc9 100644
--- a/package/xz/xz.hash
+++ b/package/xz/xz.hash
@@ -1,9 +1,11 @@ 
 # Locally calculated after checking pgp signature
-# https://tukaani.org/xz/xz-5.4.5.tar.bz2.sig
-sha256  8ccf5fff868c006f29522e386fb4c6a1b66463fbca65a4cfc3c4bd596e895e79  xz-5.4.5.tar.bz2
+# https://github.com/tukaani-project/xz/releases/download/v5.6.0/xz-5.6.0.tar.bz2.sig
+sha256  88c8631cefba91664fdc47b14bb753e1876f4964a07db650821d203992b1e1ea  xz-5.6.0.tar.bz2
 
 # Hash for license files
-sha256  72d7ef9c98be319fd34ce88b45203b36d5936f9c49e82bf3198ffee5e0c7d87e  COPYING
+sha256  0864e508475f20b43a2393957fdb5a966558099ffa8fed1e3e73fe2b3eebb145  COPYING
+sha256  0b01625d853911cd0e2e088dcfb743261034a091bb379246cb25a14cc4c74bf1  COPYING.0BSD
+sha256  23ee78c8bae49cf08ea2f0c84945c66b987ebe4520881fb51b3dad4fb43d07c2  COPYING.CC-BY-SA-4.0
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING.GPLv2
 sha256  3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986  COPYING.GPLv3
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LGPLv2.1
diff --git a/package/xz/xz.mk b/package/xz/xz.mk
index 547959c743d..88c79254943 100644
--- a/package/xz/xz.mk
+++ b/package/xz/xz.mk
@@ -4,13 +4,19 @@ 
 #
 ################################################################################
 
-XZ_VERSION = 5.4.5
+XZ_VERSION = 5.6.0
 XZ_SOURCE = xz-$(XZ_VERSION).tar.bz2
-XZ_SITE = https://tukaani.org/xz
+XZ_SITE = https://github.com/tukaani-project/xz/releases/download/v$(XZ_VERSION)
 XZ_INSTALL_STAGING = YES
 XZ_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
-XZ_LICENSE = Public Domain, GPL-2.0+, GPL-3.0+, LGPL-2.1+
-XZ_LICENSE_FILES = COPYING COPYING.GPLv2 COPYING.GPLv3 COPYING.LGPLv2.1
+XZ_LICENSE = Public Domain, 0BSD, CC-BY-SA-4.0 (logo), GPL-2.0+, GPL-3.0+, LGPL-2.1+
+XZ_LICENSE_FILES = \
+	COPYING \
+	COPYING.0BSD \
+	COPYING.CC-BY-SA-4.0 \
+	COPYING.GPLv2 \
+	COPYING.GPLv3 \
+	COPYING.LGPLv2.1
 XZ_CPE_ID_VENDOR = tukaani
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)