diff mbox series

[1/1] package/fd: new package

Message ID 20240223203031.825112-1-kazemi.ms@gmail.com
State New
Headers show
Series [1/1] package/fd: new package | expand

Commit Message

Saeed Kazemi Feb. 23, 2024, 8:30 p.m. UTC
A simple, fast and user-friendly alternative to 'find'

https://github.com/sharkdp/fd.git

Signed-off-by: Saeed Kazemi <kazemi.ms@gmail.com>
---
 DEVELOPERS           |  1 +
 package/Config.in    |  1 +
 package/fd/Config.in | 12 ++++++++++++
 package/fd/fd.hash   |  4 ++++
 package/fd/fd.mk     | 12 ++++++++++++
 5 files changed, 30 insertions(+)
 create mode 100644 package/fd/Config.in
 create mode 100644 package/fd/fd.hash
 create mode 100644 package/fd/fd.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 0f065bfafb..bf022512a5 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -2731,6 +2731,7 @@  F:	package/biosdevname/
 
 N:	Saeed Kazemi <kazemi.ms@gmail.com>
 F:	package/eza/
+F:	package/fd/
 F:	package/procs/
 
 N:	Sam Lancia <sam@gpsm.co.uk>
diff --git a/package/Config.in b/package/Config.in
index bf0fe078b9..090fa80a29 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -182,6 +182,7 @@  menu "Development tools"
 	source "package/diffutils/Config.in"
 	source "package/dos2unix/Config.in"
 	source "package/findutils/Config.in"
+	source "package/fd/Config.in"
 	source "package/flex/Config.in"
 	source "package/gawk/Config.in"
 	source "package/gettext/Config.in"
diff --git a/package/fd/Config.in b/package/fd/Config.in
new file mode 100644
index 0000000000..10f295cb20
--- /dev/null
+++ b/package/fd/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_FD
+	bool "fd"
+	depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
+	select BR2_PACKAGE_HOST_RUSTC
+	help
+	  fd is a program to find entries in your filesystem. It is a
+	  simple, fast and user-friendly alternative to find. While it
+	  does not aim to support all of find's powerful functionality,
+	  it provides sensible (opinionated) defaults for a majority of
+	  use cases.
+
+	  https://github.com/sharkdp/fd.git
diff --git a/package/fd/fd.hash b/package/fd/fd.hash
new file mode 100644
index 0000000000..7950055efa
--- /dev/null
+++ b/package/fd/fd.hash
@@ -0,0 +1,4 @@ 
+# Locally computed
+sha256  49d57704f1a75b20a770d50538818ec003f42a5c19a39a682639b5e72e72ee7d  fd-9.0.0.tar.gz
+sha256  73c83c60d817e7df1943cb3f0af81e4939a8352c9a96c2fd00451b1116fa635c  LICENSE-APACHE
+sha256  322cfc7aa0c774d0eca3b2610f1d414de3ddbd7d8dd4b9dea941a13a6eb07455  LICENSE-MIT
diff --git a/package/fd/fd.mk b/package/fd/fd.mk
new file mode 100644
index 0000000000..316da418ea
--- /dev/null
+++ b/package/fd/fd.mk
@@ -0,0 +1,12 @@ 
+################################################################################
+#
+# fd
+#
+################################################################################
+
+FD_VERSION = 9.0.0
+FD_SITE = $(call github,sharkdp,fd,v$(FD_VERSION))
+FD_LICENSE = Apache-2.0 or MIT
+FD_LICENSE_FILES = LICENSE-APACHE LICENSE-MIT
+
+$(eval $(cargo-package))