deleted file mode 100644
@@ -1,41 +0,0 @@
-From 03c5c4dd29bc7590baccb55a36d61e7f4b39c1fe Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 29 Oct 2023 18:56:35 +0100
-Subject: [PATCH] atop.h: include time.h
-
-Include time.h to avoid the following build failure with musl:
-
-atop.h:157:1: error: unknown type name 'time_t'
- 157 | time_t normalize_epoch(time_t, long);
- | ^~~~~~
-atop.h:157:1: note: 'time_t' is defined in header '<time.h>'; did you forget to '#include <time.h>'?
-atop.h:157:40: error: expected ')' before 'long'
- 157 | time_t normalize_epoch(time_t, long);
- | ^~~~~
- | )
-
-Fixes:
- - http://autobuild.buildroot.org/results/e7ec8d16f2299320f374a0198c8e9b18a102b037
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Upstream: https://github.com/Atoptool/atop/pull/280
----
- atop.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/atop.h b/atop.h
-index 9274fc5..3d5fea4 100644
---- a/atop.h
-+++ b/atop.h
-@@ -24,6 +24,8 @@
- #ifndef __ATOP__
- #define __ATOP__
-
-+#include <time.h>
-+
- #define EQ 0
- #define SECONDSINDAY 86400
- #define RAWNAMESZ 256
-2.42.0
-
@@ -6,6 +6,7 @@ config BR2_PACKAGE_ATOP
select BR2_PACKAGE_NCURSES
select BR2_PACKAGE_NCURSES_WCHAR
select BR2_PACKAGE_ZLIB
+ select BR2_PACKAGE_LIBGLIB2
help
Atop is an ASCII full-screen performance monitor for Linux
that is capable of reporting the activity of all processes
@@ -1,5 +1,5 @@
# Locally computed:
-sha256 8d82f211b712a227000ef254c0a2b53bcb71235bf40d93316acce80b04bff926 atop-2.9.0.tar.gz
+sha256 e7a673cf2c82578e7dd82ecb0dec83fd9ecb30828b2561c28a9fa5aaf75d5f93 atop-2.10.0.tar.gz
# Hash for license file:
sha256 204d8eff92f95aac4df6c8122bc1505f468f3a901e5a4cc08940e0ede1938994 COPYING
@@ -4,21 +4,23 @@
#
################################################################################
-ATOP_VERSION = 2.9.0
+ATOP_VERSION = 2.10.0
ATOP_SITE = http://www.atoptool.nl/download
ATOP_LICENSE = GPL-2.0+
ATOP_LICENSE_FILES = COPYING
ATOP_CPE_ID_VALID = YES
-ATOP_DEPENDENCIES = ncurses zlib
+ATOP_DEPENDENCIES = ncurses zlib libglib2
-ATOP_CFLAGS = $(TARGET_CFLAGS)
+ATOP_CFLAGS = $(TARGET_CFLAGS) -O2 -I. -Wall $(shell $(HOST_DIR)/bin/pkg-config --cflags glib-2.0) -Wno-stringop-truncation -Wmissing-prototypes -Wmissing-declarations -Wformat-security
+
+ATOP_LDFLAGS = $(TARGET_LDFLAGS) $(shell $(HOST_DIR)/bin/pkg-config --libs glib-2.0)
ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
ATOP_CFLAGS += -O0
endif
define ATOP_BUILD_CMDS
- $(MAKE) $(TARGET_CONFIGURE_OPTS) CFLAGS="$(ATOP_CFLAGS)" \
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) CFLAGS="$(ATOP_CFLAGS)" LDFLAGS="$(ATOP_LDFLAGS)" \
-C $(@D)
endef
Signed-off-by: Kadambini Nema <kadambini.nema@gmail.com> --- package/atop/0001-atop.h-include-time.h.patch | 41 ------------------- package/atop/Config.in | 1 + package/atop/atop.hash | 2 +- package/atop/atop.mk | 10 +++-- 4 files changed, 8 insertions(+), 46 deletions(-) delete mode 100644 package/atop/0001-atop.h-include-time.h.patch