diff mbox series

[1/2] package/python-sqlalchemy: bump version to 2.0.25

Message ID 20240103142831.901515-1-flavio.tapajos@newtesc.com.br
State Accepted
Headers show
Series [1/2] package/python-sqlalchemy: bump version to 2.0.25 | expand

Commit Message

Flávio Tapajós Jan. 3, 2024, 2:28 p.m. UTC
Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
---
 package/python-sqlalchemy/Config.in              | 1 +
 package/python-sqlalchemy/python-sqlalchemy.hash | 4 ++--
 package/python-sqlalchemy/python-sqlalchemy.mk   | 4 ++--
 3 files changed, 5 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Jan. 4, 2024, 10:33 p.m. UTC | #1
Hello Flávio,

Thanks a lot for your patch, I have applied it, but after fixing a few
small things. See below!

On Wed,  3 Jan 2024 11:28:30 -0300
Flávio Tapajós <flavio.tapajos@newtesc.com.br> wrote:

> diff --git a/package/python-sqlalchemy/Config.in b/package/python-sqlalchemy/Config.in
> index f7ec3a6ad4..f05fee7ab1 100644
> --- a/package/python-sqlalchemy/Config.in
> +++ b/package/python-sqlalchemy/Config.in
> @@ -1,5 +1,6 @@
>  config BR2_PACKAGE_PYTHON_SQLALCHEMY
>  	bool "python-sqlalchemy"
> +	select BR2_PACKAGE_PYTHON_TYPING_EXTENSIONS

This a runtime dependency only, we don't need it at build-time. We like
to document such dependencies like this:

	select BR2_PACKAGE_PYTHON_TYPING_EXTENSIONS # runtime

which helps document that it is normal for this dependency to be in
Config.in, but not in the .mk file.

> diff --git a/package/python-sqlalchemy/python-sqlalchemy.hash b/package/python-sqlalchemy/python-sqlalchemy.hash
> index 9f479d8f7b..6a894bee24 100644
> --- a/package/python-sqlalchemy/python-sqlalchemy.hash
> +++ b/package/python-sqlalchemy/python-sqlalchemy.hash
> @@ -1,5 +1,5 @@
>  # md5, sha256 from https://pypi.org/pypi/sqlalchemy/json
> -md5  52318b83e8931c5f5a459f54fe4be3e8  SQLAlchemy-1.4.42.tar.gz
> -sha256  177e41914c476ed1e1b77fd05966ea88c094053e17a85303c4ce007f88eff363  SQLAlchemy-1.4.42.tar.gz
> +sha256 a2c69a7664fb2d54b8682dd774c3b54f67f84fa123cf84dda2a5f40dcaa04e08  SQLAlchemy-2.0.25.tar.gz
> +md5 7abfc2972d7e16315c8b7492ea0e0fdb SQLAlchemy-2.0.25.tar.gz

Here you changed the ordering of the two lines, which adds a bit of
"noise" and it not really needed. You also broke the spacing of the
different fields: we want two spaces between each field (yes that's a
pure convention, but it allows things to be consistent between
packages). If you run "make check-package", or "./utils/check-package
package/python-sqlalchemy/*", it checks such minor coding style issues.

>  # Locally computed sha256 checksums
>  sha256  859ded25da34c1eb73e6e736df4c5f8ce3ed2ed5290663176f06e7720d9c9a20  LICENSE

The final issue was related to the LICENSE file: it has changed between
the old version of sqlalchemy and this new version, so the hash was no
longer correct. So I have updated the hash, but more importantly, I
have documented in the commit log why the hash changed.

With all those changes, the final commit looks like this:

  https://gitlab.com/buildroot.org/buildroot/-/commit/0f2f090892914e3b04ff217d1ea10cceafc70515

Thanks again for your contribution!

Thomas
diff mbox series

Patch

diff --git a/package/python-sqlalchemy/Config.in b/package/python-sqlalchemy/Config.in
index f7ec3a6ad4..f05fee7ab1 100644
--- a/package/python-sqlalchemy/Config.in
+++ b/package/python-sqlalchemy/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_PYTHON_SQLALCHEMY
 	bool "python-sqlalchemy"
+	select BR2_PACKAGE_PYTHON_TYPING_EXTENSIONS
 	help
 	  SQLAlchemy is the Python SQL toolkit and Object Relational
 	  Mapper that gives application developers the full power and
diff --git a/package/python-sqlalchemy/python-sqlalchemy.hash b/package/python-sqlalchemy/python-sqlalchemy.hash
index 9f479d8f7b..6a894bee24 100644
--- a/package/python-sqlalchemy/python-sqlalchemy.hash
+++ b/package/python-sqlalchemy/python-sqlalchemy.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/sqlalchemy/json
-md5  52318b83e8931c5f5a459f54fe4be3e8  SQLAlchemy-1.4.42.tar.gz
-sha256  177e41914c476ed1e1b77fd05966ea88c094053e17a85303c4ce007f88eff363  SQLAlchemy-1.4.42.tar.gz
+sha256 a2c69a7664fb2d54b8682dd774c3b54f67f84fa123cf84dda2a5f40dcaa04e08  SQLAlchemy-2.0.25.tar.gz
+md5 7abfc2972d7e16315c8b7492ea0e0fdb SQLAlchemy-2.0.25.tar.gz
 # Locally computed sha256 checksums
 sha256  859ded25da34c1eb73e6e736df4c5f8ce3ed2ed5290663176f06e7720d9c9a20  LICENSE
diff --git a/package/python-sqlalchemy/python-sqlalchemy.mk b/package/python-sqlalchemy/python-sqlalchemy.mk
index a94b9eca92..400ad92f63 100644
--- a/package/python-sqlalchemy/python-sqlalchemy.mk
+++ b/package/python-sqlalchemy/python-sqlalchemy.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_SQLALCHEMY_VERSION = 1.4.42
+PYTHON_SQLALCHEMY_VERSION = 2.0.25
 PYTHON_SQLALCHEMY_SOURCE = SQLAlchemy-$(PYTHON_SQLALCHEMY_VERSION).tar.gz
-PYTHON_SQLALCHEMY_SITE = https://files.pythonhosted.org/packages/e4/56/8ea85eaab7d93b58f9c213ad8fc5882838189a29fc8cc401d80710a12969
+PYTHON_SQLALCHEMY_SITE = https://files.pythonhosted.org/packages/7b/bb/85bd8e211f54983e927c7cd9b2ad66773fbef507957156fc72e481a62681
 PYTHON_SQLALCHEMY_SETUP_TYPE = setuptools
 PYTHON_SQLALCHEMY_LICENSE = MIT
 PYTHON_SQLALCHEMY_LICENSE_FILES = LICENSE