diff mbox series

package/re2: bump to version 2023.11.01

Message ID 20231124090758.3299176-1-buildroot@heine.tech
State Changes Requested
Headers show
Series package/re2: bump to version 2023.11.01 | expand

Commit Message

Michael Nosthoff Nov. 24, 2023, 9:07 a.m. UTC
- libabseil-cpp is now a dependency
- raise c++ standard to c++14 (due to abseil) --> requires gcc8
- drop fix for gcc <= 5 introduced in 25fd3b0a523805db14682f7c559cc1c9c366ed55
  (c++ >= 14 is the default for gcc >= 8)

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
---
 package/re2/Config.in |  7 ++++---
 package/re2/re2.hash  |  2 +-
 package/re2/re2.mk    | 13 +++++--------
 3 files changed, 10 insertions(+), 12 deletions(-)

Comments

Yann E. MORIN Nov. 25, 2023, 12:19 p.m. UTC | #1
On 2023-11-24 10:07 +0100, Michael Nosthoff via buildroot spake thusly:
> - libabseil-cpp is now a dependency
> - raise c++ standard to c++14 (due to abseil) --> requires gcc8
> - drop fix for gcc <= 5 introduced in 25fd3b0a523805db14682f7c559cc1c9c366ed55
>   (c++ >= 14 is the default for gcc >= 8)
> 
> Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
> ---
>  package/re2/Config.in |  7 ++++---
>  package/re2/re2.hash  |  2 +-
>  package/re2/re2.mk    | 13 +++++--------
>  3 files changed, 10 insertions(+), 12 deletions(-)
> 
> diff --git a/package/re2/Config.in b/package/re2/Config.in
> index 64217e8aa2..d3bcad8d1a 100644
> --- a/package/re2/Config.in
> +++ b/package/re2/Config.in
> @@ -1,8 +1,9 @@
>  config BR2_PACKAGE_RE2
>  	bool "re2"
>  	depends on BR2_INSTALL_LIBSTDCPP
> -	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # needs C++11
> +	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_8 # needs C++14, libabseil-cpp

You said in the commit log that the C++14 requirement is due to
libaseil-cpp, but the comment you wrote here is ambiguoug, as it seems
to imply that re2 itself needs C++14.

If the C++14 is only due to libaseil-cpp, then the comment should be:

    depends on BR2_TOOLCHAIN_GCC_AT_LEAST_8 # libabseil-cpp

If however re2 needs C++ for itself, then the comment should be:

    depends on BR2_TOOLCHAIN_GCC_AT_LEAST_8 # C++14

Can you clarify this?

Also, re2 is selected by two packages:

  - gprc, and it already depends on gcc >= 8 becasue of libabseil-cpp

  - qt5webengne, but that one only depends on gcc >= 4.9, so the new
    dependency mustbe propagated there too.

Can you check and respin, please?

Regards,
Yann E. MORIN.

>  	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	select BR2_PACKAGE_LIBABSEIL_CPP
>  	help
>  	  RE2 is a fast, safe, thread-friendly alternative
>  	  to backtracking regular expression engines like
> @@ -11,7 +12,7 @@ config BR2_PACKAGE_RE2
>  
>  	  https://github.com/google/re2
>  
> -comment "re2 needs a toolchain w/ C++, threads, gcc >= 4.8"
> +comment "re2 needs a toolchain w/ C++, threads, gcc >= 8"
>  	depends on !BR2_INSTALL_LIBSTDCPP || \
>  		!BR2_TOOLCHAIN_HAS_THREADS || \
> -		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
> +		!BR2_TOOLCHAIN_GCC_AT_LEAST_8
> diff --git a/package/re2/re2.hash b/package/re2/re2.hash
> index a39dece7a9..5f590aba6e 100644
> --- a/package/re2/re2.hash
> +++ b/package/re2/re2.hash
> @@ -1,3 +1,3 @@
>  # locally calculated
> -sha256  cbce8b7803e856827201a132862e41af386e7afd9cc6d9a9bc7a4fa4d8ddbdde  re2-2023-02-01.tar.gz
> +sha256  4e6593ac3c71de1c0f322735bc8b0492a72f66ffccfad76e259fa21c41d27d8a  re2-2023-11-01.tar.gz
>  sha256  6040cda75d90b1738292a631d89934c411ef7ffd543c4d6a1b7edfc8edf29449  LICENSE
> diff --git a/package/re2/re2.mk b/package/re2/re2.mk
> index 5587366b1f..b81a64f2e9 100644
> --- a/package/re2/re2.mk
> +++ b/package/re2/re2.mk
> @@ -4,29 +4,26 @@
>  #
>  ################################################################################
>  
> -RE2_VERSION = 2023-02-01
> +RE2_VERSION = 2023-11-01
>  RE2_SITE = $(call github,google,re2,$(RE2_VERSION))
>  RE2_LICENSE = BSD-3-Clause
>  RE2_LICENSE_FILES = LICENSE
>  RE2_INSTALL_STAGING = YES
> -
> -RE2_MAKE_OPTS = \
> -	$(TARGET_CONFIGURE_OPTS) \
> -	CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
> +RE2_DEPENDENCIES = libabseil-cpp
>  
>  define RE2_BUILD_CMDS
> -	$(TARGET_MAKE_ENV) $(MAKE) $(RE2_MAKE_OPTS) \
> +	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
>  		-C $(@D) $(if $(BR2_STATIC_LIBS),static)
>  endef
>  
>  define RE2_INSTALL_STAGING_CMDS
> -	$(TARGET_MAKE_ENV) $(MAKE) $(RE2_MAKE_OPTS) \
> +	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
>  		DESTDIR="$(STAGING_DIR)" prefix=/usr -C $(@D) \
>  		$(if $(BR2_STATIC_LIBS),static-install,install)
>  endef
>  
>  define RE2_INSTALL_TARGET_CMDS
> -	$(TARGET_MAKE_ENV) $(MAKE) $(RE2_MAKE_OPTS) \
> +	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
>  		DESTDIR="$(TARGET_DIR)" prefix=/usr -C $(@D) \
>  		$(if $(BR2_STATIC_LIBS),static-install,install)
>  endef
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/re2/Config.in b/package/re2/Config.in
index 64217e8aa2..d3bcad8d1a 100644
--- a/package/re2/Config.in
+++ b/package/re2/Config.in
@@ -1,8 +1,9 @@ 
 config BR2_PACKAGE_RE2
 	bool "re2"
 	depends on BR2_INSTALL_LIBSTDCPP
-	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # needs C++11
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_8 # needs C++14, libabseil-cpp
 	depends on BR2_TOOLCHAIN_HAS_THREADS
+	select BR2_PACKAGE_LIBABSEIL_CPP
 	help
 	  RE2 is a fast, safe, thread-friendly alternative
 	  to backtracking regular expression engines like
@@ -11,7 +12,7 @@  config BR2_PACKAGE_RE2
 
 	  https://github.com/google/re2
 
-comment "re2 needs a toolchain w/ C++, threads, gcc >= 4.8"
+comment "re2 needs a toolchain w/ C++, threads, gcc >= 8"
 	depends on !BR2_INSTALL_LIBSTDCPP || \
 		!BR2_TOOLCHAIN_HAS_THREADS || \
-		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_8
diff --git a/package/re2/re2.hash b/package/re2/re2.hash
index a39dece7a9..5f590aba6e 100644
--- a/package/re2/re2.hash
+++ b/package/re2/re2.hash
@@ -1,3 +1,3 @@ 
 # locally calculated
-sha256  cbce8b7803e856827201a132862e41af386e7afd9cc6d9a9bc7a4fa4d8ddbdde  re2-2023-02-01.tar.gz
+sha256  4e6593ac3c71de1c0f322735bc8b0492a72f66ffccfad76e259fa21c41d27d8a  re2-2023-11-01.tar.gz
 sha256  6040cda75d90b1738292a631d89934c411ef7ffd543c4d6a1b7edfc8edf29449  LICENSE
diff --git a/package/re2/re2.mk b/package/re2/re2.mk
index 5587366b1f..b81a64f2e9 100644
--- a/package/re2/re2.mk
+++ b/package/re2/re2.mk
@@ -4,29 +4,26 @@ 
 #
 ################################################################################
 
-RE2_VERSION = 2023-02-01
+RE2_VERSION = 2023-11-01
 RE2_SITE = $(call github,google,re2,$(RE2_VERSION))
 RE2_LICENSE = BSD-3-Clause
 RE2_LICENSE_FILES = LICENSE
 RE2_INSTALL_STAGING = YES
-
-RE2_MAKE_OPTS = \
-	$(TARGET_CONFIGURE_OPTS) \
-	CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
+RE2_DEPENDENCIES = libabseil-cpp
 
 define RE2_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) $(RE2_MAKE_OPTS) \
+	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
 		-C $(@D) $(if $(BR2_STATIC_LIBS),static)
 endef
 
 define RE2_INSTALL_STAGING_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) $(RE2_MAKE_OPTS) \
+	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
 		DESTDIR="$(STAGING_DIR)" prefix=/usr -C $(@D) \
 		$(if $(BR2_STATIC_LIBS),static-install,install)
 endef
 
 define RE2_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) $(RE2_MAKE_OPTS) \
+	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
 		DESTDIR="$(TARGET_DIR)" prefix=/usr -C $(@D) \
 		$(if $(BR2_STATIC_LIBS),static-install,install)
 endef