diff mbox series

[v1,1/1] package/go: security bump to go1.21.4

Message ID 20231107221745.2722636-1-christian@aperture.us
State Accepted
Headers show
Series [v1,1/1] package/go: security bump to go1.21.4 | expand

Commit Message

Christian Stewart Nov. 7, 2023, 10:17 p.m. UTC
Go version 1.21.4 includes the following security fixes:

CVE-2023-45283: path/filepath: recognize \??\ as a Root Local Device path prefix.
CVE-2023-45284: path/filepath: recognize device names with trailing spaces and superscripts

https://go.dev/doc/devel/release#go1.21.4

Signed-off-by: Christian Stewart <christian@aperture.us>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Nov. 8, 2023, 7:09 a.m. UTC | #1
>>>>> "Christian" == Christian Stewart <christian@aperture.us> writes:

 > Go version 1.21.4 includes the following security fixes:
 > CVE-2023-45283: path/filepath: recognize \??\ as a Root Local Device path prefix.
 > CVE-2023-45284: path/filepath: recognize device names with trailing spaces and superscripts

 > https://go.dev/doc/devel/release#go1.21.4

 > Signed-off-by: Christian Stewart <christian@aperture.us>

Committed, thanks.

Can you also send a 1.20.11 bump for 2023.08.x / 2023.02.x?

> ---
 >  package/go/go.hash | 2 +-
 >  package/go/go.mk   | 2 +-
 >  2 files changed, 2 insertions(+), 2 deletions(-)

 > diff --git a/package/go/go.hash b/package/go/go.hash
 > index 9499f50964..74b18a9b38 100644
 > --- a/package/go/go.hash
 > +++ b/package/go/go.hash
 > @@ -1,3 +1,3 @@
 >  # From https://go.dev/dl
 > -sha256  186f2b6f8c8b704e696821b09ab2041a5c1ee13dcbc3156a13adcf75931ee488  go1.21.3.src.tar.gz
 > +sha256  47b26a83d2b65a3c1c1bcace273b69bee49a7a7b5168a7604ded3d26a37bd787  go1.21.4.src.tar.gz
 >  sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
 > diff --git a/package/go/go.mk b/package/go/go.mk
 > index ef27f32835..7bd7866a05 100644
 > --- a/package/go/go.mk
 > +++ b/package/go/go.mk
 > @@ -4,7 +4,7 @@
 >  #
 >  ################################################################################
 
 > -GO_VERSION = 1.21.3
 > +GO_VERSION = 1.21.4
 >  GO_SITE = https://storage.googleapis.com/golang
 >  GO_SOURCE = go$(GO_VERSION).src.tar.gz
 
 > -- 

 > 2.42.1
Peter Korsgaard Nov. 11, 2023, 1:19 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>> "Christian" == Christian Stewart <christian@aperture.us> writes:
 >> Go version 1.21.4 includes the following security fixes:
 >> CVE-2023-45283: path/filepath: recognize \??\ as a Root Local Device path prefix.
 >> CVE-2023-45284: path/filepath: recognize device names with trailing spaces and superscripts

 >> https://go.dev/doc/devel/release#go1.21.4

 >> Signed-off-by: Christian Stewart <christian@aperture.us>

 > Committed, thanks.

 > Can you also send a 1.20.11 bump for 2023.08.x / 2023.02.x?

For 2023.02.x / 2023.08.x I have bumped to 1.20.11 instead.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 9499f50964..74b18a9b38 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://go.dev/dl
-sha256  186f2b6f8c8b704e696821b09ab2041a5c1ee13dcbc3156a13adcf75931ee488  go1.21.3.src.tar.gz
+sha256  47b26a83d2b65a3c1c1bcace273b69bee49a7a7b5168a7604ded3d26a37bd787  go1.21.4.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index ef27f32835..7bd7866a05 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.21.3
+GO_VERSION = 1.21.4
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz