diff mbox series

package/libmdbx: bump version to 0.12.8 "Vladimir Utkin"

Message ID 20231017172108.142456-1-leo@yuriev.ru
State Accepted
Headers show
Series package/libmdbx: bump version to 0.12.8 "Vladimir Utkin" | expand

Commit Message

Леонид Юрьев (Leonid Yuriev) Oct. 17, 2023, 5:21 p.m. UTC
This is bugfix release of stable libmdbx branch, on the day of the 100th
anniversary of the birth of the outstanding Soviet and Russian scientist
and engineer Vladimir Fedorovich Utkin.

It is reasonable to backport this patch to all applicable releases/branches of Buildroot.

The most significant fixes of v0.12.8:
 - Fixed regression of mdbx_put(MDBX_MULTIPLE) during batch/bulk
   insertion of multi-values (aka "dupsort").
 - Implemented overwriting in mdbx_put(MDBX_CURRENT) of all current
   multi-key values in the absence of the flag MDBX_NOOVERWRITE.
 - Added the ability to use mdbx_cursor_get(MDBX_GET_MULTIPLE) without
   first setting the cursor, combining the batch data getting operation
   with positioning the cursor.
 - Micro-optimization and refactoring cursor_put_nochecklen().
 - Clarifying the wording in the API description, including explanation
   about SIGSEGV and not allowing direct data changes.

The complete ChangeLog: https://gitflic.ru/project/erthink/libmdbx/blob?file=ChangeLog.md

Signed-off-by: Леонид Юрьев (Leonid Yuriev) <leo@yuriev.ru>
---
 package/libmdbx/libmdbx.hash | 2 +-
 package/libmdbx/libmdbx.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Nov. 1, 2023, 6:07 p.m. UTC | #1
On Tue, 17 Oct 2023 20:21:07 +0300
Леонид Юрьев (Leonid Yuriev) <leo@yuriev.ru> wrote:

> This is bugfix release of stable libmdbx branch, on the day of the 100th
> anniversary of the birth of the outstanding Soviet and Russian scientist
> and engineer Vladimir Fedorovich Utkin.
> 
> It is reasonable to backport this patch to all applicable releases/branches of Buildroot.
> 
> The most significant fixes of v0.12.8:
>  - Fixed regression of mdbx_put(MDBX_MULTIPLE) during batch/bulk
>    insertion of multi-values (aka "dupsort").
>  - Implemented overwriting in mdbx_put(MDBX_CURRENT) of all current
>    multi-key values in the absence of the flag MDBX_NOOVERWRITE.
>  - Added the ability to use mdbx_cursor_get(MDBX_GET_MULTIPLE) without
>    first setting the cursor, combining the batch data getting operation
>    with positioning the cursor.
>  - Micro-optimization and refactoring cursor_put_nochecklen().
>  - Clarifying the wording in the API description, including explanation
>    about SIGSEGV and not allowing direct data changes.
> 
> The complete ChangeLog: https://gitflic.ru/project/erthink/libmdbx/blob?file=ChangeLog.md
> 
> Signed-off-by: Леонид Юрьев (Leonid Yuriev) <leo@yuriev.ru>
> ---
>  package/libmdbx/libmdbx.hash | 2 +-
>  package/libmdbx/libmdbx.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Nov. 8, 2023, 9:21 a.m. UTC | #2
>>>>> "Леонид" == Леонид Юрьев (Leonid Yuriev) <leo@yuriev.ru> writes:

 > This is bugfix release of stable libmdbx branch, on the day of the 100th
 > anniversary of the birth of the outstanding Soviet and Russian scientist
 > and engineer Vladimir Fedorovich Utkin.

 > It is reasonable to backport this patch to all applicable releases/branches of Buildroot.

 > The most significant fixes of v0.12.8:
 >  - Fixed regression of mdbx_put(MDBX_MULTIPLE) during batch/bulk
 >    insertion of multi-values (aka "dupsort").
 >  - Implemented overwriting in mdbx_put(MDBX_CURRENT) of all current
 >    multi-key values in the absence of the flag MDBX_NOOVERWRITE.
 >  - Added the ability to use mdbx_cursor_get(MDBX_GET_MULTIPLE) without
 >    first setting the cursor, combining the batch data getting operation
 >    with positioning the cursor.
 >  - Micro-optimization and refactoring cursor_put_nochecklen().
 >  - Clarifying the wording in the API description, including explanation
 >    about SIGSEGV and not allowing direct data changes.

 > The complete ChangeLog: https://gitflic.ru/project/erthink/libmdbx/blob?file=ChangeLog.md

 > Signed-off-by: Леонид Юрьев (Leonid Yuriev) <leo@yuriev.ru>

Committed to 2023.08.x, thanks.
diff mbox series

Patch

diff --git a/package/libmdbx/libmdbx.hash b/package/libmdbx/libmdbx.hash
index 0f5908cf38..82cf28d6a9 100644
--- a/package/libmdbx/libmdbx.hash
+++ b/package/libmdbx/libmdbx.hash
@@ -1,5 +1,5 @@ 
 # Hashes from: https://libmdbx.dqdkfa.ru/release/SHA256SUMS
-sha256  e150541c2b07558b961e754e8e9171bf1aa974c8e936f62bd375606f7d550667  libmdbx-amalgamated-0.12.7.tar.xz
+sha256  c78c56c53708bbfc519bf53ebf520d1f09d30ee6427a4bedf713316696e671d0  libmdbx-amalgamated-0.12.8.tar.xz
 
 # Locally calculated
 sha256  310fe25c858a9515fc8c8d7d1f24a67c9496f84a91e0a0e41ea9975b1371e569  LICENSE
diff --git a/package/libmdbx/libmdbx.mk b/package/libmdbx/libmdbx.mk
index 84b58632b6..4cc6cbd08e 100644
--- a/package/libmdbx/libmdbx.mk
+++ b/package/libmdbx/libmdbx.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LIBMDBX_VERSION = 0.12.7
+LIBMDBX_VERSION = 0.12.8
 LIBMDBX_SOURCE = libmdbx-amalgamated-$(LIBMDBX_VERSION).tar.xz
 LIBMDBX_SITE = https://libmdbx.dqdkfa.ru/release
 LIBMDBX_SUPPORTS_IN_SOURCE_BUILD = NO