diff mbox series

package/go: security bump to version 1.21.2

Message ID 20231006093726.1931681-1-peter@korsgaard.com
State Accepted
Headers show
Series package/go: security bump to version 1.21.2 | expand

Commit Message

Peter Korsgaard Oct. 6, 2023, 9:37 a.m. UTC
Fixes CVE-2023-39323: Line directives ("//line") can be used to bypass the
restrictions on "//go:cgo_" directives, allowing blocked linker and compiler
flags to be passed during compilation.  This can result in unexpected
execution of arbitrary code when running "go build".

go1.21.2 (released 2023-10-05) includes one security fixes to the cmd/go
package, as well as bug fixes to the compiler, the go command, the linker,
the runtime, and the runtime/metrics package.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Oct. 8, 2023, 4 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes CVE-2023-39323: Line directives ("//line") can be used to bypass the
 > restrictions on "//go:cgo_" directives, allowing blocked linker and compiler
 > flags to be passed during compilation.  This can result in unexpected
 > execution of arbitrary code when running "go build".

 > go1.21.2 (released 2023-10-05) includes one security fixes to the cmd/go
 > package, as well as bug fixes to the compiler, the go command, the linker,
 > the runtime, and the runtime/metrics package.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index be8af438b3..a2ec6b5923 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://go.dev/dl
-sha256  bfa36bf75e9a1e9cbbdb9abcf9d1707e479bd3a07880a8ae3564caee5711cb99  go1.21.1.src.tar.gz
+sha256  45e59de173baec39481854490d665b726cec3e5b159f6b4172e5ec7780b2c201  go1.21.2.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index 6f080be5c0..2c32e90817 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.21.1
+GO_VERSION = 1.21.2
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz