diff mbox series

package/gptfdisk: fix bug with util-linux (libuuid) 2.38

Message ID 20230913212000.987236-2-ben.wolsieffer@hefring.com
State Accepted
Headers show
Series package/gptfdisk: fix bug with util-linux (libuuid) 2.38 | expand

Commit Message

Ben Wolsieffer Sept. 13, 2023, 9:20 p.m. UTC
Fix the following error message by backporting an upstream patch [0]:

  Warning! Unable to generate a proper UUID! Creating an improper one as a last
  resort! Windows 7 may crash if you save this partition table!

Additionally, now that gptfdisk uses libuuid again, the build fails
because passing LIBS to make overrides the default value in the
Makefile. To fix this, this patch adds -luuid to GPTFDISK_LDLIBS.

[0] https://sourceforge.net/p/gptfdisk/code/ci/6a8416cbd12d55f882bb751993b94f72d338d96f

Signed-off-by: Ben Wolsieffer <ben.wolsieffer@hefring.com>
---
 ...to-deal-with-minor-change-in-libuuid.patch | 40 +++++++++++++++++++
 package/gptfdisk/gptfdisk.mk                  |  2 +
 2 files changed, 42 insertions(+)
 create mode 100644 package/gptfdisk/0004-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch

Comments

Thomas Petazzoni Oct. 1, 2023, 9:11 p.m. UTC | #1
On Wed, 13 Sep 2023 17:20:01 -0400
Ben Wolsieffer <ben.wolsieffer@hefring.com> wrote:

> Fix the following error message by backporting an upstream patch [0]:
> 
>   Warning! Unable to generate a proper UUID! Creating an improper one as a last
>   resort! Windows 7 may crash if you save this partition table!
> 
> Additionally, now that gptfdisk uses libuuid again, the build fails
> because passing LIBS to make overrides the default value in the
> Makefile. To fix this, this patch adds -luuid to GPTFDISK_LDLIBS.
> 
> [0] https://sourceforge.net/p/gptfdisk/code/ci/6a8416cbd12d55f882bb751993b94f72d338d96f
> 
> Signed-off-by: Ben Wolsieffer <ben.wolsieffer@hefring.com>
> ---
>  ...to-deal-with-minor-change-in-libuuid.patch | 40 +++++++++++++++++++
>  package/gptfdisk/gptfdisk.mk                  |  2 +
>  2 files changed, 42 insertions(+)
>  create mode 100644 package/gptfdisk/0004-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch

Sorry for the delay, I have applied this patch after improving the
commit log:
https://gitlab.com/buildroot.org/buildroot/-/commit/58fbfe870640cf20678d4f6a40999ea5223c6fca

Best regards,

Thomas
Peter Korsgaard Oct. 13, 2023, 3:15 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > On Wed, 13 Sep 2023 17:20:01 -0400
 > Ben Wolsieffer <ben.wolsieffer@hefring.com> wrote:

 >> Fix the following error message by backporting an upstream patch [0]:
 >> 
 >> Warning! Unable to generate a proper UUID! Creating an improper one as a last
 >> resort! Windows 7 may crash if you save this partition table!
 >> 
 >> Additionally, now that gptfdisk uses libuuid again, the build fails
 >> because passing LIBS to make overrides the default value in the
 >> Makefile. To fix this, this patch adds -luuid to GPTFDISK_LDLIBS.
 >> 
 >> [0] https://sourceforge.net/p/gptfdisk/code/ci/6a8416cbd12d55f882bb751993b94f72d338d96f
 >> 
 >> Signed-off-by: Ben Wolsieffer <ben.wolsieffer@hefring.com>
 >> ---
 >> ...to-deal-with-minor-change-in-libuuid.patch | 40 +++++++++++++++++++
 >> package/gptfdisk/gptfdisk.mk                  |  2 +
 >> 2 files changed, 42 insertions(+)
 >> create mode 100644 package/gptfdisk/0004-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch

 > Sorry for the delay, I have applied this patch after improving the
 > commit log:
 > https://gitlab.com/buildroot.org/buildroot/-/commit/58fbfe870640cf20678d4f6a40999ea5223c6fca

 > Best regards,

Committed to 2023.02.x and 2023.08.x, thanks.
diff mbox series

Patch

diff --git a/package/gptfdisk/0004-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch b/package/gptfdisk/0004-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch
new file mode 100644
index 0000000000..6e4f5253e8
--- /dev/null
+++ b/package/gptfdisk/0004-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch
@@ -0,0 +1,40 @@ 
+From 6a8416cbd12d55f882bb751993b94f72d338d96f Mon Sep 17 00:00:00 2001
+From: Rod Smith <rodsmith@rodsbooks.com>
+Date: Sat, 16 Apr 2022 09:32:04 -0400
+Subject: [PATCH] Updated guid.cc to deal with minor change in libuuid
+
+Upstream: https://sourceforge.net/p/gptfdisk/code/ci/6a8416cbd12d55f882bb751993b94f72d338d96f
+---
+ NEWS    | 2 ++
+ guid.cc | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/NEWS b/NEWS
+index 9e153fd..9ec7e63 100644
+--- a/NEWS
++++ b/NEWS
+@@ -6,6 +6,8 @@
+   (commit 740, which is pre-release as I type; presumably version 1.19 and
+   later once released).
+ 
++- Updated guid.cc to deal with minor change in libuuid.
++
+ 1.0.9 (4/14/2022):
+ ------------------
+ 
+diff --git a/guid.cc b/guid.cc
+index 1e73ab7..d3e4fd5 100644
+--- a/guid.cc
++++ b/guid.cc
+@@ -141,7 +141,7 @@ void GUIDData::Zero(void) {
+ void GUIDData::Randomize(void) {
+    int i, uuidGenerated = 0;
+ 
+-#ifdef _UUID_UUID_H
++#if defined (_UUID_UUID_H) || defined (_UL_LIBUUID_UUID_H)
+    uuid_generate(uuidData);
+    ReverseBytes(&uuidData[0], 4);
+    ReverseBytes(&uuidData[4], 2);
+-- 
+2.42.0
+
diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
index f3fc930202..4a15780bae 100644
--- a/package/gptfdisk/gptfdisk.mk
+++ b/package/gptfdisk/gptfdisk.mk
@@ -22,6 +22,8 @@  ifeq ($(BR2_PACKAGE_GPTFDISK_CGDISK),y)
 GPTFDISK_DEPENDENCIES += ncurses
 endif
 
+GPTFDISK_LDLIBS += -luuid
+
 ifeq ($(BR2_STATIC_LIBS),y)
 # gptfdisk dependencies may link against libiconv, so we need to do so
 # as well when linking statically