diff mbox series

package/mmc-utils: bump version to 2023-08-07

Message ID 20230911193301.1438190-1-giulio.benetti@benettiengineering.com
State Accepted
Headers show
Series package/mmc-utils: bump version to 2023-08-07 | expand

Commit Message

Giulio Benetti Sept. 11, 2023, 7:33 p.m. UTC
Starting from commit:
https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/commit/?id=958227890690290ee766aaad1b92f3413f67048c
VERSION macro should be defined by mmc-utils Makefile itself but it doesn't
work in Buildroot because it needs to be in a git repository clone. So
let's mimic what they do in the Makefile by picking the first 6 SHA1 git
commit digits and set them to -DVERSION.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/mmc-utils/mmc-utils.hash | 2 +-
 package/mmc-utils/mmc-utils.mk   | 9 ++++++---
 2 files changed, 7 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Sept. 11, 2023, 8:06 p.m. UTC | #1
On Mon, 11 Sep 2023 21:33:01 +0200
Giulio Benetti <giulio.benetti@benettiengineering.com> wrote:

> Starting from commit:
> https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/commit/?id=958227890690290ee766aaad1b92f3413f67048c
> VERSION macro should be defined by mmc-utils Makefile itself but it doesn't
> work in Buildroot because it needs to be in a git repository clone. So
> let's mimic what they do in the Makefile by picking the first 6 SHA1 git
> commit digits and set them to -DVERSION.
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> ---
>  package/mmc-utils/mmc-utils.hash | 2 +-
>  package/mmc-utils/mmc-utils.mk   | 9 ++++++---
>  2 files changed, 7 insertions(+), 4 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/mmc-utils/mmc-utils.hash b/package/mmc-utils/mmc-utils.hash
index 0d0b6ac1b9..1bdb545cbc 100644
--- a/package/mmc-utils/mmc-utils.hash
+++ b/package/mmc-utils/mmc-utils.hash
@@ -1,3 +1,3 @@ 
 # Locally computed
-sha256  e5a8dacf26a178010202c8fa7cb28b01f50fe967da98cdbdf320b2f110920106  mmc-utils-d4c2910981ff99b983734426dfa99632fb81ac6b-br1.tar.gz
+sha256  9ac9718343ffa36ab9ef192728e60cce6504febe29d43fb8003c2e2ef5a7c7d7  mmc-utils-613495ecaca97a19fa7f8f3ea23306472b36453c-br1.tar.gz
 sha256  4207d81122a02555f78c5a11b61c83a331ee03dc933e1ef9dd932ef9b434d12d  README
diff --git a/package/mmc-utils/mmc-utils.mk b/package/mmc-utils/mmc-utils.mk
index 9da9c30293..45c1af89ff 100644
--- a/package/mmc-utils/mmc-utils.mk
+++ b/package/mmc-utils/mmc-utils.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-MMC_UTILS_VERSION = d4c2910981ff99b983734426dfa99632fb81ac6b
+MMC_UTILS_VERSION = 613495ecaca97a19fa7f8f3ea23306472b36453c
 MMC_UTILS_SITE = https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
 MMC_UTILS_SITE_METHOD = git
 MMC_UTILS_LICENSE = GPL-2.0
@@ -19,11 +19,14 @@  endif
 # override AM_CFLAGS as the project Makefile uses it to pass
 # -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2, and the latter conflicts
 # with the _FORTIFY_SOURCE that we pass when hardening options are
-# enabled.
+# enabled. Starting from commit:
+# https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/commit/?id=958227890690290ee766aaad1b92f3413f67048c
+# they use AM_CFLAGS to set VERSION to first 6 digit of git SHA1, so let's do this
+# here otherwise it won't be automatically set and build will fail
 define MMC_UTILS_BUILD_CMDS
 	$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
 		CFLAGS="$(MMC_UTILS_CFLAGS)" \
-		AM_CFLAGS=
+		AM_CFLAGS='-DVERSION=\"$(shell echo $(MMC_UTILS_VERSION) | head -c 6)\"'
 endef
 
 define MMC_UTILS_INSTALL_TARGET_CMDS