diff mbox series

[04/10] package/php-gnupg: bump version to 1.5.1

Message ID 20230905180610.1610778-4-aduskett@gmail.com
State Accepted
Headers show
Series [01/10] package/php: bump version to 8.2.10 | expand

Commit Message

Adam Duskett Sept. 5, 2023, 6:06 p.m. UTC
From: Adam Duskett <aduskett@gmail.comm>

Drop upstream patch

Signed-off-by: Adam Duskett <aduskett@gmail.comm>
---
 ...0001-Remove-inlining-_phpc_res_close.patch | 33 -------------------
 package/php-gnupg/php-gnupg.hash              |  2 +-
 package/php-gnupg/php-gnupg.mk                |  2 +-
 3 files changed, 2 insertions(+), 35 deletions(-)
 delete mode 100644 package/php-gnupg/0001-Remove-inlining-_phpc_res_close.patch
diff mbox series

Patch

diff --git a/package/php-gnupg/0001-Remove-inlining-_phpc_res_close.patch b/package/php-gnupg/0001-Remove-inlining-_phpc_res_close.patch
deleted file mode 100644
index 9b94cb7e4f..0000000000
--- a/package/php-gnupg/0001-Remove-inlining-_phpc_res_close.patch
+++ /dev/null
@@ -1,33 +0,0 @@ 
-From 887b0899d7e7423baec691255c2d8b56bb348ecd Mon Sep 17 00:00:00 2001
-From: Jakub Zelenka <bukka@php.net>
-Date: Sun, 14 Mar 2021 18:52:21 +0000
-Subject: [PATCH] Remove inlining _phpc_res_close
-
-[Retrieved from:
-https://github.com/bukka/phpc/commit/887b0899d7e7423baec691255c2d8b56bb348ecd]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- phpc.h | 8 --------
- 1 file changed, 8 deletions(-)
-
-diff --git a/phpc/phpc.h b/phpc/phpc.h
-index dc5887e..9206105 100644
---- a/phpc/phpc.h
-+++ b/phpc/phpc.h
-@@ -945,16 +945,8 @@ typedef zend_resource * phpc_res_value_t;
- 	zend_fetch_resource2(Z_RES_P(_pz_res), _res_type_name, _res_type_1, _res_type_2)
- #define PHPC_RES_DELETE(_pz_res) \
- 	zend_list_delete(Z_RES_P(_pz_res))
--#if PHP_MAJOR_VERSION < 8
- #define PHPC_RES_CLOSE(_pz_res) \
- 	zend_list_close(Z_RES_P(_pz_res))
--#else
--inline int _phpc_res_close(zval *zres) {
--	zend_list_close(Z_RES_P(zres));
--	return SUCCESS;
--}
--#define PHPC_RES_CLOSE _phpc_res_close
--#endif
- 
- /* resource to zval */
- #define PHPC_RES_PZVAL(_res, _pzv) \
diff --git a/package/php-gnupg/php-gnupg.hash b/package/php-gnupg/php-gnupg.hash
index 99ffe87f46..084de7750a 100644
--- a/package/php-gnupg/php-gnupg.hash
+++ b/package/php-gnupg/php-gnupg.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  d4f5f79aa483908f3df08e5b343ea3593c6d725b9ed2103e30242627659e0a64  gnupg-1.5.0.tgz
+sha256  a9906f465ab2343cb2f3127ee209c72760238745c34878d9bbc1576486219252  gnupg-1.5.1.tgz
 sha256  da1136d4d9326317cbd320dadddf7e9b4b4edffd973eb083cb7b9754fb6a15d9  LICENSE
diff --git a/package/php-gnupg/php-gnupg.mk b/package/php-gnupg/php-gnupg.mk
index a89f0978af..89054f5f7c 100644
--- a/package/php-gnupg/php-gnupg.mk
+++ b/package/php-gnupg/php-gnupg.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-PHP_GNUPG_VERSION = 1.5.0
+PHP_GNUPG_VERSION = 1.5.1
 PHP_GNUPG_SOURCE = gnupg-$(PHP_GNUPG_VERSION).tgz
 PHP_GNUPG_SITE = https://pecl.php.net/get
 # phpize does the autoconf magic