diff mbox series

[v1,1/1] package/go: bump to version 1.21.0

Message ID 20230829222230.1884427-1-christian@aperture.us
State Accepted
Headers show
Series [v1,1/1] package/go: bump to version 1.21.0 | expand

Commit Message

Christian Stewart Aug. 29, 2023, 10:22 p.m. UTC
Go 1.21.0 is a major release of Go.

https://go.dev/doc/devel/release#go1.21.0

Set GOTOOLCHAIN=local to disable the new toolchain download feature. This
feature, introduced in Go 1.21.x, will automatically download pre-built compiler
binaries from Google for the toolchain version specified in go.mod. We do not
want this in Buildroot as we build from source instead: set GOTOOLCHAIN=local to
disable the feature and use the locally built toolchain.

https://go.dev/doc/toolchain

Signed-off-by: Christian Stewart <christian@aperture.us>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Aug. 30, 2023, 9:58 p.m. UTC | #1
On Tue, 29 Aug 2023 15:22:30 -0700
Christian Stewart via buildroot <buildroot@buildroot.org> wrote:

> Go 1.21.0 is a major release of Go.
> 
> https://go.dev/doc/devel/release#go1.21.0
> 
> Set GOTOOLCHAIN=local to disable the new toolchain download feature. This
> feature, introduced in Go 1.21.x, will automatically download pre-built compiler
> binaries from Google for the toolchain version specified in go.mod. We do not
> want this in Buildroot as we build from source instead: set GOTOOLCHAIN=local to
> disable the feature and use the locally built toolchain.
> 
> https://go.dev/doc/toolchain
> 
> Signed-off-by: Christian Stewart <christian@aperture.us>
> ---
>  package/go/go.hash | 2 +-
>  package/go/go.mk   | 3 ++-
>  2 files changed, 3 insertions(+), 2 deletions(-)

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 2298534d91..2289442a72 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://go.dev/dl
-sha256  2c5ee9c9ec1e733b0dbbc2bdfed3f62306e51d8172bf38f4f4e542b27520f597  go1.20.7.src.tar.gz
+sha256  818d46ede85682dd551ad378ef37a4d247006f12ec59b5b755601d2ce114369a  go1.21.0.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index fc1d9ed681..04aa612256 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.20.7
+GO_VERSION = 1.21.0
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz
 
@@ -28,6 +28,7 @@  HOST_GO_COMMON_ENV = \
 	GOCACHE="$(HOST_GO_TARGET_CACHE)" \
 	GOMODCACHE="$(HOST_GO_GOPATH)/pkg/mod" \
 	GOPROXY=off \
+	GOTOOLCHAIN=local \
 	PATH=$(BR_PATH) \
 	GOBIN= \
 	CGO_ENABLED=$(HOST_GO_CGO_ENABLED)