diff mbox series

package/host-gdb: disable source-highlight

Message ID 20230818063521.6191-1-b.bilas@grinn-global.com
State Accepted
Headers show
Series package/host-gdb: disable source-highlight | expand

Commit Message

Bartosz Bilas Aug. 18, 2023, 6:35 a.m. UTC
This is the follow-up commit to the 4de60e4 which disables
sourcehighlight dependency for the target GDB package.
Do the same for the host variant to be sure that this
won't be picked up from the host system.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
 package/gdb/gdb.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN Aug. 20, 2023, 1:35 p.m. UTC | #1
Bartosz, All,

On 2023-08-18 08:35 +0200, Bartosz Bilas spake thusly:
> This is the follow-up commit to the 4de60e4 which disables
> sourcehighlight dependency for the target GDB package.
> Do the same for the host variant to be sure that this
> won't be picked up from the host system.
> 
> Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
> ---
>  package/gdb/gdb.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
> index cee7b37bcd..d9bfb39a41 100644
> --- a/package/gdb/gdb.mk
> +++ b/package/gdb/gdb.mk
> @@ -255,7 +255,8 @@ HOST_GDB_CONF_OPTS = \
>  	--with-system-zlib \
>  	--with-curses \
>  	--without-mpfr \
> -	$(GDB_DISABLE_BINUTILS_CONF_OPTS)
> +	$(GDB_DISABLE_BINUTILS_CONF_OPTS) \
> +	--disable-source-highlight

We like it better (but do not have clear rules bouat it) when the
unconditional options are passed first, and conditional ones last.

So I've inverted the order, and applied to master, thanks.

Regards,
Yann E. MORIN.

>  ifeq ($(BR2_PACKAGE_HOST_GDB_TUI),y)
>  HOST_GDB_CONF_OPTS += --enable-tui
> -- 
> 2.41.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Sept. 12, 2023, 6:08 a.m. UTC | #2
>>>>> "Bartosz" == Bartosz Bilas <b.bilas@grinn-global.com> writes:

 > This is the follow-up commit to the 4de60e4 which disables
 > sourcehighlight dependency for the target GDB package.
 > Do the same for the host variant to be sure that this
 > won't be picked up from the host system.

 > Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index cee7b37bcd..d9bfb39a41 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -255,7 +255,8 @@  HOST_GDB_CONF_OPTS = \
 	--with-system-zlib \
 	--with-curses \
 	--without-mpfr \
-	$(GDB_DISABLE_BINUTILS_CONF_OPTS)
+	$(GDB_DISABLE_BINUTILS_CONF_OPTS) \
+	--disable-source-highlight
 
 ifeq ($(BR2_PACKAGE_HOST_GDB_TUI),y)
 HOST_GDB_CONF_OPTS += --enable-tui