diff mbox series

[2/2] package/acpica: rename HOST make variable override to ACPI_HOST

Message ID 20230805230410.107850-2-ju.o@free.fr
State Accepted
Headers show
Series [1/2] package/acpica: remove HARDWARE_NAME make variable override | expand

Commit Message

Julien Olivain Aug. 5, 2023, 11:04 p.m. UTC
The HOST Makefile variable was renamed upstream to ACPI_HOST in [1].

This commit was first included in tag R02_14_20 (version 20200214).
See the change log [2].

This no longer correct use of HOST did not introduced any
compilation error, as the code uses constructs like:

    #if defined(_LINUX) || defined(__linux__)

This patch change the variable name to follow upstream, just for
correctness.

[1] https://github.com/acpica/acpica/commit/98753481f7321a7c8f2a79ff0158cdc5e73acace
[2] https://github.com/acpica/acpica/blob/R02_14_20/documents/changes.txt#L25

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/acpica/acpica.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/acpica/acpica.mk b/package/acpica/acpica.mk
index b932941369..bbabd9de69 100644
--- a/package/acpica/acpica.mk
+++ b/package/acpica/acpica.mk
@@ -14,7 +14,7 @@  HOST_ACPICA_DEPENDENCIES = host-bison host-flex
 
 define ACPICA_BUILD_CMDS
 	$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-		HOST=_LINUX CC="$(TARGET_CC)" \
+		ACPI_HOST=_LINUX CC="$(TARGET_CC)" \
 		NOWERROR=TRUE \
 		all
 endef