diff mbox series

[2/2] package/weston: introduce _SIMPLE_CLIENTS package option

Message ID 20230803201527.19108-2-ju.o@free.fr
State Accepted
Headers show
Series [1/2] package/weston: fix the configuration of simple-clients | expand

Commit Message

Julien Olivain Aug. 3, 2023, 8:15 p.m. UTC
commit "package/weston: fix the configuration of simple-clients"
fixed the configuration of Weston simple-clients by always enabling all
supported applications.

Since it is not desirable to always have all those applications
installed on target, this commit introduces a new package Kconfig
option to control this.

Since there is already a BR2_PACKAGE_WESTON_DEMO_CLIENTS option present,
this commit also update the Kconfig "help" entries, to clarify the
difference between those "demo clients" and "simple clients". Those
clients groups are directly coming from the upstream package (and are
directly mapped to Meson configure options).

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/weston/Config.in | 24 ++++++++++++++++++++++++
 package/weston/weston.mk |  4 ++++
 2 files changed, 28 insertions(+)

Comments

Yann E. MORIN Aug. 12, 2023, 6:35 p.m. UTC | #1
Julien, All,

On 2023-08-03 22:15 +0200, Julien Olivain spake thusly:
> commit "package/weston: fix the configuration of simple-clients"
> fixed the configuration of Weston simple-clients by always enabling all
> supported applications.
> 
> Since it is not desirable to always have all those applications
> installed on target, this commit introduces a new package Kconfig
> option to control this.
> 
> Since there is already a BR2_PACKAGE_WESTON_DEMO_CLIENTS option present,
> this commit also update the Kconfig "help" entries, to clarify the
> difference between those "demo clients" and "simple clients". Those
> clients groups are directly coming from the upstream package (and are
> directly mapped to Meson configure options).
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>
> ---
[--SNIP--]
> diff --git a/package/weston/weston.mk b/package/weston/weston.mk
> index 5f8d915d5a..0974159a9f 100644
> --- a/package/weston/weston.mk
> +++ b/package/weston/weston.mk
> @@ -22,6 +22,7 @@ WESTON_CONF_OPTS = \
>  	-Dlauncher-libseat=true \
>  	-Dtools=calibrator,debug,info,terminal,touch-calibrator
>  
> +ifeq ($(BR2_PACKAGE_WESTON_SIMPLE_CLIENTS),y)
>  WESTON_SIMPLE_CLIENTS = \
>  	damage \
>  	dmabuf-egl \
> @@ -37,6 +38,9 @@ WESTON_SIMPLE_CLIENTS += dmabuf-v4l
>  endif
>  
>  WESTON_CONF_OPTS += -Dsimple-clients=$(subst $(space),$(comma),$(strip $(WESTON_SIMPLE_CLIENTS)))
> +else
> +WESTON_CONF_OPTS += -Dsimple-clients=
> +endif

I moved the assignment outisde the conditional block, Indeed, if
BR2_PACKAGE_WESTON_SIMPLE_CLIENTS is unset, WESTON_SIMPLE_CLIENTS will
not be set and thus wil be empty, which is as good an empty list as we
need. ;-)

Applied to next, thanks.

Regards,
Yann E. MORIN.

>  ifeq ($(BR2_PACKAGE_JPEG),y)
>  WESTON_CONF_OPTS += -Dimage-jpeg=true
> -- 
> 2.41.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/weston/Config.in b/package/weston/Config.in
index 1a7c27a715..db6a78ee8a 100644
--- a/package/weston/Config.in
+++ b/package/weston/Config.in
@@ -174,6 +174,18 @@  config BR2_PACKAGE_WESTON_SCREENSHARE
 	bool "screenshare"
 	default y
 
+config BR2_PACKAGE_WESTON_SIMPLE_CLIENTS
+	bool "simple clients"
+	help
+	  Simple clients includes application such as:
+	  damage, dmabuf-feedback, dmabuf-egl, dmabuf-v4l, egl
+
+	  In the target filesystem, simple client program binaries are
+	  prefixed with "weston-simple-".
+
+	  Note: Weston has two sets of clients. See also the weston
+	  "demo clients" option.
+
 config BR2_PACKAGE_WESTON_DEMO_CLIENTS
 	bool "demo clients"
 	depends on BR2_USE_MMU # pango
@@ -188,6 +200,18 @@  config BR2_PACKAGE_WESTON_DEMO_CLIENTS
 	help
 	  This enables the installation of Weston's demo clients.
 
+	  Demo clients includes application such as:
+	  clickdot, confine, content_protection, dnd, editor,
+	  eventdemo, flower, fullscreen, image, multi-resource,
+	  presentation-shm, resizor, scaler, smoke, stacking,
+	  subsurfaces, tablet, transformed...
+
+	  In the target filesystem, demo client program binaries are
+	  prefixed with "weston-".
+
+	  Note: Weston has two sets of clients. See also the weston
+	  "simple clients" option.
+
 comment "demo clients needs an OpenGL ES provider, an OpenEGL-capable Wayland backend and a toolchain w/ wchar, threads, C++, gcc >= 4.9"
 	depends on BR2_USE_MMU
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4
diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index 5f8d915d5a..0974159a9f 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -22,6 +22,7 @@  WESTON_CONF_OPTS = \
 	-Dlauncher-libseat=true \
 	-Dtools=calibrator,debug,info,terminal,touch-calibrator
 
+ifeq ($(BR2_PACKAGE_WESTON_SIMPLE_CLIENTS),y)
 WESTON_SIMPLE_CLIENTS = \
 	damage \
 	dmabuf-egl \
@@ -37,6 +38,9 @@  WESTON_SIMPLE_CLIENTS += dmabuf-v4l
 endif
 
 WESTON_CONF_OPTS += -Dsimple-clients=$(subst $(space),$(comma),$(strip $(WESTON_SIMPLE_CLIENTS)))
+else
+WESTON_CONF_OPTS += -Dsimple-clients=
+endif
 
 ifeq ($(BR2_PACKAGE_JPEG),y)
 WESTON_CONF_OPTS += -Dimage-jpeg=true