diff mbox series

[v2,1/1] package/strace: use bundled headers

Message ID 20230713075740.328213-1-james.hilliard1@gmail.com
State New
Headers show
Series [v2,1/1] package/strace: use bundled headers | expand

Commit Message

James Hilliard July 13, 2023, 7:57 a.m. UTC
There is a bug in the configure script, while we could apply the
upstream patching fixing this bug the better solution is to switch
to using the bundled headers instead.

The reason for this is that strace needs the headers of the running
kernel rather than those that were used to build the toolchain.

The running kernel is often more recent than the one used in the
toolchain so we do want to use the more up-to-date headers.

As such we should use the strace bundled headers as they will be
the most up-to-date headers.

Details: https://github.com/strace/strace/issues/253

Fixes:
 - http://autobuild.buildroot.net/results/867/8675aeca53653d9d792182be61a28ea550dc530d

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
Changes v1 -> v2:
  - add more detailed description regarding bundled headers
---
 package/strace/strace.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 13, 2023, 8:11 p.m. UTC | #1
On Thu, 13 Jul 2023 01:57:40 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> There is a bug in the configure script, while we could apply the
> upstream patching fixing this bug the better solution is to switch
> to using the bundled headers instead.
> 
> The reason for this is that strace needs the headers of the running
> kernel rather than those that were used to build the toolchain.
> 
> The running kernel is often more recent than the one used in the
> toolchain so we do want to use the more up-to-date headers.
> 
> As such we should use the strace bundled headers as they will be
> the most up-to-date headers.

But then isn't there a chance that the bundled headers are too *recent*
compared to the running kernel? What happens in this case?

Thomas
Maxim Kochetkov July 13, 2023, 8:40 p.m. UTC | #2
On 13.07.2023 23:11, Thomas Petazzoni via buildroot wrote:
> On Thu, 13 Jul 2023 01:57:40 -0600
> James Hilliard <james.hilliard1@gmail.com> wrote:
> 
>> There is a bug in the configure script, while we could apply the
>> upstream patching fixing this bug the better solution is to switch
>> to using the bundled headers instead.
>>
>> The reason for this is that strace needs the headers of the running
>> kernel rather than those that were used to build the toolchain.
>>
>> The running kernel is often more recent than the one used in the
>> toolchain so we do want to use the more up-to-date headers.
>>
>> As such we should use the strace bundled headers as they will be
>> the most up-to-date headers.
> 
> But then isn't there a chance that the bundled headers are too *recent*
> compared to the running kernel? What happens in this case?

It looks like it is fixed:
https://github.com/strace/strace/commit/8f691206e4aa769cc99e264f1c15ae6956789f91

So let's try to upgrade to 6.4
James Hilliard July 13, 2023, 9:33 p.m. UTC | #3
On Thu, Jul 13, 2023 at 2:11 PM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> On Thu, 13 Jul 2023 01:57:40 -0600
> James Hilliard <james.hilliard1@gmail.com> wrote:
>
> > There is a bug in the configure script, while we could apply the
> > upstream patching fixing this bug the better solution is to switch
> > to using the bundled headers instead.
> >
> > The reason for this is that strace needs the headers of the running
> > kernel rather than those that were used to build the toolchain.
> >
> > The running kernel is often more recent than the one used in the
> > toolchain so we do want to use the more up-to-date headers.
> >
> > As such we should use the strace bundled headers as they will be
> > the most up-to-date headers.
>
> But then isn't there a chance that the bundled headers are too *recent*
> compared to the running kernel? What happens in this case?

I presume since strace is tracing syscalls made by other applications that
it shouldn't cause issues as it would be the traced application choosing
the syscalls to make.

>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
diff mbox series

Patch

diff --git a/package/strace/strace.mk b/package/strace/strace.mk
index 6514bfe354..9f6b333318 100644
--- a/package/strace/strace.mk
+++ b/package/strace/strace.mk
@@ -10,7 +10,7 @@  STRACE_SITE = https://github.com/strace/strace/releases/download/v$(STRACE_VERSI
 STRACE_LICENSE = LGPL-2.1+
 STRACE_LICENSE_FILES = COPYING LGPL-2.1-or-later
 STRACE_CPE_ID_VENDOR = strace_project
-STRACE_CONF_OPTS = --enable-mpers=no
+STRACE_CONF_OPTS = --enable-bundled=yes --enable-mpers=no
 
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 STRACE_DEPENDENCIES += libunwind