diff mbox series

package/iproute2: add optional dependency on libbpf

Message ID 20230703105819.flmwndqvctpjuolz@zenon.in.qult.net
State Changes Requested
Headers show
Series package/iproute2: add optional dependency on libbpf | expand

Commit Message

Ignacy Gawędzki July 3, 2023, 10:58 a.m. UTC
The configure script will automatically detect used pkg-config if
libbpf is available.

Signed-off-by: Ignacy Gawędzki <ignacy.gawedzki@green-communications.fr>
---
 package/iproute2/iproute2.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni July 3, 2023, 7:09 p.m. UTC | #1
Hello Ignacy,

Thanks for the patch!

On Mon, 3 Jul 2023 12:58:19 +0200
Ignacy Gawędzki <ignacy.gawedzki@green-communications.fr> wrote:

> +ifeq ($(BR2_PACKAGE_LIBBPF),y)
> +IPROUTE2_DEPENDENCIES += libbpf
> +endif

Could you test an improved version that passes LIBBPF_FORCE=on in the
enabled case and LIBBPF_FORCE=off in the disabled case?

According to the configure script:

check_force_libbpf_on()
{
    # if set LIBBPF_FORCE=on but no libbpf support, just exist the config
    # process to make sure we don't build without libbpf.
    if [ "$LIBBPF_FORCE" = on ]; then
        echo "  LIBBPF_FORCE=on set, but couldn't find a usable libbpf"
        exit 1
    fi
}

check_libbpf()
{
    # if set LIBBPF_FORCE=off, disable libbpf entirely
    if [ "$LIBBPF_FORCE" = off ]; then
        echo "no"
        return
    fi

Of course, both the enabled and disabled case need to be verified
before submitting v2 :-)

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 15af076db9..096e650b1d 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -38,6 +38,10 @@  ifeq ($(BR2_PACKAGE_BERKELEYDB_COMPAT185),y)
 IPROUTE2_DEPENDENCIES += berkeleydb
 endif
 
+ifeq ($(BR2_PACKAGE_LIBBPF),y)
+IPROUTE2_DEPENDENCIES += libbpf
+endif
+
 define IPROUTE2_CONFIGURE_CMDS
 	cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure
 	$(IPROUTE2_DISABLE_IPTABLES)