diff mbox series

[1/1] package/firmware-imx: ensure the linux firmware is installed first

Message ID 20230620170922.3722-1-ckhardin@gmail.com
State Accepted
Headers show
Series [1/1] package/firmware-imx: ensure the linux firmware is installed first | expand

Commit Message

Charles Hardin June 20, 2023, 5:09 p.m. UTC
There was imx SDMA firmware in the base linux-firmware package at
one time, but the firmware-imx is updated with the latest versions
from NXP releases.

This just ensures a dependency is set so that the imx package will
always come later in case an overlap occurs again.

Signed-off-by: Chares Hardin <ckhardin@gmail.com>
Signed-off-by: Charles Hardin <ckhardin@gmail.com>
---
 package/freescale-imx/firmware-imx/firmware-imx.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Gary Bisson June 28, 2023, 7:55 a.m. UTC | #1
Hi Charles,

On Tue, Jun 20, 2023 at 10:09:22AM -0700, Charles Hardin wrote:
> There was imx SDMA firmware in the base linux-firmware package at
> one time, but the firmware-imx is updated with the latest versions
> from NXP releases.
> 
> This just ensures a dependency is set so that the imx package will
> always come later in case an overlap occurs again.
> 
> Signed-off-by: Chares Hardin <ckhardin@gmail.com>

The above line seems to be here by mistake, please remove.

> Signed-off-by: Charles Hardin <ckhardin@gmail.com>

With that line removed:
Reviewed-by: Gary Bisson <bisson.gary@gmail.com>

Regards,
Gary
Thomas Petazzoni July 10, 2023, 6:50 p.m. UTC | #2
On Tue, 20 Jun 2023 10:09:22 -0700
Charles Hardin <ckhardin@gmail.com> wrote:

> There was imx SDMA firmware in the base linux-firmware package at
> one time, but the firmware-imx is updated with the latest versions
> from NXP releases.
> 
> This just ensures a dependency is set so that the imx package will
> always come later in case an overlap occurs again.
> 
> Signed-off-by: Chares Hardin <ckhardin@gmail.com>
> Signed-off-by: Charles Hardin <ckhardin@gmail.com>
> ---
>  package/freescale-imx/firmware-imx/firmware-imx.mk | 4 ++++
>  1 file changed, 4 insertions(+)

Applied to master, thanks.

That being said, the BR2_PER_PACKAGE_DIRECTORIES=y mechanism requires
that packages don't overwrite files installed by other packages, so at
some point, this will have to be revisited. But this issue exists for
many other packages anyway, and we are far from having addressed all
those issues.

Thomas
Peter Korsgaard Aug. 25, 2023, 12:53 p.m. UTC | #3
>>>>> "Charles" == Charles Hardin <ckhardin@gmail.com> writes:

 > There was imx SDMA firmware in the base linux-firmware package at
 > one time, but the firmware-imx is updated with the latest versions
 > from NXP releases.

 > This just ensures a dependency is set so that the imx package will
 > always come later in case an overlap occurs again.

 > Signed-off-by: Chares Hardin <ckhardin@gmail.com>
 > Signed-off-by: Charles Hardin <ckhardin@gmail.com>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/freescale-imx/firmware-imx/firmware-imx.mk b/package/freescale-imx/firmware-imx/firmware-imx.mk
index 99fe71a91c..4cceb67019 100644
--- a/package/freescale-imx/firmware-imx/firmware-imx.mk
+++ b/package/freescale-imx/firmware-imx/firmware-imx.mk
@@ -14,6 +14,10 @@  FIRMWARE_IMX_REDISTRIBUTE = NO
 
 FIRMWARE_IMX_INSTALL_IMAGES = YES
 
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE),y)
+FIRMWARE_IMX_DEPENDENCIES += linux-firmware
+endif
+
 define FIRMWARE_IMX_EXTRACT_CMDS
 	$(call NXP_EXTRACT_HELPER,$(FIRMWARE_IMX_DL_DIR)/$(FIRMWARE_IMX_SOURCE))
 endef