diff mbox series

[1/1] linux: make kconfig depend on host-make

Message ID 20230614144202.21459-1-fl@n621.de
State Accepted
Headers show
Series [1/1] linux: make kconfig depend on host-make | expand

Commit Message

Florian Larysch June 14, 2023, 2:42 p.m. UTC
Commit 0b9efc991f ("linux: use BR2_MAKE") switched LINUX_MAKE to
$(BR2_MAKE). However, this also implicitly sets LINUX_KCONFIG_MAKE.

Thus, when host-make is being used in a build that has
PER_PACKAGE_DIRECTORIES enabled, the dotconfig step will try to use the
make instance from the host directory, but since it is not listed in
LINUX_KCONFIG_DEPENDENCIES, it won't be available yet at that point in
time.

Add an explicit dependency to LINUX_KCONFIG_DEPENDENCIES to have it
copied over early enough.

Signed-off-by: Florian Larysch <fl@n621.de>
---
 linux/linux.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle June 19, 2023, 7:39 p.m. UTC | #1
On 14/06/2023 16:42, Florian Larysch wrote:
> Commit 0b9efc991f ("linux: use BR2_MAKE") switched LINUX_MAKE to
> $(BR2_MAKE). However, this also implicitly sets LINUX_KCONFIG_MAKE.
> 
> Thus, when host-make is being used in a build that has
> PER_PACKAGE_DIRECTORIES enabled, the dotconfig step will try to use the
> make instance from the host directory, but since it is not listed in
> LINUX_KCONFIG_DEPENDENCIES, it won't be available yet at that point in
> time.
> 
> Add an explicit dependency to LINUX_KCONFIG_DEPENDENCIES to have it
> copied over early enough.
> 
> Signed-off-by: Florian Larysch <fl@n621.de>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   linux/linux.mk | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/linux/linux.mk b/linux/linux.mk
> index cc36b5251d..1c4fe45ac9 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -88,7 +88,8 @@ LINUX_DEPENDENCIES += \
>   # only if the host does not have them.
>   LINUX_KCONFIG_DEPENDENCIES = \
>   	$(BR2_BISON_HOST_DEPENDENCY) \
> -	$(BR2_FLEX_HOST_DEPENDENCY)
> +	$(BR2_FLEX_HOST_DEPENDENCY) \
> +	$(BR2_MAKE_HOST_DEPENDENCY)
>   
>   # Starting with 4.18, the kconfig in the kernel calls the
>   # cross-compiler to check its capabilities. So we need the
Peter Korsgaard July 6, 2023, 11:38 a.m. UTC | #2
>>>>> "Florian" == Florian Larysch <fl@n621.de> writes:

 > Commit 0b9efc991f ("linux: use BR2_MAKE") switched LINUX_MAKE to
 > $(BR2_MAKE). However, this also implicitly sets LINUX_KCONFIG_MAKE.

 > Thus, when host-make is being used in a build that has
 > PER_PACKAGE_DIRECTORIES enabled, the dotconfig step will try to use the
 > make instance from the host directory, but since it is not listed in
 > LINUX_KCONFIG_DEPENDENCIES, it won't be available yet at that point in
 > time.

 > Add an explicit dependency to LINUX_KCONFIG_DEPENDENCIES to have it
 > copied over early enough.

 > Signed-off-by: Florian Larysch <fl@n621.de>

Committed to 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index cc36b5251d..1c4fe45ac9 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -88,7 +88,8 @@  LINUX_DEPENDENCIES += \
 # only if the host does not have them.
 LINUX_KCONFIG_DEPENDENCIES = \
 	$(BR2_BISON_HOST_DEPENDENCY) \
-	$(BR2_FLEX_HOST_DEPENDENCY)
+	$(BR2_FLEX_HOST_DEPENDENCY) \
+	$(BR2_MAKE_HOST_DEPENDENCY)
 
 # Starting with 4.18, the kconfig in the kernel calls the
 # cross-compiler to check its capabilities. So we need the