diff mbox series

[1/1] package/mesa3d: enable intel-xe-kmd

Message ID 20230608191840.3534303-1-bernd.kuhls@t-online.de
State Changes Requested
Headers show
Series [1/1] package/mesa3d: enable intel-xe-kmd | expand

Commit Message

Bernd Kuhls June 8, 2023, 7:18 p.m. UTC
ref:
- https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20418

Xe KMD is a fresh KMD implementation for Intel GPUs, you can read more
about it in here: https://patchwork.freedesktop.org/series/112188/
Xe KMD will only support Tigerlake and newer platforms, so here is added
Xe KMD support for Iris and ANV, to properly work it is necessary to
enable Xe KMD in build time with -Dintel-xe-kmd=enabled then in run time
it will check if you have i915 or Xe KMD loaded and take the appropriate
code paths.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/mesa3d/mesa3d.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Thomas Petazzoni July 26, 2023, 9:26 p.m. UTC | #1
On Thu,  8 Jun 2023 21:18:40 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> ref:
> - https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20418

According to this link "It is functional enough to run Gnome, browser, OpenGL games, Vulkan games... but eventual crashes and bugs are expected at this time.
No work has been done so far in optimizing for the new driver.", so are
you sure it is a good idea to enable this new/experimental feature as
soon as BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_IRIS ? Doesn't that mean that
users who currently successfully use the existing Iris driver as-is
will see regression because we now enable Xe KMD?

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
index feb8547e73..e4b03b65bb 100644
--- a/package/mesa3d/mesa3d.mk
+++ b/package/mesa3d/mesa3d.mk
@@ -98,6 +98,12 @@  else
 MESA3D_CONF_OPTS += -Dgallium-vc4-neon=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_IRIS),y)
+MESA3D_CONF_OPTS += -Dintel-xe-kmd=enabled
+else
+MESA3D_CONF_OPTS += -Dintel-xe-kmd=disabled
+endif
+
 # Drivers
 
 #Gallium Drivers