diff mbox series

[v3] package/qemu: install keyboard maps only if necessary

Message ID 20230524133138.60117-1-unixmania@gmail.com
State Accepted
Headers show
Series [v3] package/qemu: install keyboard maps only if necessary | expand

Commit Message

Carlos Santos May 24, 2023, 1:31 p.m. UTC
From: Carlos Santos <unixmania@gmail.com>

They are required only for system emulation, so pull a patch already
reviewd upstream that makes the installation conditional:

    https://patchwork.kernel.org/project/qemu-devel/patch/20230327172147.196607-1-casantos@redhat.com/

Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
Changes v1->v2
  - Fixed reference to uptream patch, using the QEMU patchwork
Changes v2->v3
  - Fix SOB, as required by the Buildroot policy
---
 ...tall-keyboard-maps-only-if-necessary.patch | 37 +++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 package/qemu/0003-meson-install-keyboard-maps-only-if-necessary.patch

Comments

Thomas Petazzoni July 12, 2023, 9:41 p.m. UTC | #1
On Wed, 24 May 2023 10:31:38 -0300
unixmania@gmail.com wrote:

> From: Carlos Santos <unixmania@gmail.com>
> 
> They are required only for system emulation, so pull a patch already
> reviewd upstream that makes the installation conditional:
> 
>     https://patchwork.kernel.org/project/qemu-devel/patch/20230327172147.196607-1-casantos@redhat.com/
> 
> Signed-off-by: Carlos Santos <unixmania@gmail.com>
> ---
> Changes v1->v2
>   - Fixed reference to uptream patch, using the QEMU patchwork
> Changes v2->v3
>   - Fix SOB, as required by the Buildroot policy
> ---
>  ...tall-keyboard-maps-only-if-necessary.patch | 37 +++++++++++++++++++
>  1 file changed, 37 insertions(+)
>  create mode 100644 package/qemu/0003-meson-install-keyboard-maps-only-if-necessary.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/qemu/0003-meson-install-keyboard-maps-only-if-necessary.patch b/package/qemu/0003-meson-install-keyboard-maps-only-if-necessary.patch
new file mode 100644
index 0000000000..be9d0ad59e
--- /dev/null
+++ b/package/qemu/0003-meson-install-keyboard-maps-only-if-necessary.patch
@@ -0,0 +1,37 @@ 
+From 9d9b74f806f5dbca53df6630c1a0591eaedd4500 Mon Sep 17 00:00:00 2001
+From: Carlos Santos <casantos@redhat.com>
+Date: Sun, 1 Jan 2023 21:00:57 -0300
+Subject: [PATCH] meson: install keyboard maps only if necessary
+
+They are required only for system emulation (i.e. have_system is true).
+
+Signed-off-by: Carlos Santos <casantos@redhat.com>
+Signed-off-by: Carlos Santos <unixmania@gmail.com>
+---
+ pc-bios/keymaps/meson.build | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/pc-bios/keymaps/meson.build b/pc-bios/keymaps/meson.build
+index 158a3b410c..bff3083313 100644
+--- a/pc-bios/keymaps/meson.build
++++ b/pc-bios/keymaps/meson.build
+@@ -47,7 +47,7 @@ if native_qemu_keymap.found()
+                        build_by_default: true,
+                        output: km,
+                        command: [native_qemu_keymap, '-f', '@OUTPUT@', args.split()],
+-                       install: true,
++                       install: have_system,
+                        install_dir: qemu_datadir / 'keymaps')
+   endforeach
+ 
+@@ -56,4 +56,6 @@ else
+   install_data(keymaps.keys(), install_dir: qemu_datadir / 'keymaps')
+ endif
+ 
+-install_data(['sl', 'sv'], install_dir: qemu_datadir / 'keymaps')
++if have_system
++  install_data(['sl', 'sv'], install_dir: qemu_datadir / 'keymaps')
++endif
+-- 
+2.31.1
+