diff mbox series

[1/1] package/mesa3d: fix build error with the i915 Gallium driver

Message ID 20230523160358.1270868-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/mesa3d: fix build error with the i915 Gallium driver | expand

Commit Message

Bernd Kuhls May 23, 2023, 4:03 p.m. UTC
The error was introduced by mesa3d commit
https://cgit.freedesktop.org/mesa/mesa/commit/?id=dfd20f002f388be3f168938bc1f25e91bb08bf98
which was first introduced in mesa3d 23.0.0, added with buildroot commit
89944e2c459d45dd4271c49e35dd4a13dfd850a4

Fixes:
http://autobuild.buildroot.net/results/9c1/9c1407ca5be221dbb3ee03d2a95ada65bb7eb36b/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 ...5-Gallium-driver-includes-Intel-sour.patch | 46 +++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch

Comments

Arnout Vandecappelle June 3, 2023, 7:35 p.m. UTC | #1
On 23/05/2023 18:03, Bernd Kuhls wrote:
> The error was introduced by mesa3d commit
> https://cgit.freedesktop.org/mesa/mesa/commit/?id=dfd20f002f388be3f168938bc1f25e91bb08bf98
> which was first introduced in mesa3d 23.0.0, added with buildroot commit
> 89944e2c459d45dd4271c49e35dd4a13dfd850a4
> 
> Fixes:
> http://autobuild.buildroot.net/results/9c1/9c1407ca5be221dbb3ee03d2a95ada65bb7eb36b/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

  Applied to master, thanks.

  Peter, this one is *NOT* for 2023.02.

> ---
>   ...5-Gallium-driver-includes-Intel-sour.patch | 46 +++++++++++++++++++
>   1 file changed, 46 insertions(+)
>   create mode 100644 package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch

  In parallel with this one, Romain introduced a patch 0005 already, so I 
renamed it to 0006.

> 
> diff --git a/package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch b/package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch
> new file mode 100644
> index 0000000000..1f57702eb6
> --- /dev/null
> +++ b/package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch
> @@ -0,0 +1,46 @@
> +From cd861b7f38e448822ce765aee61304d1e0a3a8b5 Mon Sep 17 00:00:00 2001
> +From: James Knight <james.d.knight@live.com>
> +Date: Thu, 13 Apr 2023 16:38:51 -0400
> +Subject: meson: ensure i915 Gallium driver includes Intel sources
> +
> +Ensure builds flag the use of Intel sources when the i915 Gallium driver
> +is configured (`-Dgallium-drivers=i915`). Otherwise, a build may fail if
> +other Intel-based configuration options are not enabled:
> +
> +    ./src/gallium/winsys/i915/drm/meson.build:21:0: ERROR: Unknown variable "libintel_common".
> +
> +Signed-off-by: James Knight <james.d.knight@live.com>
> +Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22490>
> +
> +Upstream: https://cgit.freedesktop.org/mesa/mesa/commit/?id=cd861b7f38e448822ce765aee61304d1e0a3a8b5

  mesa3d documentation now points to the gitlab instance instead of cgit, so I 
used that here as well. I believe the intention is to drop the cgit instance at 
some point.

  Regards,
  Arnout

> +
> +Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> +---
> + meson.build | 9 ++++++++-
> + 1 file changed, 8 insertions(+), 1 deletion(-)
> +
> +(limited to 'meson.build')
> +
> +diff --git a/meson.build b/meson.build
> +index 23d2d965b37..a3e3c5478a8 100644
> +--- a/meson.build
> ++++ b/meson.build
> +@@ -245,7 +245,14 @@ with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
> + with_any_vk = _vulkan_drivers.length() != 0
> +
> + with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk
> +-with_any_intel = with_intel_vk or with_intel_hasvk or with_gallium_iris or with_gallium_crocus or with_intel_tools
> ++with_any_intel = [
> ++  with_gallium_crocus,
> ++  with_gallium_i915,
> ++  with_gallium_iris,
> ++  with_intel_hasvk,
> ++  with_intel_tools,
> ++  with_intel_vk,
> ++].contains(true)
> +
> + if with_swrast_vk and not with_gallium_softpipe
> +   error('swrast vulkan requires gallium swrast')
> +--
> +cgit v1.2.1
> +
Peter Korsgaard June 14, 2023, 1:34 p.m. UTC | #2
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > The error was introduced by mesa3d commit
 > https://cgit.freedesktop.org/mesa/mesa/commit/?id=dfd20f002f388be3f168938bc1f25e91bb08bf98
 > which was first introduced in mesa3d 23.0.0, added with buildroot commit
 > 89944e2c459d45dd4271c49e35dd4a13dfd850a4

 > Fixes:
 > http://autobuild.buildroot.net/results/9c1/9c1407ca5be221dbb3ee03d2a95ada65bb7eb36b/

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch b/package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch
new file mode 100644
index 0000000000..1f57702eb6
--- /dev/null
+++ b/package/mesa3d/0005-meson-ensure-i915-Gallium-driver-includes-Intel-sour.patch
@@ -0,0 +1,46 @@ 
+From cd861b7f38e448822ce765aee61304d1e0a3a8b5 Mon Sep 17 00:00:00 2001
+From: James Knight <james.d.knight@live.com>
+Date: Thu, 13 Apr 2023 16:38:51 -0400
+Subject: meson: ensure i915 Gallium driver includes Intel sources
+
+Ensure builds flag the use of Intel sources when the i915 Gallium driver
+is configured (`-Dgallium-drivers=i915`). Otherwise, a build may fail if
+other Intel-based configuration options are not enabled:
+
+    ./src/gallium/winsys/i915/drm/meson.build:21:0: ERROR: Unknown variable "libintel_common".
+
+Signed-off-by: James Knight <james.d.knight@live.com>
+Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22490>
+
+Upstream: https://cgit.freedesktop.org/mesa/mesa/commit/?id=cd861b7f38e448822ce765aee61304d1e0a3a8b5
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ meson.build | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+(limited to 'meson.build')
+
+diff --git a/meson.build b/meson.build
+index 23d2d965b37..a3e3c5478a8 100644
+--- a/meson.build
++++ b/meson.build
+@@ -245,7 +245,14 @@ with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
+ with_any_vk = _vulkan_drivers.length() != 0
+ 
+ with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk
+-with_any_intel = with_intel_vk or with_intel_hasvk or with_gallium_iris or with_gallium_crocus or with_intel_tools
++with_any_intel = [
++  with_gallium_crocus,
++  with_gallium_i915,
++  with_gallium_iris,
++  with_intel_hasvk,
++  with_intel_tools,
++  with_intel_vk,
++].contains(true)
+ 
+ if with_swrast_vk and not with_gallium_softpipe
+   error('swrast vulkan requires gallium swrast')
+-- 
+cgit v1.2.1
+