diff mbox series

[v5,4/4,optional] pkg-cmake: make ninja the default for all packages

Message ID 20230516082155.22014-4-thomas@devoogdt.com
State Superseded
Headers show
Series [v5,1/4] pkg-cmake: add option to select the Ninja generator | expand

Commit Message

Thomas Devoogdt May 16, 2023, 8:21 a.m. UTC
From: Thomas Devoogdt <thomas.devoogdt@barco.com>

Use ninja as the default generator.
A fun fact is that we of course have to disable ninja when building ninja.

Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
v5: add this optional commit
---
 package/ninja/ninja.mk | 1 +
 package/pkg-cmake.mk   | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/ninja/ninja.mk b/package/ninja/ninja.mk
index b7bc1a4f1c..85dd2e05aa 100644
--- a/package/ninja/ninja.mk
+++ b/package/ninja/ninja.mk
@@ -9,6 +9,7 @@  NINJA_VERSION = $(NINJA_VERSION_MAJOR).g95dee.kitware.jobserver-1
 NINJA_SITE = $(call github,Kitware,ninja,v$(NINJA_VERSION))
 NINJA_LICENSE = Apache-2.0
 NINJA_LICENSE_FILES = COPYING
+NINJA_CMAKE_NINJA = NO
 
 define HOST_NINJA_INSTALL_CMDS
 	$(INSTALL) -m 0755 -D $(@D)/ninja $(HOST_DIR)/bin/ninja
diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 36ab88d3a1..dab87c81f4 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -52,7 +52,7 @@  endif
 define inner-cmake-package
 
 $(3)_SUPPORTS_IN_SOURCE_BUILD ?= YES
-
+$(3)_CMAKE_NINJA ?= YES
 
 ifeq ($$($(3)_SUPPORTS_IN_SOURCE_BUILD),YES)
 $(2)_BUILDDIR			= $$($(2)_SRCDIR)