diff mbox series

[1/1] package/go: security bump to version 1.19.9

Message ID 20230502232308.2974424-1-christian@aperture.us
State Accepted
Headers show
Series [1/1] package/go: security bump to version 1.19.9 | expand

Commit Message

Christian Stewart May 2, 2023, 11:23 p.m. UTC
go1.19.9 (released 2023-05-02) includes three security fixes to the
html/template package, as well as bug fixes to the compiler, the runtime, and
the crypto/subtle, crypto/tls, net/http, and syscall packages.

CVE-2023-24539: html/template: improper sanitization of CSS values
CVE-2023-24540: html/template: improper handling of JavaScript whitespace
CVE-2023-29400: html/template: improper handling of empty HTML attributes

https://go.dev/doc/devel/release#go1.19.9
https://github.com/golang/go/issues?q=milestone%3AGo1.19.9+label%3ACherryPickApproved

Signed-off-by: Christian Stewart <christian@aperture.us>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard May 3, 2023, 8:31 p.m. UTC | #1
On 03/05/2023 01.23, Christian Stewart wrote:
> go1.19.9 (released 2023-05-02) includes three security fixes to the
> html/template package, as well as bug fixes to the compiler, the runtime, and
> the crypto/subtle, crypto/tls, net/http, and syscall packages.
> 
> CVE-2023-24539: html/template: improper sanitization of CSS values
> CVE-2023-24540: html/template: improper handling of JavaScript whitespace
> CVE-2023-29400: html/template: improper handling of empty HTML attributes
> 
> https://go.dev/doc/devel/release#go1.19.9
> https://github.com/golang/go/issues?q=milestone%3AGo1.19.9+label%3ACherryPickApproved
> 
> Signed-off-by: Christian Stewart <christian@aperture.us>

Committed, thanks
Peter Korsgaard May 4, 2023, 7:16 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > On 03/05/2023 01.23, Christian Stewart wrote:
 >> go1.19.9 (released 2023-05-02) includes three security fixes to the
 >> html/template package, as well as bug fixes to the compiler, the runtime, and
 >> the crypto/subtle, crypto/tls, net/http, and syscall packages.
 >> CVE-2023-24539: html/template: improper sanitization of CSS values
 >> CVE-2023-24540: html/template: improper handling of JavaScript whitespace
 >> CVE-2023-29400: html/template: improper handling of empty HTML attributes
 >> https://go.dev/doc/devel/release#go1.19.9
 >> https://github.com/golang/go/issues?q=milestone%3AGo1.19.9+label%3ACherryPickApproved
 >> Signed-off-by: Christian Stewart <christian@aperture.us>

 > Committed, thanks

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 5488ed9710..ffe42bf395 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://go.dev/dl
-sha256  1d7a67929dccafeaf8a29e55985bc2b789e0499cb1a17100039f084e3238da2f  go1.19.8.src.tar.gz
+sha256  131190a4697a70c5b1d232df5d3f55a3f9ec0e78e40516196ffb3f09ae6a5744  go1.19.9.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index 37554ddf86..89c3577982 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.19.8
+GO_VERSION = 1.19.9
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz