diff mbox series

package/pciutils: bump to version 3.9.0

Message ID 20230328162715.1502327-1-francois.perrad@gadz.org
State Accepted
Headers show
Series package/pciutils: bump to version 3.9.0 | expand

Commit Message

Francois Perrad March 28, 2023, 4:27 p.m. UTC
remove patch, see commit "Avoid adding multiple version tags to the same symbol"

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 ...nd-build-failure-with-older-binutils.patch | 57 -------------------
 package/pciutils/Config.in                    |  2 +-
 package/pciutils/pciutils.hash                |  2 +-
 package/pciutils/pciutils.mk                  |  2 +-
 4 files changed, 3 insertions(+), 60 deletions(-)
 delete mode 100644 package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch

Comments

Baruch Siach March 28, 2023, 7:35 p.m. UTC | #1
Hi Francois,

On Tue, Mar 28 2023, Francois Perrad wrote:

> remove patch, see commit "Avoid adding multiple version tags to the same symbol"

That is upstream commit 0478e1f3928bf.

Thanks for the patch.

baruch

> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  ...nd-build-failure-with-older-binutils.patch | 57 -------------------
>  package/pciutils/Config.in                    |  2 +-
>  package/pciutils/pciutils.hash                |  2 +-
>  package/pciutils/pciutils.mk                  |  2 +-
>  4 files changed, 3 insertions(+), 60 deletions(-)
>  delete mode 100644 package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch
>
> diff --git a/package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch b/package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch
> deleted file mode 100644
> index 1590bc19c..000000000
> --- a/package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch
> +++ /dev/null
> @@ -1,57 +0,0 @@
> -From fda20d4bcb91f0f9d0db294b4813264de2d88866 Mon Sep 17 00:00:00 2001
> -From: Baruch Siach <baruch@tkos.co.il>
> -Date: Thu, 12 May 2022 16:16:21 +0300
> -Subject: [PATCH] Workaround build failure with older binutils
> -
> -binutils releases older than 2.35 are affected by bug gas/23840[1] that
> -breaks the link of shared library:
> -
> -cc -O2 -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes -fPIC -fvisibility=hidden   -c -o filter.o filter.c
> -/tmp/ccLtucRG.s: Assembler messages:
> -/tmp/ccLtucRG.s:6: Error: multiple versions [`pci_filter_init@@LIBPCI_3.8'|`pci_filter_init@LIBPCI_3.3'] for symbol `pci_filter_init_v38'
> -/tmp/ccLtucRG.s:8: Error: multiple versions [`pci_filter_parse_slot@@LIBPCI_3.8'|`pci_filter_parse_slot@LIBPCI_3.3'] for symbol `pci_filter_parse_slot_v38'
> -/tmp/ccLtucRG.s:10: Error: multiple versions [`pci_filter_parse_id@@LIBPCI_3.8'|`pci_filter_parse_id@LIBPCI_3.3'] for symbol `pci_filter_parse_id_v38'
> -/tmp/ccLtucRG.s:12: Error: multiple versions [`pci_filter_match@@LIBPCI_3.8'|`pci_filter_match@LIBPCI_3.3'] for symbol `pci_filter_match_v38'
> -
> -The symbol versioning feature has little value in the context of
> -Buildroot. As a workaround remove one of each duplicated symbol.
> -
> -[1] https://sourceware.org/bugzilla/show_bug.cgi?id=23840
> -
> -Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ----
> -Upstream status: not upstreamable
> -
> -Upstream bug report: https://lore.kernel.org/linux-pci/87mtfm7v58.fsf@tarshish/
> ----
> - lib/filter.c | 4 ----
> - 1 file changed, 4 deletions(-)
> -
> -diff --git a/lib/filter.c b/lib/filter.c
> -index b881b6bc9083..bc34e8c2bab9 100644
> ---- a/lib/filter.c
> -+++ b/lib/filter.c
> -@@ -304,20 +304,16 @@ pci_filter_match_v30(struct pci_filter_v30 *f, struct pci_dev *d)
> - 
> - STATIC_ALIAS(void pci_filter_init(struct pci_access *a, struct pci_filter *f), pci_filter_init_v38(a, f));
> - SYMBOL_VERSION(pci_filter_init_v30, pci_filter_init@LIBPCI_3.0);
> --SYMBOL_VERSION(pci_filter_init_v38, pci_filter_init@LIBPCI_3.3);
> - SYMBOL_VERSION(pci_filter_init_v38, pci_filter_init@@LIBPCI_3.8);
> - 
> - STATIC_ALIAS(char *pci_filter_parse_slot(struct pci_filter *f, char *str), pci_filter_parse_slot_v38(f, str));
> - SYMBOL_VERSION(pci_filter_parse_slot_v30, pci_filter_parse_slot@LIBPCI_3.0);
> --SYMBOL_VERSION(pci_filter_parse_slot_v38, pci_filter_parse_slot@LIBPCI_3.3);
> - SYMBOL_VERSION(pci_filter_parse_slot_v38, pci_filter_parse_slot@@LIBPCI_3.8);
> - 
> - STATIC_ALIAS(char *pci_filter_parse_id(struct pci_filter *f, char *str), pci_filter_parse_id_v38(f, str));
> - SYMBOL_VERSION(pci_filter_parse_id_v30, pci_filter_parse_id@LIBPCI_3.0);
> --SYMBOL_VERSION(pci_filter_parse_id_v38, pci_filter_parse_id@LIBPCI_3.3);
> - SYMBOL_VERSION(pci_filter_parse_id_v38, pci_filter_parse_id@@LIBPCI_3.8);
> - 
> - STATIC_ALIAS(int pci_filter_match(struct pci_filter *f, struct pci_dev *d), pci_filter_match_v38(f, d));
> - SYMBOL_VERSION(pci_filter_match_v30, pci_filter_match@LIBPCI_3.0);
> --SYMBOL_VERSION(pci_filter_match_v38, pci_filter_match@LIBPCI_3.3);
> - SYMBOL_VERSION(pci_filter_match_v38, pci_filter_match@@LIBPCI_3.8);
> --- 
> -2.35.1
> -
> diff --git a/package/pciutils/Config.in b/package/pciutils/Config.in
> index a082f2399..d16c36340 100644
> --- a/package/pciutils/Config.in
> +++ b/package/pciutils/Config.in
> @@ -4,4 +4,4 @@ config BR2_PACKAGE_PCIUTILS
>  	  Various utilities dealing with the PCI bus.
>  	  Provides things like setpci and lspci.
>  
> -	  http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
> +	  https://mj.ucw.cz/sw/pciutils/
> diff --git a/package/pciutils/pciutils.hash b/package/pciutils/pciutils.hash
> index 0b66b8258..93df1558f 100644
> --- a/package/pciutils/pciutils.hash
> +++ b/package/pciutils/pciutils.hash
> @@ -1,3 +1,3 @@
>  # From https://www.kernel.org/pub/software/utils/pciutils/sha256sums.asc
> -sha256  91edbd0429a84705c9ad156d4ff38ccc724d41ea54c4c5b88e38e996f8a34f05  pciutils-3.8.0.tar.xz
> +sha256  cdea7ae97239dee23249a09c68a19a287a3f109fbeb2c232ebb616cb38599012  pciutils-3.9.0.tar.xz
>  sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING
> diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
> index 140276dbc..95b377d84 100644
> --- a/package/pciutils/pciutils.mk
> +++ b/package/pciutils/pciutils.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -PCIUTILS_VERSION = 3.8.0
> +PCIUTILS_VERSION = 3.9.0
>  PCIUTILS_SITE = $(BR2_KERNEL_MIRROR)/software/utils/pciutils
>  PCIUTILS_SOURCE = pciutils-$(PCIUTILS_VERSION).tar.xz
>  PCIUTILS_INSTALL_STAGING = YES
Peter Korsgaard May 1, 2023, 11:14 a.m. UTC | #2
>>>>> "Francois" == Francois Perrad <fperrad@gmail.com> writes:

 > remove patch, see commit "Avoid adding multiple version tags to the same symbol"
 > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>

Committed after adding a reference to the specific git commit as
suggested by Baruch, thanks.
diff mbox series

Patch

diff --git a/package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch b/package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch
deleted file mode 100644
index 1590bc19c..000000000
--- a/package/pciutils/0001-Workaround-build-failure-with-older-binutils.patch
+++ /dev/null
@@ -1,57 +0,0 @@ 
-From fda20d4bcb91f0f9d0db294b4813264de2d88866 Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Thu, 12 May 2022 16:16:21 +0300
-Subject: [PATCH] Workaround build failure with older binutils
-
-binutils releases older than 2.35 are affected by bug gas/23840[1] that
-breaks the link of shared library:
-
-cc -O2 -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes -fPIC -fvisibility=hidden   -c -o filter.o filter.c
-/tmp/ccLtucRG.s: Assembler messages:
-/tmp/ccLtucRG.s:6: Error: multiple versions [`pci_filter_init@@LIBPCI_3.8'|`pci_filter_init@LIBPCI_3.3'] for symbol `pci_filter_init_v38'
-/tmp/ccLtucRG.s:8: Error: multiple versions [`pci_filter_parse_slot@@LIBPCI_3.8'|`pci_filter_parse_slot@LIBPCI_3.3'] for symbol `pci_filter_parse_slot_v38'
-/tmp/ccLtucRG.s:10: Error: multiple versions [`pci_filter_parse_id@@LIBPCI_3.8'|`pci_filter_parse_id@LIBPCI_3.3'] for symbol `pci_filter_parse_id_v38'
-/tmp/ccLtucRG.s:12: Error: multiple versions [`pci_filter_match@@LIBPCI_3.8'|`pci_filter_match@LIBPCI_3.3'] for symbol `pci_filter_match_v38'
-
-The symbol versioning feature has little value in the context of
-Buildroot. As a workaround remove one of each duplicated symbol.
-
-[1] https://sourceware.org/bugzilla/show_bug.cgi?id=23840
-
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
-Upstream status: not upstreamable
-
-Upstream bug report: https://lore.kernel.org/linux-pci/87mtfm7v58.fsf@tarshish/
----
- lib/filter.c | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/lib/filter.c b/lib/filter.c
-index b881b6bc9083..bc34e8c2bab9 100644
---- a/lib/filter.c
-+++ b/lib/filter.c
-@@ -304,20 +304,16 @@ pci_filter_match_v30(struct pci_filter_v30 *f, struct pci_dev *d)
- 
- STATIC_ALIAS(void pci_filter_init(struct pci_access *a, struct pci_filter *f), pci_filter_init_v38(a, f));
- SYMBOL_VERSION(pci_filter_init_v30, pci_filter_init@LIBPCI_3.0);
--SYMBOL_VERSION(pci_filter_init_v38, pci_filter_init@LIBPCI_3.3);
- SYMBOL_VERSION(pci_filter_init_v38, pci_filter_init@@LIBPCI_3.8);
- 
- STATIC_ALIAS(char *pci_filter_parse_slot(struct pci_filter *f, char *str), pci_filter_parse_slot_v38(f, str));
- SYMBOL_VERSION(pci_filter_parse_slot_v30, pci_filter_parse_slot@LIBPCI_3.0);
--SYMBOL_VERSION(pci_filter_parse_slot_v38, pci_filter_parse_slot@LIBPCI_3.3);
- SYMBOL_VERSION(pci_filter_parse_slot_v38, pci_filter_parse_slot@@LIBPCI_3.8);
- 
- STATIC_ALIAS(char *pci_filter_parse_id(struct pci_filter *f, char *str), pci_filter_parse_id_v38(f, str));
- SYMBOL_VERSION(pci_filter_parse_id_v30, pci_filter_parse_id@LIBPCI_3.0);
--SYMBOL_VERSION(pci_filter_parse_id_v38, pci_filter_parse_id@LIBPCI_3.3);
- SYMBOL_VERSION(pci_filter_parse_id_v38, pci_filter_parse_id@@LIBPCI_3.8);
- 
- STATIC_ALIAS(int pci_filter_match(struct pci_filter *f, struct pci_dev *d), pci_filter_match_v38(f, d));
- SYMBOL_VERSION(pci_filter_match_v30, pci_filter_match@LIBPCI_3.0);
--SYMBOL_VERSION(pci_filter_match_v38, pci_filter_match@LIBPCI_3.3);
- SYMBOL_VERSION(pci_filter_match_v38, pci_filter_match@@LIBPCI_3.8);
--- 
-2.35.1
-
diff --git a/package/pciutils/Config.in b/package/pciutils/Config.in
index a082f2399..d16c36340 100644
--- a/package/pciutils/Config.in
+++ b/package/pciutils/Config.in
@@ -4,4 +4,4 @@  config BR2_PACKAGE_PCIUTILS
 	  Various utilities dealing with the PCI bus.
 	  Provides things like setpci and lspci.
 
-	  http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
+	  https://mj.ucw.cz/sw/pciutils/
diff --git a/package/pciutils/pciutils.hash b/package/pciutils/pciutils.hash
index 0b66b8258..93df1558f 100644
--- a/package/pciutils/pciutils.hash
+++ b/package/pciutils/pciutils.hash
@@ -1,3 +1,3 @@ 
 # From https://www.kernel.org/pub/software/utils/pciutils/sha256sums.asc
-sha256  91edbd0429a84705c9ad156d4ff38ccc724d41ea54c4c5b88e38e996f8a34f05  pciutils-3.8.0.tar.xz
+sha256  cdea7ae97239dee23249a09c68a19a287a3f109fbeb2c232ebb616cb38599012  pciutils-3.9.0.tar.xz
 sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 140276dbc..95b377d84 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-PCIUTILS_VERSION = 3.8.0
+PCIUTILS_VERSION = 3.9.0
 PCIUTILS_SITE = $(BR2_KERNEL_MIRROR)/software/utils/pciutils
 PCIUTILS_SOURCE = pciutils-$(PCIUTILS_VERSION).tar.xz
 PCIUTILS_INSTALL_STAGING = YES