diff mbox series

[v2] package/linux-tools: add USB tools (testusb and ffs-test)

Message ID 20230327135948.90710-1-luca.ceresoli@bootlin.com
State Accepted
Headers show
Series [v2] package/linux-tools: add USB tools (testusb and ffs-test) | expand

Commit Message

Luca Ceresoli March 27, 2023, 1:59 p.m. UTC
Extend the linux-tools package to also build the userspace USB tools, which
currently include testusb and ffs-test.

These tools are in the kernel tree since a long time, but a Makefile was
added only in 5.9 to allow building in the same way as other tools provided
with the kernel. Here we use the Makefile and thus version >= 5.9 is
required. Support for older kernels may be added later if needed.

Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>

---

Changes in v2:

 - Use ALL_TARGETS to select tools to build and install instead of the ugly
   removal logic
---
 DEVELOPERS                                    |  1 +
 package/linux-tools/Config.in                 | 26 ++++++++++++++
 package/linux-tools/linux-tool-usbtools.mk.in | 34 +++++++++++++++++++
 3 files changed, 61 insertions(+)
 create mode 100644 package/linux-tools/linux-tool-usbtools.mk.in

Comments

Herve Codina March 27, 2023, 2:52 p.m. UTC | #1
Hi Luca,

On Mon, 27 Mar 2023 15:59:48 +0200
Luca Ceresoli <luca.ceresoli@bootlin.com> wrote:

> Extend the linux-tools package to also build the userspace USB tools, which
> currently include testusb and ffs-test.
> 
> These tools are in the kernel tree since a long time, but a Makefile was
> added only in 5.9 to allow building in the same way as other tools provided
> with the kernel. Here we use the Makefile and thus version >= 5.9 is
> required. Support for older kernels may be added later if needed.
> 
> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
> 
> ---
> 
> Changes in v2:
> 
>  - Use ALL_TARGETS to select tools to build and install instead of the ugly
>    removal logic
> ---
>  DEVELOPERS                                    |  1 +
>  package/linux-tools/Config.in                 | 26 ++++++++++++++
>  package/linux-tools/linux-tool-usbtools.mk.in | 34 +++++++++++++++++++
>  3 files changed, 61 insertions(+)
>  create mode 100644 package/linux-tools/linux-tool-usbtools.mk.in
> 

Thanks for this v2.

Reviewed-by: Herve Codina <herve.codina@bootlin.com>

Regards,
Hervé
Yann E. MORIN March 28, 2023, 7:56 p.m. UTC | #2
Luca, All,

On 2023-03-27 15:59 +0200, Luca Ceresoli spake thusly:
> Extend the linux-tools package to also build the userspace USB tools, which
> currently include testusb and ffs-test.
> 
> These tools are in the kernel tree since a long time, but a Makefile was
> added only in 5.9 to allow building in the same way as other tools provided

That is not entirely correct.

The Makefile itself has been present since 2.6.39, but indeed only
gained an install rule for 5.9:

    4f22ce7045c1  2011-02-17  USB: tools: Add a Makefile
    9ca325ffcac4  2020-08-19  tools: usb: move to tools buildsystem

So I've tweaked the commit log accordingly.

> with the kernel. Here we use the Makefile and thus version >= 5.9 is
> required. Support for older kernels may be added later if needed.
> 
> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> 
> Changes in v2:
> 
>  - Use ALL_TARGETS to select tools to build and install instead of the ugly
>    removal logic
> ---
>  DEVELOPERS                                    |  1 +
>  package/linux-tools/Config.in                 | 26 ++++++++++++++
>  package/linux-tools/linux-tool-usbtools.mk.in | 34 +++++++++++++++++++
>  3 files changed, 61 insertions(+)
>  create mode 100644 package/linux-tools/linux-tool-usbtools.mk.in
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index b6d288c54fa9..67c6004ddf2e 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1874,6 +1874,7 @@ F:	configs/zynqmp_zcu106_defconfig
>  F:	package/agentpp/
>  F:	package/exim/
>  F:	package/libpjsip/
> +F:	package/linux-tools/linux-tool-usbtools.mk.in
>  F:	package/qpid-proton/
>  F:	package/rtl8188eu/
>  F:	package/snmppp/
> diff --git a/package/linux-tools/Config.in b/package/linux-tools/Config.in
> index 8a0b6d5802cc..451b0eeff5bb 100644
> --- a/package/linux-tools/Config.in
> +++ b/package/linux-tools/Config.in
> @@ -135,6 +135,32 @@ comment "selftests needs BR2_PACKAGE_BUSYBOX_SHOW_OTHERS and a toolchain w/ dyna
>  	depends on !BR2_PACKAGE_BUSYBOX_SHOW_OTHERS || \
>  		BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14
>  
> +config BR2_PACKAGE_LINUX_TOOLS_USBTOOLS
> +	bool "USB test programs"
> +	select BR2_PACKAGE_LINUX_TOOLS
> +	help
> +	  Build and install the USB test tools.
> +
> +	  These tools exist since Linux 2.6.35, but Buildroot can build
> +	  them only with kernel versions 5.9 and later.
> +
> +if BR2_PACKAGE_LINUX_TOOLS_USBTOOLS
> +
> +config BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_TESTUSB
> +	bool "testusb"
> +	help
> +	  testusb issues ioctls to perform the tests implemented by the
> +	  kernel driver.  It can generate a variety of transfer
> +	  patterns.
> +
> +	  See http://www.linux-usb.org/usbtest/
> +
> +config BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_FFSTEST
> +	bool "ffs-test"
> +	help
> +	  User mode filesystem api for usb composite function
> +endif
> +
>  config BR2_PACKAGE_LINUX_TOOLS_TMON
>  	bool "tmon"
>  	depends on BR2_TOOLCHAIN_HAS_THREADS
> diff --git a/package/linux-tools/linux-tool-usbtools.mk.in b/package/linux-tools/linux-tool-usbtools.mk.in
> new file mode 100644
> index 000000000000..797758adce51
> --- /dev/null
> +++ b/package/linux-tools/linux-tool-usbtools.mk.in
> @@ -0,0 +1,34 @@
> +################################################################################
> +#
> +# usbtools
> +#
> +################################################################################
> +
> +LINUX_TOOLS += usbtools
> +
> +USBTOOLS_MAKE_OPTS = $(LINUX_MAKE_FLAGS) LDFLAGS="$(TARGET_LDFLAGS)"
> +
> +LINUX_TOOLS_USBTOOLS_LIST = \
> +	$(if $(BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_TESTUSB),testusb) \
> +	$(if $(BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_FFSTEST),ffs-test)
> +
> +define USBTOOLS_BUILD_CMDS
> +	$(Q)if ! grep install $(LINUX_DIR)/tools/usb/Makefile >/dev/null 2>&1 ; then \
> +		echo "Your kernel version is too old to build the USB tools." ; \
> +		echo "At least kernel 5.9 must be used." ; \
> +		exit 1 ; \
> +	fi
> +
> +	$(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/usb \
> +		ALL_TARGETS="$(LINUX_TOOLS_USBTOOLS_LIST)" \
> +		$(USBTOOLS_MAKE_OPTS) \
> +		all
> +endef
> +
> +define USBTOOLS_INSTALL_TARGET_CMDS
> +	$(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/usb \
> +		ALL_TARGETS="$(LINUX_TOOLS_USBTOOLS_LIST)" \
> +		$(USBTOOLS_MAKE_OPTS) \
> +		DESTDIR=$(TARGET_DIR) \
> +		install
> +endef
> -- 
> 2.34.1
>
Luca Ceresoli March 29, 2023, 6:43 a.m. UTC | #3
Hi Yann,

On Tue, 28 Mar 2023 21:56:59 +0200
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> Luca, All,
> 
> On 2023-03-27 15:59 +0200, Luca Ceresoli spake thusly:
> > Extend the linux-tools package to also build the userspace USB tools, which
> > currently include testusb and ffs-test.
> > 
> > These tools are in the kernel tree since a long time, but a Makefile was
> > added only in 5.9 to allow building in the same way as other tools provided  
> 
> That is not entirely correct.
> 
> The Makefile itself has been present since 2.6.39, but indeed only
> gained an install rule for 5.9:
> 
>     4f22ce7045c1  2011-02-17  USB: tools: Add a Makefile
>     9ca325ffcac4  2020-08-19  tools: usb: move to tools buildsystem
> 
> So I've tweaked the commit log accordingly.

I think the original sentence somehow had the same meaning, even though
it would possibly take a lawyer to prove that... Your rewrite is way
more clear (and fun). Thanks!
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index b6d288c54fa9..67c6004ddf2e 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1874,6 +1874,7 @@  F:	configs/zynqmp_zcu106_defconfig
 F:	package/agentpp/
 F:	package/exim/
 F:	package/libpjsip/
+F:	package/linux-tools/linux-tool-usbtools.mk.in
 F:	package/qpid-proton/
 F:	package/rtl8188eu/
 F:	package/snmppp/
diff --git a/package/linux-tools/Config.in b/package/linux-tools/Config.in
index 8a0b6d5802cc..451b0eeff5bb 100644
--- a/package/linux-tools/Config.in
+++ b/package/linux-tools/Config.in
@@ -135,6 +135,32 @@  comment "selftests needs BR2_PACKAGE_BUSYBOX_SHOW_OTHERS and a toolchain w/ dyna
 	depends on !BR2_PACKAGE_BUSYBOX_SHOW_OTHERS || \
 		BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14
 
+config BR2_PACKAGE_LINUX_TOOLS_USBTOOLS
+	bool "USB test programs"
+	select BR2_PACKAGE_LINUX_TOOLS
+	help
+	  Build and install the USB test tools.
+
+	  These tools exist since Linux 2.6.35, but Buildroot can build
+	  them only with kernel versions 5.9 and later.
+
+if BR2_PACKAGE_LINUX_TOOLS_USBTOOLS
+
+config BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_TESTUSB
+	bool "testusb"
+	help
+	  testusb issues ioctls to perform the tests implemented by the
+	  kernel driver.  It can generate a variety of transfer
+	  patterns.
+
+	  See http://www.linux-usb.org/usbtest/
+
+config BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_FFSTEST
+	bool "ffs-test"
+	help
+	  User mode filesystem api for usb composite function
+endif
+
 config BR2_PACKAGE_LINUX_TOOLS_TMON
 	bool "tmon"
 	depends on BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/linux-tools/linux-tool-usbtools.mk.in b/package/linux-tools/linux-tool-usbtools.mk.in
new file mode 100644
index 000000000000..797758adce51
--- /dev/null
+++ b/package/linux-tools/linux-tool-usbtools.mk.in
@@ -0,0 +1,34 @@ 
+################################################################################
+#
+# usbtools
+#
+################################################################################
+
+LINUX_TOOLS += usbtools
+
+USBTOOLS_MAKE_OPTS = $(LINUX_MAKE_FLAGS) LDFLAGS="$(TARGET_LDFLAGS)"
+
+LINUX_TOOLS_USBTOOLS_LIST = \
+	$(if $(BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_TESTUSB),testusb) \
+	$(if $(BR2_PACKAGE_LINUX_TOOLS_USBTOOLS_FFSTEST),ffs-test)
+
+define USBTOOLS_BUILD_CMDS
+	$(Q)if ! grep install $(LINUX_DIR)/tools/usb/Makefile >/dev/null 2>&1 ; then \
+		echo "Your kernel version is too old to build the USB tools." ; \
+		echo "At least kernel 5.9 must be used." ; \
+		exit 1 ; \
+	fi
+
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/usb \
+		ALL_TARGETS="$(LINUX_TOOLS_USBTOOLS_LIST)" \
+		$(USBTOOLS_MAKE_OPTS) \
+		all
+endef
+
+define USBTOOLS_INSTALL_TARGET_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/usb \
+		ALL_TARGETS="$(LINUX_TOOLS_USBTOOLS_LIST)" \
+		$(USBTOOLS_MAKE_OPTS) \
+		DESTDIR=$(TARGET_DIR) \
+		install
+endef