diff mbox series

[RESEND,1/2] package/urandom-scripts: move to new package busybox-initscripts

Message ID 20230313081549.493823-2-michael@walle.cc
State New
Headers show
Series new package buildroot-initscripts | expand

Commit Message

Michael Walle March 13, 2023, 8:15 a.m. UTC
As a preparation to add new initscripts, rename the urandom-scripts
package to a more generic one and prepare the package to support more
than one initscript. This way we don't need one package per initscript.

Individual initscripts are chosen as a configuration option of the
package.

Signed-off-by: Michael Walle <michael@walle.cc>
---
 Config.in.legacy                                | 11 +++++++++++
 package/Config.in                               |  2 +-
 package/buildroot-initscripts/Config.in         | 17 +++++++++++++++++
 .../S20seedrng                                  |  0
 .../buildroot-initscripts.mk                    | 16 ++++++++++++++++
 package/urandom-scripts/Config.in               |  7 -------
 package/urandom-scripts/urandom-scripts.mk      | 12 ------------
 7 files changed, 45 insertions(+), 20 deletions(-)
 create mode 100644 package/buildroot-initscripts/Config.in
 rename package/{urandom-scripts => buildroot-initscripts}/S20seedrng (100%)
 create mode 100644 package/buildroot-initscripts/buildroot-initscripts.mk
 delete mode 100644 package/urandom-scripts/Config.in
 delete mode 100644 package/urandom-scripts/urandom-scripts.mk

Comments

Thomas Petazzoni March 13, 2023, 8:21 a.m. UTC | #1
On Mon, 13 Mar 2023 09:15:48 +0100
Michael Walle <michael@walle.cc> wrote:

> +config BR2_PACKAGE_URANDOM_SCRIPTS
> +	bool "urandom-initscripts package was renamed"
> +	select BR2_LEGACY
> +	select BR2_PACKAGE_BUILDROOT_INITSCRIPTS
> +	select BR2_PACKAGE_BUILDROOT_INITSCRIPTS_URANDOM

This is basically causing to cause the legacy warning to trigger for
virtually all configurations, as this package is enabled in basically
all non-systemd configurations.

It's a bit annoying :-/

One option would be to not have the "select BR2_LEGACY", which would
work OK because of the 2 selects that enable the new package. But
it would also mean that people will keep BR2_PACKAGE_URANDOM_SCRIPTS=y
in their .config forever.

I don't really have a good solution/idea here, just pointing out this
inconvenience.

Best regards,

Thomas
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 7f69462f2e..d82bd0f1f8 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -144,6 +144,17 @@  endif
 
 ###############################################################################
 
+comment "Legacy options removed in 2023.05"
+
+config BR2_PACKAGE_URANDOM_SCRIPTS
+	bool "urandom-initscripts package was renamed"
+	select BR2_LEGACY
+	select BR2_PACKAGE_BUILDROOT_INITSCRIPTS
+	select BR2_PACKAGE_BUILDROOT_INITSCRIPTS_URANDOM
+	help
+	  Package urandom-scripts was moved as option to
+	  package buildroot-initscripts.
+
 comment "Legacy options removed in 2023.02"
 
 config BR2_KERNEL_HEADERS_6_0
diff --git a/package/Config.in b/package/Config.in
index 7c32305129..df618c48cb 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2570,7 +2570,6 @@  menu "Security"
 	source "package/selinux-python/Config.in"
 	source "package/semodule-utils/Config.in"
 	source "package/setools/Config.in"
-	source "package/urandom-scripts/Config.in"
 endmenu
 
 menu "Shell and utilities"
@@ -2626,6 +2625,7 @@  menu "System tools"
 	source "package/audit/Config.in"
 	source "package/balena-engine/Config.in"
 	source "package/bubblewrap/Config.in"
+	source "package/buildroot-initscripts/Config.in"
 	source "package/cgroupfs-mount/Config.in"
 	source "package/circus/Config.in"
 	source "package/containerd/Config.in"
diff --git a/package/buildroot-initscripts/Config.in b/package/buildroot-initscripts/Config.in
new file mode 100644
index 0000000000..8e84e975fa
--- /dev/null
+++ b/package/buildroot-initscripts/Config.in
@@ -0,0 +1,17 @@ 
+config BR2_PACKAGE_BUILDROOT_INITSCRIPTS
+	bool "buildroot-initscripts"
+	default y if BR2_PACKAGE_INITSCRIPTS
+	depends on !BR2_PACKAGE_SYSTEMD
+	help
+	  Support for various initscripts.
+
+if BR2_PACKAGE_BUILDROOT_INITSCRIPTS
+
+config BR2_PACKAGE_BUILDROOT_INITSCRIPTS_URANDOM
+	bool "urandom"
+	default y if BR2_PACKAGE_INITSCRIPTS
+	depends on BR2_PACKAGE_BUSYBOX
+	help
+	  Initscript to preserve the random seed between reboots.
+
+endif
diff --git a/package/urandom-scripts/S20seedrng b/package/buildroot-initscripts/S20seedrng
similarity index 100%
rename from package/urandom-scripts/S20seedrng
rename to package/buildroot-initscripts/S20seedrng
diff --git a/package/buildroot-initscripts/buildroot-initscripts.mk b/package/buildroot-initscripts/buildroot-initscripts.mk
new file mode 100644
index 0000000000..098113bcbd
--- /dev/null
+++ b/package/buildroot-initscripts/buildroot-initscripts.mk
@@ -0,0 +1,16 @@ 
+################################################################################
+#
+# buildroot-initscripts
+#
+################################################################################
+
+BUILDROOT_INITSCRIPTS_SCRIPTS_$(BR2_PACKAGE_BUILDROOT_INITSCRIPTS_URANDOM) += S20seedrng
+
+define BUILDROOT_INITSCRIPTS_INSTALL_INIT_SYSV
+	for i in $(BUILDROOT_INITSCRIPTS_SCRIPTS_y); do \
+		$(INSTALL) -D -m 0755 $(BUILDROOT_INITSCRIPTS_PKGDIR)/$$i \
+			$(TARGET_DIR)/etc/init.d/$$i || exit 1; \
+	done
+endef
+
+$(eval $(generic-package))
diff --git a/package/urandom-scripts/Config.in b/package/urandom-scripts/Config.in
deleted file mode 100644
index 6b4a609f95..0000000000
--- a/package/urandom-scripts/Config.in
+++ /dev/null
@@ -1,7 +0,0 @@ 
-config BR2_PACKAGE_URANDOM_SCRIPTS
-	bool "urandom-initscripts"
-	default y if BR2_PACKAGE_INITSCRIPTS
-	depends on BR2_PACKAGE_BUSYBOX
-	depends on !BR2_PACKAGE_SYSTEMD
-	help
-	  Initscript to preserve the random seed between reboots.
diff --git a/package/urandom-scripts/urandom-scripts.mk b/package/urandom-scripts/urandom-scripts.mk
deleted file mode 100644
index 32f3e09343..0000000000
--- a/package/urandom-scripts/urandom-scripts.mk
+++ /dev/null
@@ -1,12 +0,0 @@ 
-################################################################################
-#
-# urandom-scripts
-#
-################################################################################
-
-define URANDOM_SCRIPTS_INSTALL_INIT_SYSV
-	$(INSTALL) -D -m 0755 $(URANDOM_SCRIPTS_PKGDIR)/S20seedrng \
-		$(TARGET_DIR)/etc/init.d/S20seedrng
-endef
-
-$(eval $(generic-package))